mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: jacal: Update to 1c7.
* gnu/packages/patches/jacal-fix-texinfo.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Delete this. * gnu/packages/maths.scm (jacal)[source]: Delete this patch. [version]: Update to 1c7. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
This commit is contained in:
parent
c8512d8443
commit
d0744d8650
3 changed files with 4 additions and 98 deletions
|
@ -1298,7 +1298,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
|
||||
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
|
||||
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
|
||||
%D%/packages/patches/jacal-fix-texinfo.patch \
|
||||
%D%/packages/patches/jami-fix-crash-on-quit.patch \
|
||||
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
|
||||
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
|
||||
|
|
|
@ -5789,15 +5789,14 @@ (define-public reducelcs
|
|||
(define-public jacal
|
||||
(package
|
||||
(name "jacal")
|
||||
(version "1c4")
|
||||
(version "1c7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"http://groups.csail.mit.edu/mac/ftpdir/scm/jacal-"
|
||||
version ".zip"))
|
||||
(sha256 (base32
|
||||
"055zrn12a1dmy0dqkwrkq3fklbhg3yir6vn0lacp4mvbg8573a3q"))
|
||||
(patches (search-patches "jacal-fix-texinfo.patch"))))
|
||||
(sha256
|
||||
(base32 "06a5sx9ikd62bpnd898g3yk818b020b1a27mk7dbfla2zizib4xz"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
@ -5823,7 +5822,7 @@ (define-public jacal
|
|||
(chmod wrapper #o555))))
|
||||
(replace 'configure
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(invoke "./configure"
|
||||
(invoke "sh" "configure"
|
||||
(string-append "--prefix="
|
||||
(assoc-ref outputs "out"))))))))
|
||||
(inputs (list scm))
|
||||
|
|
|
@ -1,92 +0,0 @@
|
|||
Fix the broken Texinfo in the Jacal package documentation
|
||||
|
||||
--- jacal/jacal.texi,orig 2017-02-23 20:35:55.303980444 +0100
|
||||
+++ jacal/jacal.texi 2017-02-23 20:53:14.539024674 +0100
|
||||
@@ -343,7 +343,7 @@
|
||||
|
||||
With the standard input grammar, the precedence of @samp{-} as a prefix
|
||||
behaves strangely. @code{a^-b*c} becomes @code{a^(-b*c)} while
|
||||
-@code{@result{a^b*c} (a^b)*c}.
|
||||
+@code{a^b*c @result{} (a^b)*c}.
|
||||
|
||||
Using @code{divide} to divide a polynomial by an integer does not work.
|
||||
|
||||
@@ -675,8 +675,9 @@
|
||||
e1: ---------
|
||||
a
|
||||
@end example
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Command suchthat var exp
|
||||
+@deffn Command suchthat var exp
|
||||
|
||||
If an expression rather than an equation is given to @code{suchthat}, it
|
||||
is as though the equation @code{@var{exp}=0} was given.
|
||||
@@ -688,8 +689,9 @@
|
||||
e2: ---------
|
||||
a
|
||||
@end example
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Operator | var exp_or_eqn
|
||||
+@deffn Operator | var exp_or_eqn
|
||||
|
||||
An alternative infix notation is also available for @code{suchthat}.
|
||||
|
||||
@@ -857,8 +859,9 @@
|
||||
|
||||
Returns the degree of polynomial or equation @var{poly} in variable
|
||||
@var{var}.
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Operator degree poly
|
||||
+@deffn Operator degree poly
|
||||
|
||||
Returns the total-degree, the degree of its highest degree monomial,
|
||||
of polynomial or equation @var{poly}.
|
||||
@@ -1016,10 +1019,12 @@
|
||||
Returns @var{poly1} reduced with respect to @var{poly2} (or @var{eqn})
|
||||
and @var{var}. If @var{poly2} is univariate, the third argument is not
|
||||
needed.
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Command mod poly1 n
|
||||
+@deffn Command mod poly1 n
|
||||
Returns @var{poly1} with all the coefficients taken modulo @var{n}.
|
||||
-@deffnx Command mod poly1
|
||||
+@end deffn
|
||||
+@deffn Command mod poly1
|
||||
Returns @var{poly1} with all the coefficients taken modulo the
|
||||
current modulus.
|
||||
|
||||
@@ -1220,8 +1225,9 @@
|
||||
e1: -1 2 3 5
|
||||
@end group
|
||||
@end example
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Command factor polyratio
|
||||
+@deffn Command factor polyratio
|
||||
Given a univariate ratio of polynomials @var{polyratio}, returns a
|
||||
matrix of factors and exponents.
|
||||
|
||||
@@ -2028,7 +2034,7 @@
|
||||
formed from the pair-wise products of components of the inputs. For
|
||||
example, for the input tensors @code{x[a,b]} and @code{y[c]}
|
||||
@example
|
||||
-@result{z:tmult(x,y);} z[a,b,c] = x[a,b]*y[c]
|
||||
+z:tmult(x,y); @result{} z[a,b,c] = x[a,b]*y[c]
|
||||
@end example
|
||||
|
||||
With an additional argument, @code{tmult} will produce the inner product
|
||||
@@ -2464,8 +2470,9 @@
|
||||
If you do not wish to return to Jacal but really want to terminate the
|
||||
session and return to the operating system, then after typing
|
||||
@code{qed();}, type @code{(slib:exit)} or use @code{quit}.
|
||||
+@end deffn
|
||||
|
||||
-@deffnx Command quit
|
||||
+@deffn Command quit
|
||||
Exit directly from Jacal to the operating system. You will not be able
|
||||
to continue your Jacal session.
|
||||
|
Loading…
Reference in a new issue