mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: strace: Update to 5.3.
* gnu/packages/patches/strace-ipc-tests.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/linux.scm (strace): Update to 5.3. [source](patches): Remove. [arguments]: Remove obsolete phase.
This commit is contained in:
parent
f8026a797c
commit
d1eb423478
3 changed files with 3 additions and 44 deletions
|
@ -1327,7 +1327,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
|
||||
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
|
||||
%D%/packages/patches/steghide-fixes.patch \
|
||||
%D%/packages/patches/strace-ipc-tests.patch \
|
||||
%D%/packages/patches/streamlink-update-test.patch \
|
||||
%D%/packages/patches/stumpwm-fix-broken-read-one-line.patch \
|
||||
%D%/packages/patches/supercollider-boost-1.70-build-fix.patch \
|
||||
|
|
|
@ -1459,18 +1459,15 @@ (define-public zerofree
|
|||
(define-public strace
|
||||
(package
|
||||
(name "strace")
|
||||
(version "5.2")
|
||||
(version "5.3")
|
||||
(home-page "https://strace.io")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append home-page "/files/" version
|
||||
"/strace-" version ".tar.xz"))
|
||||
;; XXX Remove the 'regenerate-tests' phase below when
|
||||
;; "strace-ipc-tests.patch" is no longer applied.
|
||||
(patches (search-patches "strace-ipc-tests.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1li49i75wrdw91hchyyd8spnzfcmxcfyfb5g9zbaza89aq4bq4ym"))))
|
||||
"0ix06z4vnc49mv76f22kixz8dsh7daqv9mpgwcgl0mlnfjc124vc"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases
|
||||
|
@ -1479,14 +1476,7 @@ (define-public strace
|
|||
(lambda _
|
||||
(substitute* "strace.c"
|
||||
(("/bin/sh") (which "sh")))
|
||||
#t))
|
||||
(add-before 'configure 'regenerate-tests
|
||||
;; XXX Remove this phase when "strace-ipc-tests.patch" is no longer
|
||||
;; applied in the 'source' field above. This phase is needed to
|
||||
;; regenerate many other files from tests/gen_tests.in, which is
|
||||
;; modified by the aforementioned patch.
|
||||
(lambda _
|
||||
(invoke "tests/gen_tests.sh"))))
|
||||
#t)))
|
||||
;; Don't fail if the architecture doesn't support different personalities.
|
||||
#:configure-flags '("--enable-mpers=check")
|
||||
;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32459>.
|
||||
|
|
|
@ -1,30 +0,0 @@
|
|||
Fix a test failure on some systems.
|
||||
|
||||
Taken from upstream:
|
||||
https://github.com/strace/strace/commit/4377e3a1535a0ec3a42da8a1366ad6943f4efa0e
|
||||
|
||||
diff --git a/tests/gen_tests.in b/tests/gen_tests.in
|
||||
index 4a506b94c..4fdf4722c 100644
|
||||
--- a/tests/gen_tests.in
|
||||
+++ b/tests/gen_tests.in
|
||||
@@ -168,16 +168,16 @@ ipc_msg-Xabbrev +ipc.sh -Xabbrev -a26
|
||||
ipc_msg-Xraw +ipc.sh -Xraw -a16
|
||||
ipc_msg-Xverbose +ipc.sh -Xverbose -a34
|
||||
ipc_msgbuf-Xabbrev +ipc_msgbuf.test -Xabbrev
|
||||
-ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a22
|
||||
+ipc_msgbuf-Xraw +ipc_msgbuf.test -Xraw -a20
|
||||
ipc_msgbuf-Xverbose +ipc_msgbuf.test -Xverbose
|
||||
ipc_sem +ipc.sh -a29
|
||||
ipc_sem-Xabbrev +ipc.sh -Xabbrev -a29
|
||||
ipc_sem-Xraw +ipc.sh -Xraw -a19
|
||||
ipc_sem-Xverbose +ipc.sh -Xverbose -a36
|
||||
-ipc_shm +ipc.sh -a29
|
||||
-ipc_shm-Xabbrev +ipc.sh -Xabbrev -a29
|
||||
+ipc_shm +ipc.sh -a26
|
||||
+ipc_shm-Xabbrev +ipc.sh -Xabbrev -a26
|
||||
ipc_shm-Xraw +ipc.sh -Xraw -a19
|
||||
-ipc_shm-Xverbose +ipc.sh -Xverbose -a36
|
||||
+ipc_shm-Xverbose +ipc.sh -Xverbose -a34
|
||||
kcmp -a22
|
||||
kcmp-y -a22 -y -e trace=kcmp
|
||||
kern_features -a16
|
Loading…
Reference in a new issue