mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: emacs-telega: Patch to use telega-server from Guix.
* gnu/packages/patches/emacs-telega-patch-server-functions.patch: New file. * gnu/local.mk (dist_patch_DATA): Reference new patch. * gnu/packages/emacs-xyz.scm (emacs-telega)[source]: Use new patch, bump revision.
This commit is contained in:
parent
1a1369dc3d
commit
d4b02a6fba
3 changed files with 36 additions and 2 deletions
|
@ -916,6 +916,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
|
||||
%D%/packages/patches/emacs-scheme-complete-scheme-r5rs-info.patch \
|
||||
%D%/packages/patches/emacs-source-date-epoch.patch \
|
||||
%D%/packages/patches/emacs-telega-patch-server-functions.patch \
|
||||
%D%/packages/patches/emacs-telega-test-env.patch \
|
||||
%D%/packages/patches/emacs-undohist-ignored.patch \
|
||||
%D%/packages/patches/emacs-wordnut-require-adaptive-wrap.patch \
|
||||
|
|
|
@ -22266,7 +22266,7 @@ (define-public emacs-telega
|
|||
;; Get the current version from `telega-version` in telega.el.
|
||||
;; or by running M-x telega-version.
|
||||
(let ((commit "5c39c3a81e48222911db75ae30e5a8f8fa34efb5")
|
||||
(revision "1")
|
||||
(revision "2")
|
||||
(version "0.6.27"))
|
||||
(package
|
||||
(name "emacs-telega")
|
||||
|
@ -22280,7 +22280,9 @@ (define-public emacs-telega
|
|||
(sha256
|
||||
(base32
|
||||
"0wyycgsb1ja73phs9a2dgi50m2p6sdvx3xdwclfyijx4hzwlv233"))
|
||||
(patches (search-patches "emacs-telega-test-env.patch"))
|
||||
(patches (search-patches
|
||||
"emacs-telega-patch-server-functions.patch"
|
||||
"emacs-telega-test-env.patch"))
|
||||
(file-name (git-file-name name version))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
|
|
|
@ -0,0 +1,31 @@
|
|||
Remove interactive build for telega-server, as it fails on Guix.
|
||||
Modify the `telega-server--find-bin' function to only use the version
|
||||
of telega-server installed by Guix.
|
||||
|
||||
Created by Brett Gilio <brettg@gnu.org>
|
||||
|
||||
--- a/telega-server.el
|
||||
+++ b/telega-server.el
|
||||
@@ -113,7 +113,6 @@ If already deferring, then just executes the BODY."
|
||||
If BUILD-FLAGS is specified, then rebuild server without any
|
||||
queries using this flags for building, could be empty string.
|
||||
Otherwise query user about building flags."
|
||||
- (interactive)
|
||||
(telega-test-env 'quiet)
|
||||
(when (or build-flags
|
||||
(y-or-n-p "Build `telega-server'? "))
|
||||
@@ -137,11 +136,8 @@ Otherwise query user about building flags."
|
||||
(defun telega-server--find-bin ()
|
||||
"Find telega-server executable.
|
||||
Raise error if not found."
|
||||
- (let ((exec-path (cons telega-directory exec-path)))
|
||||
- (or (executable-find "telega-server")
|
||||
- (progn (telega-server-build)
|
||||
- (executable-find "telega-server"))
|
||||
- (error "`telega-server' not found in exec-path"))))
|
||||
+ (or (executable-find "telega-server")
|
||||
+ (error "`telega-server' not found in exec-path")))
|
||||
|
||||
(defun telega-server-version ()
|
||||
"Return telega-server version."
|
||||
|
Loading…
Reference in a new issue