mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 23:32:24 -05:00
gnu: diffoscope: Update to use python-magic.
Fixes: https://salsa.debian.org/reproducible-builds/diffoscope/-/issues/238 * gnu/packages/patches/diffoscope-revert-to-magic-open.patch: Remove file. * gnu/local.mk [dist_patch_DATA]: Update. * gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch. [inputs]: Remove python-file.
This commit is contained in:
parent
e69f2e9add
commit
d588cc8fa9
3 changed files with 1 additions and 75 deletions
|
@ -927,7 +927,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/desmume-gcc6-fixes.patch \
|
||||
%D%/packages/patches/desmume-gcc7-fixes.patch \
|
||||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||
%D%/packages/patches/diffoscope-revert-to-magic-open.patch \
|
||||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \
|
||||
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
|
||||
|
|
|
@ -81,9 +81,7 @@ (define-public diffoscope
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"0vc4a38ii6b10af4c7cxfkvj4lk4ihx1xs4q5lshnkyg74gmm21b"))
|
||||
(patches (search-patches
|
||||
"diffoscope-revert-to-magic-open.patch"))))
|
||||
"0vc4a38ii6b10af4c7cxfkvj4lk4ihx1xs4q5lshnkyg74gmm21b"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:phases (modify-phases %standard-phases
|
||||
|
@ -137,7 +135,6 @@ (define-public diffoscope
|
|||
(install-file "doc/diffoscope.1" man)
|
||||
#t))))))
|
||||
(inputs `(("rpm" ,rpm) ;for rpm-python
|
||||
("python-file" ,python-file)
|
||||
("python-debian" ,python-debian)
|
||||
("python-libarchive-c" ,python-libarchive-c)
|
||||
("python-magic" ,python-magic)
|
||||
|
|
|
@ -1,70 +0,0 @@
|
|||
From b658c3a6819ccb9a104b13e973132c66f0965965 Mon Sep 17 00:00:00 2001
|
||||
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
|
||||
Date: Thu, 11 Feb 2021 17:28:21 -0800
|
||||
Subject: [PATCH] Revert "Prefer to use magic.Magic over the magic.open
|
||||
compatibility interface. (Closes: reproducible-builds/diffoscope#236)"
|
||||
|
||||
This reverts commit c72c30f29ea3760eb4c785644dc7cd4c26833740.
|
||||
---
|
||||
diffoscope/comparators/utils/file.py | 28 ++++++++++++++--------------
|
||||
1 file changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/diffoscope/comparators/utils/file.py b/diffoscope/comparators/utils/file.py
|
||||
index fb3b4316..32700f02 100644
|
||||
--- a/diffoscope/comparators/utils/file.py
|
||||
+++ b/diffoscope/comparators/utils/file.py
|
||||
@@ -65,37 +65,37 @@ def _run_tests(fold, tests):
|
||||
|
||||
|
||||
class File(metaclass=abc.ABCMeta):
|
||||
- if hasattr(magic, "Magic"): # use python-magic
|
||||
+ if hasattr(magic, "open"): # use Magic-file-extensions from file
|
||||
|
||||
@classmethod
|
||||
def guess_file_type(cls, path):
|
||||
if not hasattr(cls, "_mimedb"):
|
||||
- cls._mimedb = magic.Magic()
|
||||
- return maybe_decode(cls._mimedb.from_file(path))
|
||||
+ cls._mimedb = magic.open(magic.NONE)
|
||||
+ cls._mimedb.load()
|
||||
+ return cls._mimedb.file(
|
||||
+ path.encode("utf-8", errors="surrogateescape")
|
||||
+ )
|
||||
|
||||
@classmethod
|
||||
def guess_encoding(cls, path):
|
||||
if not hasattr(cls, "_mimedb_encoding"):
|
||||
- cls._mimedb_encoding = magic.Magic(mime_encoding=True)
|
||||
- return maybe_decode(cls._mimedb_encoding.from_file(path))
|
||||
+ cls._mimedb_encoding = magic.open(magic.MAGIC_MIME_ENCODING)
|
||||
+ cls._mimedb_encoding.load()
|
||||
+ return cls._mimedb_encoding.file(path)
|
||||
|
||||
- else: # use Magic-file-extensions from file
|
||||
+ else: # use python-magic
|
||||
|
||||
@classmethod
|
||||
def guess_file_type(cls, path):
|
||||
if not hasattr(cls, "_mimedb"):
|
||||
- cls._mimedb = magic.open(magic.NONE)
|
||||
- cls._mimedb.load()
|
||||
- return cls._mimedb.file(
|
||||
- path.encode("utf-8", errors="surrogateescape")
|
||||
- )
|
||||
+ cls._mimedb = magic.Magic()
|
||||
+ return maybe_decode(cls._mimedb.from_file(path))
|
||||
|
||||
@classmethod
|
||||
def guess_encoding(cls, path):
|
||||
if not hasattr(cls, "_mimedb_encoding"):
|
||||
- cls._mimedb_encoding = magic.open(magic.MAGIC_MIME_ENCODING)
|
||||
- cls._mimedb_encoding.load()
|
||||
- return cls._mimedb_encoding.file(path)
|
||||
+ cls._mimedb_encoding = magic.Magic(mime_encoding=True)
|
||||
+ return maybe_decode(cls._mimedb_encoding.from_file(path))
|
||||
|
||||
def __init__(self, container=None):
|
||||
self._comments = []
|
||||
--
|
||||
2.30.0
|
||||
|
Loading…
Reference in a new issue