mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: aws-c-mqtt: Replace patch.
* gnu/packages/c.scm (aws-c-mqtt): Replace patch. [arguments]: Fix CMAKE_PREFIX_PATH. [source]: Remove patch. * gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch: Delete file. * gnu/local.mk: Remove it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
2d61354788
commit
d5c9f52a37
3 changed files with 5 additions and 17 deletions
|
@ -872,7 +872,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||||
%D%/packages/patches/aws-c-auth-install-private-headers.patch \
|
%D%/packages/patches/aws-c-auth-install-private-headers.patch \
|
||||||
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
|
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
|
||||||
%D%/packages/patches/aws-c-mqtt-cmake-prefix.patch \
|
|
||||||
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
||||||
%D%/packages/patches/aws-crt-cpp-cmake-prefix.patch \
|
%D%/packages/patches/aws-crt-cpp-cmake-prefix.patch \
|
||||||
%D%/packages/patches/aws-crt-cpp-disable-networking-tests.patch \
|
%D%/packages/patches/aws-crt-cpp-disable-networking-tests.patch \
|
||||||
|
|
|
@ -846,6 +846,7 @@ (define-public aws-c-s3
|
||||||
(define-public aws-c-mqtt
|
(define-public aws-c-mqtt
|
||||||
(package
|
(package
|
||||||
(name "aws-c-mqtt")
|
(name "aws-c-mqtt")
|
||||||
|
; Update only when updating aws-crt-cpp.
|
||||||
(version "0.7.8")
|
(version "0.7.8")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method git-fetch)
|
(method git-fetch)
|
||||||
|
@ -855,12 +856,13 @@ (define-public aws-c-mqtt
|
||||||
(file-name (git-file-name name version))
|
(file-name (git-file-name name version))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"19j6nw2v36c4yff4p0fbf0748s06fd5r9cp2yakry9ybn1ada99c"))
|
"19j6nw2v36c4yff4p0fbf0748s06fd5r9cp2yakry9ybn1ada99c"))))
|
||||||
(patches (search-patches "aws-c-mqtt-cmake-prefix.patch"))))
|
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags
|
'(#:configure-flags
|
||||||
'("-DBUILD_SHARED_LIBS=ON")))
|
(list "-DBUILD_SHARED_LIBS=ON"
|
||||||
|
(string-append "-DCMAKE_PREFIX_PATH="
|
||||||
|
(assoc-ref %build-inputs "aws-c-common")))))
|
||||||
(propagated-inputs
|
(propagated-inputs
|
||||||
`(("aws-c-http" ,aws-c-http)
|
`(("aws-c-http" ,aws-c-http)
|
||||||
("aws-c-io" ,aws-c-io)))
|
("aws-c-io" ,aws-c-io)))
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -7,6 +7,10 @@ if (POLICY CMP0069)
|
|
||||||
cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
|
|
||||||
endif()
|
|
||||||
|
|
||||||
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
|
||||||
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
|
||||||
+endif()
|
|
||||||
+
|
|
||||||
if (DEFINED CMAKE_PREFIX_PATH)
|
|
||||||
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
|
||||||
endif()
|
|
Loading…
Reference in a new issue