gnu: erlang: Fix build.

* gnu/packages/patches/erlang-man-path.patch: Adjust patch.

Change-Id: I2531c92001a3b1c2a3363615a7a1542904fa98b7
Signed-off-by: Andrew Tropin <andrew@trop.in>
This commit is contained in:
Igor Goryachev via Guix-patches via 2024-09-19 19:39:11 +03:00 committed by Andrew Tropin
parent d600adbca6
commit d6211bd0c1
No known key found for this signature in database
GPG key ID: 2208D20958C1DEB0

View file

@ -9,10 +9,10 @@ as other man pages.)
--- a/erts/etc/common/erlexec.c
+++ b/erts/etc/common/erlexec.c
@@ -709,8 +709,10 @@
error("-man not supported on Windows");
#else
argv[i] = "man";
@@ -728,8 +728,10 @@ int main(int argc, char **argv)
break;
}
}
- erts_snprintf(tmpStr, sizeof(tmpStr), "%s/man", rootdir);
- set_env("MANPATH", tmpStr);
+ /*