mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: netsurf: Update to 3.7.
For compatibility, dependents must be updated at the same time. * gnu/packages/web.scm (libcss): Update to 0.7.0 (nsgenbind): Update to 0.5. (netsurf): Update to 3.7. [arguments]: Fix binary name in .desktop. Adjust "docs" directory name. * gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source.
This commit is contained in:
parent
772588bd22
commit
d8799bd0df
2 changed files with 25 additions and 40 deletions
|
@ -28,37 +28,22 @@ Work around upstream's lack of a pkg-config file and update API.
|
|||
|
||||
#include "utils/errors.h"
|
||||
#include "utils/idna.h"
|
||||
@@ -250,7 +250,7 @@
|
||||
return NSERROR_NOMEM;
|
||||
}
|
||||
--- netsurf-3.7/test/Makefile 2017-10-15 08:39:24.000000000 -0500
|
||||
+++ netsurf-3.7/test/Makefile 2017-11-05 11:14:46.219013218 -0600
|
||||
@@ -139,14 +139,14 @@
|
||||
-D_XOPEN_SOURCE=600 \
|
||||
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
|
||||
-Dnsgtk \
|
||||
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
|
||||
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
|
||||
$(LIB_CFLAGS)
|
||||
TESTCFLAGS := $(BASE_TESTCFLAGS) \
|
||||
$(COV_CFLAGS) \
|
||||
$(COV_CPPFLAGS)
|
||||
|
||||
- nfc_size = utf8proc_normalise(nfc_label, nfc_size,
|
||||
+ nfc_size = utf8proc_normalize_utf32(nfc_label, nfc_size,
|
||||
UTF8PROC_STABLE | UTF8PROC_COMPOSE);
|
||||
if (nfc_size < 0) {
|
||||
return NSERROR_NOMEM;
|
||||
@@ -565,7 +565,7 @@
|
||||
}
|
||||
|
||||
/* Perform NFC normalisation */
|
||||
- ucs4_len = utf8proc_normalise(ucs4, u_ucs4_len,
|
||||
+ ucs4_len = utf8proc_normalize_utf32(ucs4, u_ucs4_len,
|
||||
UTF8PROC_STABLE | UTF8PROC_COMPOSE);
|
||||
if (ucs4_len < 0) {
|
||||
free(ucs4);
|
||||
--- netsurf-3.6/test/Makefile
|
||||
+++ netsurf-3.6/test/Makefile
|
||||
@@ -112,11 +112,11 @@
|
||||
-D_XOPEN_SOURCE=600 \
|
||||
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
|
||||
-Dnsgtk \
|
||||
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) \
|
||||
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libidn) \
|
||||
$(LIB_CFLAGS) \
|
||||
$(COV_CFLAGS)
|
||||
|
||||
-TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) -lz \
|
||||
+TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libidn) -lz -lutf8proc \
|
||||
$(LIB_LDFLAGS)\
|
||||
$(COV_LDFLAGS)
|
||||
TESTLDFLAGS := -L$(TESTROOT) \
|
||||
- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
|
||||
+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
|
||||
$(LIB_LDFLAGS)\
|
||||
$(COV_LDFLAGS)
|
||||
|
||||
|
|
|
@ -4340,7 +4340,7 @@ (define-public libwapcaplet
|
|||
(define-public libcss
|
||||
(package
|
||||
(name "libcss")
|
||||
(version "0.6.0")
|
||||
(version "0.7.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -4348,7 +4348,7 @@ (define-public libcss
|
|||
name "-" version "-src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0qp4p1q1dwgdra4pkrzd081zjzisxkgwx650ijx323j8bj725daf"))))
|
||||
"16mns3h8vj7iw8myvgnw58q84irvbjlvfkxh8mdw6fbkjvaa7cnz"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("netsurf-buildsystem" ,netsurf-buildsystem)
|
||||
|
@ -4527,7 +4527,7 @@ (define-public libnspsl
|
|||
(define-public nsgenbind
|
||||
(package
|
||||
(name "nsgenbind")
|
||||
(version "0.4")
|
||||
(version "0.5")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -4535,7 +4535,7 @@ (define-public nsgenbind
|
|||
name "-" version "-src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"078gpbfcs96bgcba0ygha0ph9jzqr6ry5s3a8p6sl61px2908s66"))))
|
||||
"1iwjpdaan0njlhb9ir6a2q5vpxfmkqfldkvnqszqdz50b44vd1jv"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("netsurf-buildsystem" ,netsurf-buildsystem)
|
||||
|
@ -4555,7 +4555,7 @@ (define-public nsgenbind
|
|||
(define-public netsurf
|
||||
(package
|
||||
(name "netsurf")
|
||||
(version "3.6")
|
||||
(version "3.7")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -4563,7 +4563,7 @@ (define-public netsurf
|
|||
"releases/source/netsurf-" version "-src.tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"174sjx0566agckwmlj4w2cip5qbxdiafyhlp185a1qprxx84pbjr"))
|
||||
"05kynfzzwd4fc03vbqdjpghh5xnk2yrh43w7vikak89vla30mhpg"))
|
||||
(patches (search-patches "netsurf-system-utf8proc.patch"
|
||||
"netsurf-y2038-tests.patch"
|
||||
"netsurf-longer-test-timeout.patch"))))
|
||||
|
@ -4652,10 +4652,10 @@ (define-public netsurf
|
|||
(copy-file "frontends/gtk/res/netsurf-gtk.desktop"
|
||||
desktop)
|
||||
(substitute* desktop
|
||||
(("netsurf-gtk") (string-append out "/bin/netsurf"))
|
||||
(("netsurf-gtk") (string-append out "/bin/netsurf-gtk"))
|
||||
(("netsurf.png") (string-append out "/share/netsurf/"
|
||||
"netsurf.xpm")))
|
||||
(install-file "Docs/netsurf-gtk.1"
|
||||
(install-file "docs/netsurf-gtk.1"
|
||||
(string-append out "/share/man/man1/"))
|
||||
#t))))))
|
||||
(home-page "http://www.netsurf-browser.org")
|
||||
|
|
Loading…
Reference in a new issue