mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: kiwix-desktop: Update to 2.3.1.
* gnu/packages/web.scm (kiwix-desktop): Update to 2.3.1. * gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Signed-off-by: Christopher Baines <mail@cbaines.net>
This commit is contained in:
parent
3fef73ed03
commit
d953a1e5d6
3 changed files with 44 additions and 2 deletions
|
@ -1477,6 +1477,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/kio-search-smbd-on-PATH.patch \
|
||||
%D%/packages/patches/kismet-unbundle-boost.patch \
|
||||
%D%/packages/patches/kitty-fix-wayland-protocols.patch \
|
||||
%D%/packages/patches/kiwix-desktop-newer-libkiwix.patch \
|
||||
%D%/packages/patches/kmod-module-directory.patch \
|
||||
%D%/packages/patches/kmscon-runtime-keymap-switch.patch \
|
||||
%D%/packages/patches/kobodeluxe-paths.patch \
|
||||
|
|
40
gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
Normal file
40
gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
Description: Fix building kiwix-desktop with libkiwix-12.1.0
|
||||
Bug: https://github.com/kiwix/kiwix-desktop/issues/964
|
||||
Origin: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
|
||||
Applied-Upstream: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
|
||||
---
|
||||
From 1b322d8f01c787846546a6473f153cf1daa41e65 Mon Sep 17 00:00:00 2001
|
||||
From: Matthieu Gautier <mgautier@kymeria.fr>
|
||||
Date: Thu, 9 Feb 2023 09:47:47 +0100
|
||||
Subject: [PATCH] With last version of libkiwix, Downloader now return
|
||||
shared_ptr<Download>.
|
||||
|
||||
---
|
||||
src/contentmanager.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/contentmanager.cpp b/src/contentmanager.cpp
|
||||
index c2f4ff9..d4db50a 100644
|
||||
--- a/src/contentmanager.cpp
|
||||
+++ b/src/contentmanager.cpp
|
||||
@@ -173,7 +173,7 @@ QStringList ContentManager::updateDownloadInfos(QString id, const QStringList &k
|
||||
return values;
|
||||
}
|
||||
auto& b = mp_library->getBookById(id);
|
||||
- kiwix::Download* d;
|
||||
+ std::shared_ptr<kiwix::Download> d;
|
||||
try {
|
||||
d = mp_downloader->getDownload(b.getDownloadId());
|
||||
} catch(...) {
|
||||
@@ -270,7 +270,7 @@ QString ContentManager::downloadBook(const QString &id)
|
||||
for (auto b : booksList)
|
||||
if (b.toStdString() == book.getId())
|
||||
return "";
|
||||
- kiwix::Download *download;
|
||||
+ std::shared_ptr<kiwix::Download> download;
|
||||
try {
|
||||
std::pair<std::string, std::string> downloadDir("dir", downloadPath.toStdString());
|
||||
const std::vector<std::pair<std::string, std::string>> options = { downloadDir };
|
||||
--
|
||||
2.41.0
|
||||
|
|
@ -8786,7 +8786,7 @@ (define-public kiwix-lib
|
|||
(define-public kiwix-desktop
|
||||
(package
|
||||
(name "kiwix-desktop")
|
||||
(version "2.2.2")
|
||||
(version "2.3.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -8795,7 +8795,8 @@ (define-public kiwix-desktop
|
|||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ani12d91azcwwys499848ws7rx0m7c23nalcm5fanjak76bg6n6"))))
|
||||
"0hlk05gcb3fmnxhwj6gan51v98rdq3iv2lklwbpmm1bazmz8i7br"))
|
||||
(patches (search-patches "kiwix-desktop-newer-libkiwix.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
|
|
Loading…
Reference in a new issue