mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: lightdm: Apply patch to fix a problem with VNC integration.
* gnu/packages/patches/lightdm-vncserver-check.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/display-managers.scm (lightdm): Apply it.
This commit is contained in:
parent
0e76781df4
commit
da3c784c68
3 changed files with 71 additions and 3 deletions
|
@ -1360,6 +1360,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/librime-fix-build-with-gcc10.patch \
|
||||
%D%/packages/patches/libvirt-add-install-prefix.patch \
|
||||
%D%/packages/patches/libziparchive-add-includes.patch \
|
||||
%D%/packages/patches/lightdm-vncserver-check.patch \
|
||||
%D%/packages/patches/localed-xorg-keyboard.patch \
|
||||
%D%/packages/patches/kdiagram-Fix-missing-link-libraries.patch \
|
||||
%D%/packages/patches/kiki-level-selection-crash.patch \
|
||||
|
|
|
@ -268,7 +268,8 @@ (define-public lightdm
|
|||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1wr60c946p8jz9kb8zi4cd8d4mkcy7infbvlfzwajiglc22nblxn"))))
|
||||
"1wr60c946p8jz9kb8zi4cd8d4mkcy7infbvlfzwajiglc22nblxn"))
|
||||
(patches (search-patches "lightdm-vncserver-check.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:parallel-tests? #f ; fails when run in parallel
|
||||
|
@ -303,8 +304,8 @@ (define-public lightdm
|
|||
(unsetenv "LC_ALL"))))))
|
||||
(inputs
|
||||
(list audit
|
||||
bash-minimal ;for cross-compilation
|
||||
coreutils-minimal ;ditto
|
||||
bash-minimal ;for cross-compilation
|
||||
coreutils-minimal ;ditto
|
||||
linux-pam
|
||||
shadow ;for sbin/nologin
|
||||
libgcrypt
|
||||
|
|
66
gnu/packages/patches/lightdm-vncserver-check.patch
Normal file
66
gnu/packages/patches/lightdm-vncserver-check.patch
Normal file
|
@ -0,0 +1,66 @@
|
|||
Honor the Xvnc command specified in the config instead of using a hard-coded
|
||||
default.
|
||||
|
||||
Submitted upstream at: https://github.com/canonical/lightdm/pull/265
|
||||
|
||||
diff --git a/src/lightdm.c b/src/lightdm.c
|
||||
index 74f9ff2d..0ccfcd78 100644
|
||||
--- a/src/lightdm.c
|
||||
+++ b/src/lightdm.c
|
||||
@@ -349,27 +349,42 @@ start_display_manager (void)
|
||||
/* Start the VNC server */
|
||||
if (config_get_boolean (config_get_instance (), "VNCServer", "enabled"))
|
||||
{
|
||||
- g_autofree gchar *path = g_find_program_in_path ("Xvnc");
|
||||
- if (path)
|
||||
+ /* Validate that a the VNC command is available. */
|
||||
+ g_autofree gchar *command = config_get_string (config_get_instance (), "VNCServer", "command");
|
||||
+ if (command)
|
||||
{
|
||||
- vnc_server = vnc_server_new ();
|
||||
- if (config_has_key (config_get_instance (), "VNCServer", "port"))
|
||||
+ g_auto(GStrv) tokens = g_strsplit (command, " ", 2);
|
||||
+ if (!g_find_program_in_path (tokens[0]))
|
||||
{
|
||||
- gint port = config_get_integer (config_get_instance (), "VNCServer", "port");
|
||||
- if (port > 0)
|
||||
- vnc_server_set_port (vnc_server, port);
|
||||
+ g_warning ("Can't start VNC server; command '%s' not found", tokens[0]);
|
||||
+ return;
|
||||
}
|
||||
- g_autofree gchar *listen_address = config_get_string (config_get_instance (), "VNCServer", "listen-address");
|
||||
- vnc_server_set_listen_address (vnc_server, listen_address);
|
||||
- g_signal_connect (vnc_server, VNC_SERVER_SIGNAL_NEW_CONNECTION, G_CALLBACK (vnc_connection_cb), NULL);
|
||||
-
|
||||
- g_debug ("Starting VNC server on TCP/IP port %d", vnc_server_get_port (vnc_server));
|
||||
- vnc_server_start (vnc_server);
|
||||
}
|
||||
else
|
||||
- g_warning ("Can't start VNC server, Xvnc is not in the path");
|
||||
+ {
|
||||
+ /* Fallback to 'Xvnc'. */
|
||||
+ if (!g_find_program_in_path ("Xvnc")) {
|
||||
+ g_warning ("Can't start VNC server; 'Xvnc' command not found");
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ vnc_server = vnc_server_new ();
|
||||
+ if (config_has_key (config_get_instance (), "VNCServer", "port"))
|
||||
+ {
|
||||
+ gint port = config_get_integer (config_get_instance (), "VNCServer", "port");
|
||||
+ if (port > 0)
|
||||
+ vnc_server_set_port (vnc_server, port);
|
||||
+ }
|
||||
+ g_autofree gchar *listen_address = config_get_string (config_get_instance (), "VNCServer", "listen-address");
|
||||
+ vnc_server_set_listen_address (vnc_server, listen_address);
|
||||
+ g_signal_connect (vnc_server, VNC_SERVER_SIGNAL_NEW_CONNECTION, G_CALLBACK (vnc_connection_cb), NULL);
|
||||
+
|
||||
+ g_debug ("Starting VNC server on TCP/IP port %d", vnc_server_get_port (vnc_server));
|
||||
+ vnc_server_start (vnc_server);
|
||||
}
|
||||
}
|
||||
+
|
||||
static void
|
||||
service_ready_cb (DisplayManagerService *service)
|
||||
{
|
Loading…
Reference in a new issue