mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: python-pillow: Fix build with zlib 1.3.
* gnu/packages/patches/python-pillow-use-zlib-1.3.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/python-xyz.scm (python-pillow): Use it. Change-Id: I97e706c11f616c42fb604cb616a94663f389a376
This commit is contained in:
parent
ef3bac711b
commit
dc26246ef6
3 changed files with 25 additions and 1 deletions
|
@ -1876,6 +1876,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-feedparser-missing-import.patch \
|
||||
%D%/packages/patches/python-louvain-fix-test.patch \
|
||||
%D%/packages/patches/python-random2-getrandbits-test.patch \
|
||||
%D%/packages/patches/python-pillow-use-zlib-1.3.patch \
|
||||
%D%/packages/patches/python-pyreadstat-link-libiconv.patch \
|
||||
%D%/packages/patches/python-pyls-black-41.patch \
|
||||
%D%/packages/patches/python-pypdf-annotate-tests-appropriately.patch \
|
||||
|
|
21
gnu/packages/patches/python-pillow-use-zlib-1.3.patch
Normal file
21
gnu/packages/patches/python-pillow-use-zlib-1.3.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
From 9ef7cb39def45b0fe1cdf4828ca20838a1fc39d1 Mon Sep 17 00:00:00 2001
|
||||
From: Andrew Murray <radarhere@users.noreply.github.com>
|
||||
Date: Fri, 18 Aug 2023 22:22:51 +1000
|
||||
Subject: [PATCH] Updated zlib to 1.3
|
||||
|
||||
---
|
||||
Tests/test_file_png.py | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/Tests/test_file_png.py b/Tests/test_file_png.py
|
||||
index 3ffe93c6d15..f8df88d6777 100644
|
||||
--- a/Tests/test_file_png.py
|
||||
+++ b/Tests/test_file_png.py
|
||||
@@ -79,6 +79,6 @@ def get_chunks(self, filename):
|
||||
|
||||
def test_sanity(self, tmp_path):
|
||||
# internal version number
|
||||
- assert re.search(r"\d+\.\d+\.\d+(\.\d+)?$", features.version_codec("zlib"))
|
||||
+ assert re.search(r"\d+(\.\d+){1,3}$", features.version_codec("zlib"))
|
||||
|
||||
test_file = str(tmp_path / "temp.png")
|
|
@ -10249,7 +10249,9 @@ (define-public python-pillow
|
|||
(snippet '(begin
|
||||
(delete-file-recursively "src/thirdparty")))
|
||||
(patches
|
||||
(search-patches "python-pillow-CVE-2022-45199.patch"))))
|
||||
(search-patches "python-pillow-CVE-2022-45199.patch"
|
||||
;; Included in 10.1.0.
|
||||
"python-pillow-use-zlib-1.3.patch"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs (list python-pytest))
|
||||
(inputs (list freetype
|
||||
|
|
Loading…
Reference in a new issue