gnu: openboardview: Update to 9.0.3.

* gnu/packages/electronics.scm (openboardview): Update to 9.0.3.
[source](patches): Remove obsolete patch.
* gnu/packages/patches/openboardview-use-system-utf8.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
Marius Bakke 2022-11-26 11:01:48 +01:00 committed by Maxim Cournoyer
parent ea041be417
commit dd8a6ace60
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 3 additions and 53 deletions

View file

@ -1617,7 +1617,6 @@ dist_patch_DATA = \
%D%/packages/patches/onnx-skip-model-downloads.patch \
%D%/packages/patches/openbios-aarch64-riscv64-support.patch \
%D%/packages/patches/openboardview-use-system-imgui.patch \
%D%/packages/patches/openboardview-use-system-utf8.patch \
%D%/packages/patches/openbox-python3.patch \
%D%/packages/patches/openfoam-4.1-cleanup.patch \
%D%/packages/patches/openjdk-10-idlj-reproducibility.patch \

View file

@ -252,7 +252,7 @@ (define-public sigrok-cli
(define-public openboardview
(package
(name "openboardview")
(version "8.95.2")
(version "9.0.3")
(source (origin
(method git-fetch)
(uri (git-reference
@ -270,11 +270,10 @@ (define keep (list "." ".." "openboardview"))
(delete-file-recursively f)))
(scandir "." (negate (cut member <> keep))))))
(patches
(search-patches "openboardview-use-system-imgui.patch"
"openboardview-use-system-utf8.patch"))
(search-patches "openboardview-use-system-imgui.patch"))
(sha256
(base32
"1n2yfi8wpky0y231kq2zdgwn7f7kff8m53m904hxi5ppmwhx1d6q"))))
"0wmplzgi3rpkcajdrnkxvqhgxrn6qdxa6vwgd24bm10ryyhiqw54"))))
(build-system cmake-build-system)
(arguments
(list

View file

@ -1,48 +0,0 @@
From 251e23422f37c93a3f460fb660c5e5bfa8200d91 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Sun, 2 Dec 2018 16:40:39 -0500
Subject: [PATCH] build system: Allow using utf8.h from the system.
---
src/CMakeLists.txt | 12 ++++++++----
src/openboardview/CMakeLists.txt | 1 +
2 files changed, 9 insertions(+), 4 deletions(-)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 90442ed..26d4a69 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,10 +8,14 @@ if(NOT WIN32 OR MINGW)
endif()
## utf8.h ##
-execute_process(
- COMMAND git submodule update --init src/utf8
- WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
-)
+FIND_PATH(UTF8_INCLUDE_DIR utf8.h)
+if(NOT UTF8_INCLUDE_DIR)
+ execute_process(
+ COMMAND git submodule update --init src/utf8
+ WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
+ )
+ set(UTF8_INCLUDE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/utf8)
+endif()
## zlib ##
find_package(ZLIB)
diff --git a/src/openboardview/CMakeLists.txt b/src/openboardview/CMakeLists.txt
index b0bdbe3..6c4564c 100644
--- a/src/openboardview/CMakeLists.txt
+++ b/src/openboardview/CMakeLists.txt
@@ -44,6 +44,7 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/..
${IMGUI_INCLUDE_DIRS}
+ ${UTF8_INCLUDE_DIR}
${GLAD_INCLUDE_DIRS}
${GTK_INCLUDE_DIRS}
${OPENGL_INCLUDE_DIR}
--
2.34.0