gnu: bear: Update to 3.0.17.

* gnu/packages/build-tools.scm (bear): Update to 3.0.17.
[source]: Remove patch, and…
[arguments]: …replace it with a new 'disable-TEST_BEFORE_INSTALL phase.
Don't explicitly return #t from other phases.
* gnu/packages/patches/bear-disable-preinstall-tests.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Tobias Geerinckx-Rice 2021-12-19 00:22:19 +01:00
parent a035acc652
commit de01d08bdf
No known key found for this signature in database
GPG key ID: 0DB0FF884F556D79
3 changed files with 17 additions and 42 deletions

View file

@ -885,7 +885,6 @@ dist_patch_DATA = \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
%D%/packages/patches/bc-fix-cross-compilation.patch \
%D%/packages/patches/bdb-5.3-atomics-on-gcc-9.patch \
%D%/packages/patches/bear-disable-preinstall-tests.patch \
%D%/packages/patches/bind-re-add-attr-constructor-priority.patch \
%D%/packages/patches/brightnessctl-elogind-support.patch \
%D%/packages/patches/bsd-games-2.17-64bit.patch \

View file

@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Corentin Bocquillon <corentin@nybble.fr>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 20172021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@ -102,25 +102,27 @@ (define-public bam
(define-public bear
(package
(name "bear")
(version "3.0.16")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rizsotto/Bear")
(commit version)))
(file-name (git-file-name name version))
(patches (search-patches
"bear-disable-preinstall-tests.patch"))
(sha256
(base32
"01giv11nhjp4pvw8ssf8bxf503pabwnwnvfzmrxyxixnairwmykg"))))
(version "3.0.17")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rizsotto/Bear")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "0klbk99qphibrp2944w8gn6x1dwwgrbm7f2bh530wjp5h3bpkr45"))))
(build-system cmake-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'unpack 'disable-TEST_BEFORE_INSTALL
(lambda _
(substitute* "CMakeLists.txt"
;; Delete the matching line—and comment out the next.
((".*TEST_(BEFORE_INSTALL|COMMAND).*") "#"))))
(add-before 'check 'set-build-environment
(lambda _
(setenv "CC" "gcc")
#t))
(setenv "CC" "gcc")))
;; TODO: Test Configuration is Incomplete
(replace 'check
(lambda _

View file

@ -1,26 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,10 +60,6 @@ ExternalProject_Add(BearSource
-DCMAKE_BUILD_TYPE:STRING=${CMAKE_BUILD_TYPE}
-DENABLE_UNIT_TESTS:BOOL=${ENABLE_UNIT_TESTS}
-DENABLE_FUNC_TESTS:BOOL=${ENABLE_FUNC_TESTS}
- TEST_BEFORE_INSTALL
- 1
- TEST_COMMAND
- ctest # or `ctest -T memcheck`
)
# Run the functional tests
@@ -77,12 +73,8 @@ if (ENABLE_FUNC_TESTS)
-DCMAKE_INSTALL_LIBDIR:PATH=${CMAKE_INSTALL_LIBDIR}
-DCMAKE_INSTALL_BINDIR:PATH=${CMAKE_INSTALL_BINDIR}
-DSTAGED_INSTALL_PREFIX:PATH=${STAGED_INSTALL_PREFIX}
- TEST_BEFORE_INSTALL
- 1
INSTALL_COMMAND
""
- TEST_COMMAND
- ctest --verbose
)
endif ()