mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: python-telingo: Update to 2.1.3.
* gnu/packages/potassco.scm (python-telingo): Update to 2.1.3. [source]: Drop obsolete patch. * gnu/packages/patches/python-telingo-fix-comparison.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
d694062fb5
commit
e046d6d443
3 changed files with 2 additions and 23 deletions
|
@ -1812,7 +1812,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-sip-include-dirs.patch \
|
||||
%D%/packages/patches/python-sgmllib3k-assertions.patch \
|
||||
%D%/packages/patches/python-sphinx-prompt-docutils-0.19.patch \
|
||||
%D%/packages/patches/python-telingo-fix-comparison.patch \
|
||||
%D%/packages/patches/python-typeguard-python3.10.patch \
|
||||
%D%/packages/patches/python-uqbar-python3.10.patch \
|
||||
%D%/packages/patches/python-wxwidgets-type-errors.patch \
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
Index: source/telingo/transformers/head.py
|
||||
===================================================================
|
||||
--- source.orig/telingo/transformers/head.py
|
||||
+++ source/telingo/transformers/head.py
|
||||
@@ -564,10 +564,12 @@ class HeadTransformer:
|
||||
cond = []
|
||||
diff = _ast.BinaryOperation(loc, _ast.BinaryOperator.Minus, param, shift)
|
||||
if lhs.ast_type != _ast.ASTType.SymbolicTerm or lhs.symbol.type != _clingo.SymbolType.Number or lhs.symbol.number > 0:
|
||||
- cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, lhs, diff)))
|
||||
+ cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
|
||||
+ _ast.Comparison(lhs, [_ast.Guard(_ast.ComparisonOperator.LessEqual, diff)])))
|
||||
|
||||
if rhs.ast_type != _ast.ASTType.SymbolicTerm or rhs.symbol.type != _clingo.SymbolType.Supremum:
|
||||
- cond.append(_ast.Literal(loc, _ast.Sign.NoSign, _ast.Comparison(_ast.ComparisonOperator.LessEqual, diff, rhs)))
|
||||
+ cond.append(_ast.Literal(loc, _ast.Sign.NoSign,
|
||||
+ _ast.Comparison(diff, [_ast.Guard(_ast.ComparisonOperator.LessEqual, rhs)])))
|
||||
|
||||
elems.extend([_ast.ConditionalLiteral(loc, _ast.Literal(loc, _ast.Sign.NoSign, head), cond) for head in heads])
|
||||
|
|
@ -520,17 +520,16 @@ (define-public python-plingo
|
|||
(define-public python-telingo
|
||||
(package
|
||||
(name "python-telingo")
|
||||
(version "2.1.1")
|
||||
(version "2.1.3")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url "https://github.com/potassco/telingo")
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "python-telingo-fix-comparison.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0g3khxfdzc2hc7dkiyyqhb399h6h21m5wkp6wy8w71n0m32fiy53"))))
|
||||
"1q6hlh4b5hsa4n5agvmfa9rhsxfd2g6kpl4b9kfccwbmf6dh51k6"))))
|
||||
(build-system pyproject-build-system)
|
||||
(propagated-inputs (list python-clingo))
|
||||
(home-page "https://potassco.org/")
|
||||
|
|
Loading…
Reference in a new issue