mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 21:59:08 -05:00
gnu: libreoffice: Update to 6.2.8.2.
* gnu/packages/libreoffice.scm (libreoffice): Update to 6.2.8.2. [sources]: Remove libreoffice-boost.patch, libreoffice-orcus patch, libreoffice-mdds patch. [inputs]: Add fontforge, mariadb. [arguments]: Remove substitution checking for mdds and orcus versions. From configure-flags, remove outdated flags, add flag to build font file. * gnu/packages/patches/libreoffice-boost.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
7460f34670
commit
e0efda9561
3 changed files with 8 additions and 59 deletions
|
@ -1065,7 +1065,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
||||
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
||||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||
%D%/packages/patches/libreoffice-boost.patch \
|
||||
%D%/packages/patches/libreoffice-icu.patch \
|
||||
%D%/packages/patches/libreoffice-glm.patch \
|
||||
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
||||
|
|
|
@ -929,7 +929,7 @@ (define-public libqxp
|
|||
(define-public libreoffice
|
||||
(package
|
||||
(name "libreoffice")
|
||||
(version "6.1.5.2")
|
||||
(version "6.2.8.2")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -939,36 +939,9 @@ (define-public libreoffice
|
|||
(version-prefix version 3) "/libreoffice-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1wh8qhqkmb89nmfcb0w6iwpdzxwqr7c5kzxgpk4gy60xin6gwjgb"))
|
||||
(patches
|
||||
(append (list (origin
|
||||
;; Support newer versions of Orcus and MDDS. These patches
|
||||
;; are taken from upstream, but we use the patches from Arch
|
||||
;; because they are adapted for the release tarball.
|
||||
;; Note: remove the related substitutions below when these
|
||||
;; are no longer needed.
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://git.archlinux.org/svntogit"
|
||||
"/packages.git/plain/trunk/"
|
||||
"0001-Update-orcus-to-0.14.0.patch?&id="
|
||||
"4002fa927f2a143bd2ec008a0c400b2ce9f2c8a7"))
|
||||
(file-name "libreoffice-orcus.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"0v1knblrmfzkb4g9pm5mdnrmjib59bznvca1ygbwlap2ln1h4mk0")))
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://git.archlinux.org/svntogit"
|
||||
"/packages.git/plain/trunk/"
|
||||
"0001-Update-mdds-to-1.4.1.patch?&id="
|
||||
"4002fa927f2a143bd2ec008a0c400b2ce9f2c8a7"))
|
||||
(file-name "libreoffice-mdds.patch")
|
||||
(sha256
|
||||
(base32
|
||||
"0apbmammmp4pk473xiv5vk50r4c5gjvqzf9jkficksvz58q6114f"))))
|
||||
(search-patches "libreoffice-boost.patch"
|
||||
"libreoffice-icu.patch"
|
||||
"libreoffice-glm.patch")))
|
||||
"1npxyj0hklls3jnaxx9kj3r6bgydgrbz6nacy05n0zhq8i6zb5ir"))
|
||||
(patches (search-patches "libreoffice-icu.patch"
|
||||
"libreoffice-glm.patch"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
|
@ -992,6 +965,7 @@ (define-public libreoffice
|
|||
("cups" ,cups)
|
||||
("dbus-glib" ,dbus-glib)
|
||||
("fontconfig" ,fontconfig)
|
||||
("fontforge" ,fontforge)
|
||||
("gconf" ,gconf)
|
||||
("glew" ,glew)
|
||||
("glm" ,glm)
|
||||
|
@ -1031,6 +1005,7 @@ (define-public libreoffice
|
|||
("libxt" ,libxt)
|
||||
("libzmf" ,libzmf)
|
||||
("lpsolve" ,lpsolve)
|
||||
("mariadb" ,mariadb)
|
||||
("mdds" ,mdds)
|
||||
("mythes" ,mythes)
|
||||
("neon" ,neon)
|
||||
|
@ -1066,13 +1041,6 @@ (define-public libreoffice
|
|||
"solenv/gbuild/platform/unxgcc.mk")
|
||||
(("/bin/sh") (which "sh")))
|
||||
|
||||
;; XXX: Adjust the checks for MDDS and liborcus to avoid having
|
||||
;; to re-bootstrap the whole thing. Remove this with the related
|
||||
;; patches above.
|
||||
(substitute* "configure"
|
||||
(("mdds-1.2 >= 1.2.3") "mdds-1.4 >= 1.4.1")
|
||||
(("liborcus-0.13 >= 0.13.3") "liborcus-0.14 >= 0.14.0"))
|
||||
|
||||
;; GPGME++ headers are installed in a gpgme++ subdirectory, but
|
||||
;; files in "xmlsecurity/source/gpg/" and elsewhere expect to
|
||||
;; find them on the include path without a prefix.
|
||||
|
@ -1161,16 +1129,15 @@ (define (install-appdata app)
|
|||
;; With java, the build fails since sac.jar is missing.
|
||||
"--without-java"
|
||||
;; FIXME: Enable once the corresponding inputs are packaged.
|
||||
"--without-system-npapi-headers"
|
||||
"--disable-coinmp"
|
||||
"--disable-firebird-sdbc" ; embedded firebird
|
||||
"--disable-gltf"
|
||||
;; XXX: PDFium support requires fetching an external tarball and
|
||||
;; patching the build scripts to work with GCC5. Try enabling this
|
||||
;; when our default compiler is >=GCC 6.
|
||||
"--disable-pdfium"
|
||||
"--disable-gtk" ; disable use of GTK+ 2
|
||||
"--without-doxygen")))
|
||||
"--without-doxygen"
|
||||
"--enable-build-opensymbol")))
|
||||
(home-page "https://www.libreoffice.org/")
|
||||
(synopsis "Office suite")
|
||||
(description "LibreOffice is a comprehensive office suite. It contains
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Fix compatibility with newer Boost.
|
||||
|
||||
Extracted from this upstream commit:
|
||||
https://cgit.freedesktop.org/libreoffice/core/commit/?id=23a8d5ffbbe58761b89f590f0735abccd69a3681
|
||||
|
||||
diff --git a/sfx2/source/appl/shutdownicon.cxx b/sfx2/source/appl/shutdownicon.cxx
|
||||
--- a/sfx2/source/appl/shutdownicon.cxx
|
||||
+++ b/sfx2/source/appl/shutdownicon.cxx
|
||||
@@ -144,7 +144,7 @@ bool LoadModule()
|
||||
#endif // ENABLE_QUICKSTART_APPLET
|
||||
}
|
||||
assert(!boost::logic::indeterminate(loaded));
|
||||
- return loaded;
|
||||
+ return bool(loaded);
|
||||
}
|
||||
|
||||
}
|
Loading…
Reference in a new issue