mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: grim: Fix output rotation interpretation with Sway 1.4.
* gnu/packages/image.scm (grim)[source]: Add patch. * gnu/packages/patches/grim-revert-output-rotation.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
7a0491ad0c
commit
e1fefb810b
4 changed files with 32 additions and 1 deletions
|
@ -1085,6 +1085,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/gpsbabel-qstring.patch \
|
||||
%D%/packages/patches/grantlee-merge-theme-dirs.patch \
|
||||
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
||||
%D%/packages/patches/grim-revert-output-rotation.patch \
|
||||
%D%/packages/patches/grocsvs-dont-use-admiral.patch \
|
||||
%D%/packages/patches/gromacs-tinyxml2.patch \
|
||||
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
|
||||
|
|
|
@ -1949,7 +1949,8 @@ (define-public grim
|
|||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32 "0fjmjq0ws9rlblkcqxxw2lv7zvvyi618jqzlnz5z9zb477jwdfib"))))
|
||||
(base32 "0fjmjq0ws9rlblkcqxxw2lv7zvvyi618jqzlnz5z9zb477jwdfib"))
|
||||
(patches (search-patches "grim-revert-output-rotation.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(native-inputs `(("pkg-config" ,pkg-config)
|
||||
("scdoc" ,scdoc)))
|
||||
|
|
27
gnu/packages/patches/grim-revert-output-rotation.patch
Normal file
27
gnu/packages/patches/grim-revert-output-rotation.patch
Normal file
|
@ -0,0 +1,27 @@
|
|||
From 80b17ceaff90b81b28b44004d2aca4cc40f365be Mon Sep 17 00:00:00 2001
|
||||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Fri, 2 Oct 2020 00:07:30 +0200
|
||||
Subject: [PATCH] Revert "Correct interpretation of output rotation"
|
||||
|
||||
This reverts commit 8f9d60885ce2f9bd66cd93d3378dcb6866d4588a.
|
||||
It is incompatible with the current Sway version (1.4) in Guix.
|
||||
---
|
||||
render.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/render.c b/render.c
|
||||
index 8f31e7e..a6b0b12 100644
|
||||
--- a/render.c
|
||||
+++ b/render.c
|
||||
@@ -104,7 +104,7 @@ cairo_surface_t *render(struct grim_state *state, struct grim_box *geometry,
|
||||
cairo_matrix_translate(&matrix,
|
||||
(double)output->geometry.width / 2,
|
||||
(double)output->geometry.height / 2);
|
||||
- cairo_matrix_rotate(&matrix, get_output_rotation(output->transform));
|
||||
+ cairo_matrix_rotate(&matrix, -get_output_rotation(output->transform));
|
||||
cairo_matrix_scale(&matrix,
|
||||
(double)raw_output_width / output_width * output_flipped_x,
|
||||
(double)raw_output_height / output_height * output_flipped_y);
|
||||
--
|
||||
2.28.0
|
||||
|
|
@ -1386,6 +1386,8 @@ (define-public wlroots
|
|||
(define-public sway
|
||||
(package
|
||||
(name "sway")
|
||||
;; XXX When updating, check whether grim-revert-output-rotation.patch can
|
||||
;; be dropped from the grim package.
|
||||
(version "1.4")
|
||||
(source
|
||||
(origin
|
||||
|
|
Loading…
Reference in a new issue