mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: nsis: Update to 3.08.
* gnu/packages/patches/nsis-source-date-epoch.patch: Drop this patch. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/patches/nsis-env-passthru.patch: Adjust the patch. * gnu/packages/installers.scm (make-nsis): Update to 3.08. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
This commit is contained in:
parent
cb14d802ae
commit
e2ad0b0f8b
4 changed files with 12 additions and 38 deletions
|
@ -1550,7 +1550,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/nginx-socket-cloexec.patch \
|
%D%/packages/patches/nginx-socket-cloexec.patch \
|
||||||
%D%/packages/patches/nnpack-system-libraries.patch \
|
%D%/packages/patches/nnpack-system-libraries.patch \
|
||||||
%D%/packages/patches/nsis-env-passthru.patch \
|
%D%/packages/patches/nsis-env-passthru.patch \
|
||||||
%D%/packages/patches/nsis-source-date-epoch.patch \
|
|
||||||
%D%/packages/patches/nss-getcwd-nonnull.patch \
|
%D%/packages/patches/nss-getcwd-nonnull.patch \
|
||||||
%D%/packages/patches/nss-increase-test-timeout.patch \
|
%D%/packages/patches/nss-increase-test-timeout.patch \
|
||||||
%D%/packages/patches/nss-3.56-pkgconfig.patch \
|
%D%/packages/patches/nss-3.56-pkgconfig.patch \
|
||||||
|
|
|
@ -34,16 +34,15 @@ (define (make-nsis machine target-arch nsis-target-type)
|
||||||
(xgcc (cross-gcc triplet #:libc xlibc)))
|
(xgcc (cross-gcc triplet #:libc xlibc)))
|
||||||
(package
|
(package
|
||||||
(name (string-append "nsis-" machine))
|
(name (string-append "nsis-" machine))
|
||||||
(version "3.05")
|
(version "3.08")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://prdownloads.sourceforge.net/nsis/nsis-"
|
(uri (string-append "http://prdownloads.sourceforge.net/nsis/nsis-"
|
||||||
version "-src.tar.bz2"))
|
version "-src.tar.bz2"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1sbwx5vzpddharkb7nj4q5z3i5fbg4lan63ng738cw4hmc4v7qdn"))
|
"11qy1n1qdcqwal9hn8cmzm7gxjdyx7by6w14rfz2l646afnp0lm8"))
|
||||||
(patches (search-patches "nsis-env-passthru.patch"
|
(patches (search-patches "nsis-env-passthru.patch"))))
|
||||||
"nsis-source-date-epoch.patch"))))
|
|
||||||
(build-system scons-build-system)
|
(build-system scons-build-system)
|
||||||
(native-inputs `(("xgcc" ,xgcc)
|
(native-inputs `(("xgcc" ,xgcc)
|
||||||
("xbinutils" ,xbinutils)
|
("xbinutils" ,xbinutils)
|
||||||
|
@ -125,7 +124,7 @@ (define (mingw-path? path)
|
||||||
(lambda _
|
(lambda _
|
||||||
;; NSIS target detection is screwed up, manually change
|
;; NSIS target detection is screwed up, manually change
|
||||||
;; it ourselves
|
;; it ourselves
|
||||||
(substitute* "Source/build.cpp" (("m_target_type=TARGET_X86ANSI")
|
(substitute* "Source/build.cpp" (("m_target_type=TARGET_X86UNICODE")
|
||||||
(string-append "m_target_type=" ,nsis-target-type))))))))
|
(string-append "m_target_type=" ,nsis-target-type))))))))
|
||||||
(home-page "https://nsis.sourceforge.io/Main_Page")
|
(home-page "https://nsis.sourceforge.io/Main_Page")
|
||||||
(synopsis "System to create Windows installers")
|
(synopsis "System to create Windows installers")
|
||||||
|
|
|
@ -1,12 +1,11 @@
|
||||||
--- nsis-3.04-src/SConstruct 2019-05-30 14:53:30.276775332 -0400
|
--- nsis-3.08-src/SConstruct 2021-01-15 17:31:10.000000000 +0100
|
||||||
+++ nsis-3.04-src/SConstruct 2019-05-30 14:54:17.901232914 -0400
|
+++ nsis-3.08-src/SConstruct-passthru 2022-08-02 17:11:12.414702282 +0200
|
||||||
@@ -77,6 +77,9 @@
|
@@ -71,7 +71,7 @@
|
||||||
if not toolset and not path:
|
|
||||||
defenv = Environment(TARGET_ARCH = arch)
|
|
||||||
|
|
||||||
+import os;
|
defenv = {
|
||||||
+defenv['ENV'] = os.environ
|
'TARGET_ARCH': ARGUMENTS.get('TARGET_ARCH', 'x86'),
|
||||||
+
|
- 'ENV': {}
|
||||||
Export('defenv')
|
+ 'ENV': os.environ.copy()
|
||||||
|
}
|
||||||
|
|
||||||
######################################################################
|
######################################################################
|
||||||
|
|
|
@ -1,23 +0,0 @@
|
||||||
Honour SOURCE_DATE_EPOCH for VERSION default
|
|
||||||
|
|
||||||
Merged upstream as cd3f1024a37a332f1d4fa96a817ca80dfa2a478c, but not yet in a
|
|
||||||
release. GitHub PR: https://github.com/kichik/nsis/pull/13
|
|
||||||
|
|
||||||
Python snippet from: https://reproducible-builds.org/docs/source-date-epoch/#python
|
|
||||||
|
|
||||||
|
|
||||||
diff --git a/SConstruct b/SConstruct
|
|
||||||
index e8252c9..41786f2 100755
|
|
||||||
--- a/SConstruct
|
|
||||||
+++ b/SConstruct
|
|
||||||
@@ -95,8 +95,8 @@ default_doctype = 'html'
|
|
||||||
if defenv.WhereIs('hhc', os.environ['PATH']):
|
|
||||||
default_doctype = 'chm'
|
|
||||||
|
|
||||||
-from time import strftime, gmtime
|
|
||||||
-cvs_version = strftime('%d-%b-%Y.cvs', gmtime())
|
|
||||||
+import time
|
|
||||||
+cvs_version = time.strftime('%d-%b-%Y.cvs', time.gmtime(int(os.environ.get('SOURCE_DATE_EPOCH', time.time()))))
|
|
||||||
|
|
||||||
opts = Variables()
|
|
||||||
|
|
Loading…
Reference in a new issue