gnu: ark: Update to 24.05.2.

* gnu/packages/kde-utils.scm (ark): Update to 24.05.2.
[inputs]: Remove khtml and qtbase-5; add kfilemetadata.
[arguments]: Set #:qtbase to qtbase; Use Gexps.

* gnu/packages/patches/ark-skip-xar-test.patch: Adjust it.

Change-Id: I225a2e0c6487001160cb7d81032b6dcd1fef12dd
This commit is contained in:
Zheng Junjie 2024-07-08 11:34:16 +08:00
parent 1fd0cc75b0
commit e2c0a0bdd7
No known key found for this signature in database
GPG key ID: 3B5AA993E1A2DFF0
2 changed files with 51 additions and 58 deletions

View file

@ -54,21 +54,23 @@ (define-module (gnu packages kde-utils)
(define-public ark
(package
(name "ark")
(version "23.04.3")
(version "24.05.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/" version
"/src/ark-" version ".tar.xz"))
(sha256
(base32
"081swq9f87yxg4dxdl5i4hszhr0q4ph402in397zfa5vpyspzy41"))
"1q0fyx65gp0d1vj4jxiaswdfzi15hbfi537f3i8y277b621qp3rs"))
;; The libarchive package in Guix does not support
;; xar; disable related tests.
(patches (search-patches "ark-skip-xar-test.patch"))))
(build-system qt-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(list
#:qtbase qtbase
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'start-xserver
;; adddialogtest requires DISPLAY.
(lambda* (#:key inputs #:allow-other-keys)
@ -99,7 +101,6 @@ (define-public ark
kconfig
kcrash
kdbusaddons
khtml
ki18n
kiconthemes
kio
@ -108,9 +109,9 @@ (define-public ark
kpty
kservice
kwidgetsaddons
kfilemetadata
libarchive
libzip
qtbase-5
zlib
;; Command line tools used by Ark.
lrzip

View file

@ -1,44 +1,36 @@
Guix libarchive no support xar.
--- ark-20.04.1.orig/autotests/kerfuffle/loadtest.cpp 2020-12-23 08:46:15.780782601 +0800
+++ ark-20.04.1/autotests/kerfuffle/loadtest.cpp 2020-12-23 11:13:17.101724042 +0800
@@ -181,13 +181,6 @@
--- ark-24.05.2.orig/autotests/kerfuffle/loadtest.cpp 2024-07-08 11:19:30.347366493 +0800
+++ ark-24.05.2/autotests/kerfuffle/loadtest.cpp 2024-07-08 11:19:47.495641516 +0800
@@ -125,8 +125,6 @@
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
}
- QTest::newRow("xar archive")
- << QFINDTESTDATA("data/simplearchive.xar")
- << QStringLiteral("simplearchive")
- << true << false << false << false << false << 0 << Archive::Unencrypted
- << QStringLiteral("simplearchive")
- << QString();
-
QTest::newRow("mimetype child of application/zip")
<< QFINDTESTDATA("data/test.odt")
<< QStringLiteral("test")
--- ark-20.04.1.orig/autotests/kerfuffle/extracttest.cpp 2020-12-23 08:46:15.780782601 +0800
+++ ark-20.04.1/autotests/kerfuffle/extracttest.cpp 2020-12-23 11:14:02.801809620 +0800
@@ -350,23 +350,6 @@
- QTest::newRow("xar archive") << QFINDTESTDATA("data/simplearchive.xar") << QStringLiteral("simplearchive") << true << false << false << false << false << 0
- << Archive::Unencrypted << 6 << QStringLiteral("simplearchive") << QString();
QTest::newRow("mimetype child of application/zip") << QFINDTESTDATA("data/test.odt") << QStringLiteral("test") << false << true << false << false << false
<< 0 << Archive::Unencrypted << 17 << QStringLiteral("test") << QString();
--- ark-24.05.2.orig/autotests/kerfuffle/extracttest.cpp 2024-07-08 11:21:25.849219202 +0800
+++ ark-24.05.2/autotests/kerfuffle/extracttest.cpp 2024-07-08 11:22:01.413789814 +0800
@@ -329,18 +329,5 @@
qDebug() << "lz4 executable not found in path. Skipping lz4 test.";
}
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
- QTest::newRow("extract selected entries from a xar archive without path")
- << archivePath
- << QVector<Archive::Entry*> {
- setupRow("extract selected entries from a xar archive without path",
- archivePath,
- QList<Archive::Entry *>{
- new Archive::Entry(this, QStringLiteral("dir1/file11.txt"), QString()),
- new Archive::Entry(this, QStringLiteral("file4.txt"), QString())
- }
- << optionsNoPaths
- << 2;
- new Archive::Entry(this, QStringLiteral("file4.txt"), QString()),
- },
- optionsNoPaths,
- 2);
-
- archivePath = QFINDTESTDATA("data/simplearchive.xar");
- QTest::newRow("extract all entries from a xar archive with path")
- << archivePath
- << QVector<Archive::Entry*>()
- << optionsPreservePaths
- << 6;
- setupRow("extract all entries from a xar archive with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 6);
-
archivePath = QFINDTESTDATA("data/hello-1.0-x86_64.AppImage");
QTest::newRow("extract all entries from an AppImage with path")
<< archivePath
setupRow("extract all entries from an AppImage with path", archivePath, QList<Archive::Entry *>(), optionsPreservePaths, 7);