mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 06:18:07 -05:00
gnu: mongodb: Update to 3.4.24 [security fixes].
* gnu/packages/patches/mongodb-support-unknown-linux-distributions.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Ditto. * gnu/packages/databases.scm (mongodb): Update to 3.4.24. [source]: Drop patch. Update third_party libs folder names.
This commit is contained in:
parent
fdf82830d4
commit
e5f89570c1
3 changed files with 5 additions and 64 deletions
|
@ -1372,7 +1372,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/mpc123-initialize-ao.patch \
|
||||
%D%/packages/patches/module-init-tools-moduledir.patch \
|
||||
%D%/packages/patches/monero-use-system-miniupnpc.patch \
|
||||
%D%/packages/patches/mongodb-support-unknown-linux-distributions.patch \
|
||||
%D%/packages/patches/mono-mdoc-timestamping.patch \
|
||||
%D%/packages/patches/mozjs17-aarch64-support.patch \
|
||||
%D%/packages/patches/mozjs24-aarch64-support.patch \
|
||||
|
|
|
@ -664,27 +664,24 @@ (define-public python2-pylibmc
|
|||
(define-public mongodb
|
||||
(package
|
||||
(name "mongodb")
|
||||
(version "3.4.10")
|
||||
(version "3.4.24")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/mongodb/mongo/archive/r"
|
||||
version ".tar.gz"))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0676lvkljj7a5hdhv78dbykqnqrj9lbn9799mi84b8vbnzsq961r"))
|
||||
(base32 "0y1669sqj8wyf0y0njhxs4qhn1qzjhrs2h2qllya5samxrlrjhkg"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(for-each (lambda (dir)
|
||||
(delete-file-recursively
|
||||
(string-append "src/third_party/" dir)))
|
||||
'("pcre-8.41" "scons-2.5.0" "snappy-1.1.3"
|
||||
'("pcre-8.42" "scons-2.5.0" "snappy-1.1.3"
|
||||
"valgrind-3.11.0" "wiredtiger"
|
||||
"yaml-cpp-0.5.3" "zlib-1.2.8"))
|
||||
#t))
|
||||
(patches
|
||||
(list
|
||||
(search-patch "mongodb-support-unknown-linux-distributions.patch")))))
|
||||
"yaml-cpp-0.6.2" "zlib-1.2.11"))
|
||||
#t))))
|
||||
(build-system scons-build-system)
|
||||
(inputs
|
||||
`(("openssl" ,openssl-1.0)
|
||||
|
|
|
@ -1,55 +0,0 @@
|
|||
From e724bb7018a482640c4f194f88b554af2c59d76e Mon Sep 17 00:00:00 2001
|
||||
From: Mark Benvenuto <mark.benvenuto@mongodb.com>
|
||||
Date: Wed, 20 Sep 2017 11:50:02 -0400
|
||||
Subject: [PATCH] SERVER-30857 Support unknown Linux distributions
|
||||
|
||||
---
|
||||
src/mongo/rpc/metadata/client_metadata.cpp | 6 ------
|
||||
src/mongo/util/processinfo_linux.cpp | 9 ++++++---
|
||||
2 files changed, 6 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/src/mongo/rpc/metadata/client_metadata.cpp b/src/mongo/rpc/metadata/client_metadata.cpp
|
||||
index 845a315dd74..a959a4e31e9 100644
|
||||
--- a/src/mongo/rpc/metadata/client_metadata.cpp
|
||||
+++ b/src/mongo/rpc/metadata/client_metadata.cpp
|
||||
@@ -302,9 +302,6 @@ void ClientMetadata::serializePrivate(StringData driverName,
|
||||
StringData osArchitecture,
|
||||
StringData osVersion,
|
||||
BSONObjBuilder* builder) {
|
||||
- invariant(!driverName.empty() && !driverVersion.empty() && !osType.empty() && !osName.empty() &&
|
||||
- !osArchitecture.empty() && !osVersion.empty());
|
||||
-
|
||||
BSONObjBuilder metaObjBuilder(builder->subobjStart(kMetadataDocumentName));
|
||||
|
||||
{
|
||||
@@ -347,9 +344,6 @@ Status ClientMetadata::serializePrivate(StringData driverName,
|
||||
StringData osVersion,
|
||||
StringData appName,
|
||||
BSONObjBuilder* builder) {
|
||||
- invariant(!driverName.empty() && !driverVersion.empty() && !osType.empty() && !osName.empty() &&
|
||||
- !osArchitecture.empty() && !osVersion.empty());
|
||||
-
|
||||
if (appName.size() > kMaxApplicationNameByteLength) {
|
||||
return Status(ErrorCodes::ClientMetadataAppNameTooLarge,
|
||||
str::stream() << "The '" << kApplication << "." << kName
|
||||
diff --git a/src/mongo/util/processinfo_linux.cpp b/src/mongo/util/processinfo_linux.cpp
|
||||
index c3debf377bd..c2813b026b0 100644
|
||||
--- a/src/mongo/util/processinfo_linux.cpp
|
||||
+++ b/src/mongo/util/processinfo_linux.cpp
|
||||
@@ -376,10 +376,13 @@ class LinuxSysHelper {
|
||||
if ((nl = name.find('\n', nl)) != string::npos)
|
||||
// stop at first newline
|
||||
name.erase(nl);
|
||||
- // no standard format for name and version. use kernel version
|
||||
- version = "Kernel ";
|
||||
- version += LinuxSysHelper::readLineFromFile("/proc/sys/kernel/osrelease");
|
||||
+ } else {
|
||||
+ name = "unknown";
|
||||
}
|
||||
+
|
||||
+ // There is no standard format for name and version so use the kernel version.
|
||||
+ version = "Kernel ";
|
||||
+ version += LinuxSysHelper::readLineFromFile("/proc/sys/kernel/osrelease");
|
||||
}
|
||||
|
||||
/**
|
Loading…
Reference in a new issue