mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add llvm-13.
* gnu/packages/llvm.scm (llvm-13, clang-runtime-13, clang-13, clang-toolchain-13): New variables. (llvm-12): Inherit from llvm-13. * gnu/packages/patches/clang-13.0-libc-search-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
89afe76a16
commit
e742437211
3 changed files with 192 additions and 14 deletions
|
@ -946,6 +946,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/clang-10.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-11.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-12.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-13.0-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
|
||||
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
|
||||
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
|
||||
|
|
|
@ -486,17 +486,17 @@ (define (make-clang-toolchain clang)
|
|||
("libc-debug" ,glibc "debug")
|
||||
("libc-static" ,glibc "static")))))
|
||||
|
||||
(define-public llvm-12
|
||||
(define-public llvm-13
|
||||
(package
|
||||
(name "llvm")
|
||||
(version "12.0.1")
|
||||
(version "13.0.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (llvm-uri "llvm" version))
|
||||
(sha256
|
||||
(base32
|
||||
"1pzx9zrmd7r3481sbhwvkms68fwhffpp4mmz45dgrkjpyl2q96kx"))))
|
||||
"081h2vw757j5xjg2441539j2vhfzzihrgxwza5pq5sj3hrq133a0"))))
|
||||
(build-system cmake-build-system)
|
||||
(outputs '("out" "opt-viewer"))
|
||||
(native-inputs
|
||||
|
@ -506,6 +506,97 @@ (define-public llvm-12
|
|||
(list libffi))
|
||||
(propagated-inputs
|
||||
(list zlib)) ;to use output from llvm-config
|
||||
(arguments
|
||||
;; TODO(core-updates): Unconditionally use quasiquote
|
||||
`(#:configure-flags
|
||||
,#~(#$(if (%current-target-system)
|
||||
#~quasiquote
|
||||
#~quote)
|
||||
;; These options are required for cross-compiling LLVM according to
|
||||
;; https://llvm.org/docs/HowToCrossCompileLLVM.html.
|
||||
(#$@(if (%current-target-system)
|
||||
#~(,(string-append "-DLLVM_TABLEGEN="
|
||||
#+(file-append this-package
|
||||
"/bin/llvm-tblgen"))
|
||||
#$(string-append "-DLLVM_DEFAULT_TARGET_TRIPLE="
|
||||
(%current-target-system))
|
||||
#$(string-append "-DLLVM_TARGET_ARCH="
|
||||
(system->llvm-target))
|
||||
#$(string-append "-DLLVM_TARGETS_TO_BUILD="
|
||||
(system->llvm-target)))
|
||||
#~())
|
||||
"-DCMAKE_SKIP_BUILD_RPATH=FALSE"
|
||||
"-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
|
||||
"-DBUILD_SHARED_LIBS:BOOL=TRUE"
|
||||
"-DLLVM_ENABLE_FFI:BOOL=TRUE"
|
||||
"-DLLVM_REQUIRES_RTTI=1" ; For some third-party utilities
|
||||
"-DLLVM_INSTALL_UTILS=ON")) ; Needed for rustc.
|
||||
;; Don't use '-g' during the build, to save space.
|
||||
#:build-type "Release"
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-after 'install 'install-opt-viewer
|
||||
(lambda* (#:key outputs #:allow-other-keys)
|
||||
(let* ((out (assoc-ref outputs "out"))
|
||||
(opt-viewer-out (assoc-ref outputs "opt-viewer"))
|
||||
(opt-viewer-share-dir (string-append opt-viewer-out "/share"))
|
||||
(opt-viewer-dir (string-append opt-viewer-share-dir "/opt-viewer")))
|
||||
(mkdir-p opt-viewer-share-dir)
|
||||
(rename-file (string-append out "/share/opt-viewer")
|
||||
opt-viewer-dir)))))))
|
||||
(home-page "https://www.llvm.org")
|
||||
(synopsis "Optimizing compiler infrastructure")
|
||||
(description
|
||||
"LLVM is a compiler infrastructure designed for compile-time, link-time,
|
||||
runtime, and idle-time optimization of programs from arbitrary programming
|
||||
languages. It currently supports compilation of C and C++ programs, using
|
||||
front-ends derived from GCC 4.0.1. A new front-end for the C family of
|
||||
languages is in development. The compiler infrastructure includes mirror sets
|
||||
of programming tools as well as libraries with equivalent functionality.")
|
||||
(license license:asl2.0)))
|
||||
|
||||
(define-public clang-runtime-13
|
||||
(clang-runtime-from-llvm
|
||||
llvm-13
|
||||
"0gyvfhnypfmlf7hdgkiz2wh2lgk4nz26aqf361msjs3qdkbh4djc"))
|
||||
|
||||
(define-public clang-13
|
||||
(let ((template
|
||||
(clang-from-llvm llvm-13 clang-runtime-13
|
||||
"0zp1p6syii5iajm8v2c207s80arv00yz5ckfwimn5dng0sxiqqax"
|
||||
#:patches '("clang-13.0-libc-search-path.patch")
|
||||
#:tools-extra
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (llvm-uri "clang-tools-extra"
|
||||
(package-version llvm-13)))
|
||||
(sha256
|
||||
(base32
|
||||
"1mgalgdgxlxi08yxw7k6yh4iia1bpjmjgn7mrpqas8lbl9h612s2"))))))
|
||||
(package
|
||||
(inherit template)
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments template)
|
||||
((#:phases phases '%standard-phases)
|
||||
`(modify-phases ,phases
|
||||
;; This fails because the target to
|
||||
;; lib/clang/13.0.0/share/cfi_blacklist.txt is not found.
|
||||
(delete 'validate-runpath))))))))
|
||||
|
||||
(define-public clang-toolchain-13
|
||||
(make-clang-toolchain clang-13))
|
||||
|
||||
(define-public llvm-12
|
||||
(package
|
||||
(inherit llvm-13)
|
||||
(version "12.0.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (llvm-uri "llvm" version))
|
||||
(sha256
|
||||
(base32
|
||||
"1pzx9zrmd7r3481sbhwvkms68fwhffpp4mmz45dgrkjpyl2q96kx"))))
|
||||
(arguments
|
||||
;; TODO(core-updates): Unconditionally use quasiquote
|
||||
`(#:configure-flags
|
||||
|
@ -553,17 +644,7 @@ (define-public llvm-12
|
|||
(mkdir-p opt-viewer-share-dir)
|
||||
(rename-file (string-append out "/share/opt-viewer")
|
||||
opt-viewer-dir))
|
||||
#t)))))
|
||||
(home-page "https://www.llvm.org")
|
||||
(synopsis "Optimizing compiler infrastructure")
|
||||
(description
|
||||
"LLVM is a compiler infrastructure designed for compile-time, link-time,
|
||||
runtime, and idle-time optimization of programs from arbitrary programming
|
||||
languages. It currently supports compilation of C and C++ programs, using
|
||||
front-ends derived from GCC 4.0.1. A new front-end for the C family of
|
||||
languages is in development. The compiler infrastructure includes mirror sets
|
||||
of programming tools as well as libraries with equivalent functionality.")
|
||||
(license license:asl2.0))) ;with LLVM exceptions, see LICENSE.txt
|
||||
#t)))))))
|
||||
|
||||
(define-public clang-runtime-12
|
||||
(clang-runtime-from-llvm
|
||||
|
|
96
gnu/packages/patches/clang-13.0-libc-search-path.patch
Normal file
96
gnu/packages/patches/clang-13.0-libc-search-path.patch
Normal file
|
@ -0,0 +1,96 @@
|
|||
Clang attempts to guess file names based on the OS and distro (yes!),
|
||||
but unfortunately, that doesn't work for us.
|
||||
|
||||
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
||||
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
||||
the distro-specific stuff and removes the hard-coded FHS directory names
|
||||
to make sure Clang also works on foreign distros.
|
||||
|
||||
diff --git a/lib/Driver/Distro.cpp b/lib/Driver/Distro.cpp
|
||||
index ee4fe841..f0313bbe 100644
|
||||
--- a/lib/Driver/Distro.cpp
|
||||
+++ b/lib/Driver/Distro.cpp
|
||||
@@ -93,6 +93,10 @@ static Distro::DistroType DetectLsbRelease(llvm::vfs::FileSystem &VFS) {
|
||||
}
|
||||
|
||||
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS) {
|
||||
+ // The compiler should always behave the same, even when used via Guix on a
|
||||
+ // foreign distro.
|
||||
+ return Distro::UnknownDistro;
|
||||
+
|
||||
Distro::DistroType Version = Distro::UnknownDistro;
|
||||
|
||||
// Newer freedesktop.org's compilant systemd-based systems
|
||||
diff --git a/lib/Driver/ToolChains/Cuda.cpp b/lib/Driver/ToolChains/Cuda.cpp
|
||||
index d14776c5..88bc3ccd 100644
|
||||
--- a/lib/Driver/ToolChains/Cuda.cpp
|
||||
+++ b/lib/Driver/ToolChains/Cuda.cpp
|
||||
@@ -119,6 +119,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
||||
const Driver &D, const llvm::Triple &HostTriple,
|
||||
const llvm::opt::ArgList &Args)
|
||||
: D(D) {
|
||||
+ // Don't look for CUDA in /usr.
|
||||
+ return;
|
||||
+
|
||||
struct Candidate {
|
||||
std::string Path;
|
||||
bool StrictChecking;
|
||||
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
||||
--- a/lib/Driver/ToolChains/Linux.cpp
|
||||
+++ b/lib/Driver/ToolChains/Linux.cpp
|
||||
@@ -186,6 +186,10 @@
|
||||
|
||||
Generic_GCC::PushPPaths(PPaths);
|
||||
|
||||
+ // Comment out the distro-specific tweaks so that they don't bite when
|
||||
+ // using Guix on a foreign distro.
|
||||
+#if 0
|
||||
+
|
||||
Distro Distro(D.getVFS(), Triple);
|
||||
|
||||
if (Distro.IsAlpineLinux() || Triple.isAndroid()) {
|
||||
@@ -251,6 +255,7 @@
|
||||
|
||||
if (IsAndroid || Distro.IsOpenSUSE())
|
||||
ExtraOpts.push_back("--enable-new-dtags");
|
||||
+#endif
|
||||
|
||||
// The selection of paths to try here is designed to match the patterns which
|
||||
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
||||
@@ -264,6 +269,7 @@
|
||||
|
||||
Generic_GCC::AddMultilibPaths(D, SysRoot, OSLibDir, MultiarchTriple, Paths);
|
||||
|
||||
+#if 0
|
||||
addPathIfExists(D, SysRoot + "/lib/" + MultiarchTriple, Paths);
|
||||
addPathIfExists(D, SysRoot + "/lib/../" + OSLibDir, Paths);
|
||||
|
||||
@@ -295,9 +301,11 @@
|
||||
addPathIfExists(D, SysRoot + "/" + OSLibDir + "/" + ABIName, Paths);
|
||||
addPathIfExists(D, SysRoot + "/usr/" + OSLibDir + "/" + ABIName, Paths);
|
||||
}
|
||||
+#endif
|
||||
|
||||
Generic_GCC::AddMultiarchPaths(D, SysRoot, OSLibDir, Paths);
|
||||
|
||||
+#if 0
|
||||
// Similar to the logic for GCC above, if we are currently running Clang
|
||||
// inside of the requested system root, add its parent library path to those
|
||||
// searched.
|
||||
@@ -305,9 +313,14 @@
|
||||
// directory ('Dir' below) or the ResourceDir.
|
||||
if (StringRef(D.Dir).startswith(SysRoot))
|
||||
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
||||
+#endif
|
||||
+
|
||||
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
||||
+ // and friends can be found.
|
||||
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
||||
|
||||
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
||||
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
||||
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
||||
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
||||
}
|
||||
|
||||
ToolChain::RuntimeLibType Linux::GetDefaultRuntimeLibType() const {
|
Loading…
Reference in a new issue