mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: ffmpeg: Enable tests.
* gnu/packages/video.scm (ffmpeg): Add upstream patch and re-enable tests. * gnu/packages/patches/ffmpeg-check.patch: New file. * gnu-system.am (dist_patch_DATA): Register patch.
This commit is contained in:
parent
49d294e5c8
commit
e7de5ac0d5
3 changed files with 21 additions and 3 deletions
|
@ -228,6 +228,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/dbus-localstatedir.patch \
|
||||
gnu/packages/patches/diffutils-gets-undeclared.patch \
|
||||
gnu/packages/patches/emacs-configure-sh.patch \
|
||||
gnu/packages/patches/ffmpeg-check.patch \
|
||||
gnu/packages/patches/findutils-absolute-paths.patch \
|
||||
gnu/packages/patches/flac-fix-memcmp-not-declared.patch \
|
||||
gnu/packages/patches/flex-bison-tests.patch \
|
||||
|
|
15
gnu/packages/patches/ffmpeg-check.patch
Normal file
15
gnu/packages/patches/ffmpeg-check.patch
Normal file
|
@ -0,0 +1,15 @@
|
|||
See https://trac.ffmpeg.org/ticket/3177 .
|
||||
|
||||
diff --git a/libavcodec/cabac.c b/libavcodec/cabac.c
|
||||
index 29b188b..dff0a91 100644
|
||||
--- a/libavcodec/cabac.c
|
||||
+++ b/libavcodec/cabac.c
|
||||
@@ -301,7 +301,7 @@ STOP_TIMER("get_cabac_bypass")
|
||||
|
||||
for(i=0; i<SIZE; i++){
|
||||
START_TIMER
|
||||
- if( (r[i]&1) != get_cabac(&c, state) )
|
||||
+ if( (r[i]&1) != get_cabac_noinline(&c, state) )
|
||||
av_log(NULL, AV_LOG_ERROR, "CABAC failure at %d\n", i);
|
||||
STOP_TIMER("get_cabac")
|
||||
}
|
|
@ -21,6 +21,7 @@ (define-module (gnu packages video)
|
|||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages algebra)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages fontutils)
|
||||
|
@ -41,7 +42,9 @@ (define-public ffmpeg
|
|||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))))
|
||||
"1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))
|
||||
;; from upstream, drop with next release
|
||||
(patches (list (search-patch "ffmpeg-check.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("bc" ,bc)
|
||||
|
@ -57,8 +60,7 @@ (define-public ffmpeg
|
|||
("yasm" ,yasm)
|
||||
("zlib", zlib)))
|
||||
(arguments
|
||||
`(#:tests? #f ; see https://trac.ffmpeg.org/ticket/3177
|
||||
#:phases
|
||||
`(#:phases
|
||||
(alist-replace
|
||||
'configure
|
||||
;; configure does not work followed by "SHELL=..." and
|
||||
|
|
Loading…
Reference in a new issue