gnu: qtwayland-5: Update to 5.15.10.

* gnu/packages/qt.scm (qtwayland-5): Update to 5.15.10.
[source]: Remove qtwayland-gcc-11.patch patch.
* gnu/packages/patches/qtwayland-gcc-11.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
This commit is contained in:
Maxim Cournoyer 2023-08-15 16:20:05 -04:00
parent 70fed689c0
commit e89704d84a
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 3 additions and 23 deletions

View file

@ -1880,7 +1880,6 @@ dist_patch_DATA = \
%D%/packages/patches/quagga-reproducible-build.patch \
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
%D%/packages/patches/quilt-grep-compat.patch \
%D%/packages/patches/qtwayland-gcc-11.patch \
%D%/packages/patches/qtwayland-dont-recreate-callbacks.patch \
%D%/packages/patches/qtwayland-cleanup-callbacks.patch \
%D%/packages/patches/ragel-char-signedness.patch \

View file

@ -1,18 +0,0 @@
Add missing import for newer libstdc++.
Taken from upstream:
https://github.com/qt/qtwayland/commit/1aa6ec2c778504d96543f6cdc2b9199a7b066fc1
diff --git a/tests/auto/client/shared/corecompositor.cpp b/tests/auto/client/shared/corecompositor.cpp
index 5c6c83baa..fa9b7662a 100644
--- a/tests/auto/client/shared/corecompositor.cpp
+++ b/tests/auto/client/shared/corecompositor.cpp
@@ -27,6 +27,7 @@
****************************************************************************/
#include "corecompositor.h"
+#include <thread>
namespace MockCompositor {

View file

@ -1729,16 +1729,15 @@ (define-public qtwayland-5
(package
(inherit qtsvg-5)
(name "qtwayland")
(version "5.15.8")
(version "5.15.10")
(source (origin
(method url-fetch)
(uri (qt-url name version))
(patches (search-patches "qtwayland-gcc-11.patch"
"qtwayland-dont-recreate-callbacks.patch"
(patches (search-patches "qtwayland-dont-recreate-callbacks.patch"
"qtwayland-cleanup-callbacks.patch"))
(sha256
(base32
"0aa5jcvvap6qca6imdkhs1mhv5bnaxn466mmpl7x78jx1za7n3ps"))))
"1w9nclz1lfg5haq3m6ihils0kl2n1pqagdyh71ry1m281w8gvly8"))))
(arguments
(substitute-keyword-arguments (package-arguments qtsvg-5)
((#:phases phases)