mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: diffutils: Update to 3.7.
* gnu/packages/base.scm (diffutils): Update to 3.7. [source]: Remove patch. [native-inputs]: Add perl. * gnu/packages/commencement.scm (diffutils-boot0)[native-inputs]: Don't add perl. * gnu/packages/patches/diffutils-getopt.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
17f4334622
commit
e992d56669
4 changed files with 4 additions and 48 deletions
|
@ -657,7 +657,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/deja-dup-use-ref-keyword-for-iter.patch \
|
||||
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
|
||||
%D%/packages/patches/diffutils-gets-undeclared.patch \
|
||||
%D%/packages/patches/diffutils-getopt.patch \
|
||||
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \
|
||||
%D%/packages/patches/doc++-include-directives.patch \
|
||||
%D%/packages/patches/doc++-segfault-fix.patch \
|
||||
|
|
|
@ -245,16 +245,16 @@ (define-public patch
|
|||
(define-public diffutils
|
||||
(package
|
||||
(name "diffutils")
|
||||
(version "3.6")
|
||||
(version "3.7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/diffutils/diffutils-"
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1mivg0fy3a6fcn535ln8nkgfj6vxh5hsxxs5h6692wxmsjyyh8fn"))
|
||||
(patches (search-patches "diffutils-getopt.patch"))))
|
||||
"09isrg0isjinv8c535nxsi1s86wfdfzml80dbw41dj9x3hiad9xk"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("perl" ,perl)))
|
||||
(synopsis "Comparing and merging files")
|
||||
(description
|
||||
"GNU Diffutils is a package containing tools for finding the
|
||||
|
|
|
@ -1430,6 +1430,7 @@ (define diffutils-boot0
|
|||
#:guile %bootstrap-guile)))
|
||||
(package (inherit p)
|
||||
(name "diffutils-boot0")
|
||||
(native-inputs `())
|
||||
(arguments `(#:tests? #f ; the test suite needs diffutils
|
||||
,@(package-arguments p)))))))
|
||||
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
commit e3461d1c21a99bcef1b8826f710434e0ffb5adea
|
||||
Author: Paul Eggert <eggert@cs.ucla.edu>
|
||||
Date: Sun Jun 11 15:53:09 2017 -0700
|
||||
|
||||
getopt-posix: port to glibc 2.25.90
|
||||
|
||||
Problem reported by Daniel P. Berrange in:
|
||||
http://lists.gnu.org/archive/html/bug-gnulib/2017-06/msg00003.html
|
||||
* lib/getopt-pfx-core.h (_GETOPT_CORE_H):
|
||||
* lib/getopt-pfx-ext.h (_GETOPT_EXT_H):
|
||||
#undef if __GETOPT_PREFIX is defined.
|
||||
|
||||
diff --git a/lib/getopt-pfx-core.h b/lib/getopt-pfx-core.h
|
||||
index 155c11612..6ad0da683 100644
|
||||
--- a/lib/getopt-pfx-core.h
|
||||
+++ b/lib/getopt-pfx-core.h
|
||||
@@ -47,6 +47,11 @@
|
||||
# define opterr __GETOPT_ID (opterr)
|
||||
# define optind __GETOPT_ID (optind)
|
||||
# define optopt __GETOPT_ID (optopt)
|
||||
+
|
||||
+/* The system's getopt.h may have already included getopt-core.h to
|
||||
+ declare the unprefixed identifiers. Undef _GETOPT_CORE_H so that
|
||||
+ getopt-core.h declares them with prefixes. */
|
||||
+# undef _GETOPT_CORE_H
|
||||
#endif
|
||||
|
||||
#include <getopt-core.h>
|
||||
diff --git a/lib/getopt-pfx-ext.h b/lib/getopt-pfx-ext.h
|
||||
index d960bb34e..c5ac52202 100644
|
||||
--- a/lib/getopt-pfx-ext.h
|
||||
+++ b/lib/getopt-pfx-ext.h
|
||||
@@ -45,6 +45,11 @@
|
||||
# define getopt_long_only __GETOPT_ID (getopt_long_only)
|
||||
# define option __GETOPT_ID (option)
|
||||
# define _getopt_internal __GETOPT_ID (getopt_internal)
|
||||
+
|
||||
+/* The system's getopt.h may have already included getopt-ext.h to
|
||||
+ declare the unprefixed identifiers. Undef _GETOPT_EXT_H so that
|
||||
+ getopt-ext.h declares them with prefixes. */
|
||||
+# undef _GETOPT_EXT_H
|
||||
#endif
|
||||
|
||||
/* Standalone applications get correct prototypes for getopt_long and
|
Loading…
Reference in a new issue