mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-12 06:06:53 -05:00
gnu: efl: Fix build on 32-bit architectures.
* gnu/packages/patches/efl-mesa-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/enlightenment.scm (efl)[source](patches): Use it.
This commit is contained in:
parent
33eb63da64
commit
e99d036828
3 changed files with 23 additions and 0 deletions
|
@ -659,6 +659,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/doxygen-test.patch \
|
%D%/packages/patches/doxygen-test.patch \
|
||||||
%D%/packages/patches/dropbear-CVE-2018-15599.patch \
|
%D%/packages/patches/dropbear-CVE-2018-15599.patch \
|
||||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||||
|
%D%/packages/patches/efl-mesa-compat.patch \
|
||||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||||
%D%/packages/patches/einstein-build.patch \
|
%D%/packages/patches/einstein-build.patch \
|
||||||
%D%/packages/patches/emacs-exec-path.patch \
|
%D%/packages/patches/emacs-exec-path.patch \
|
||||||
|
|
|
@ -70,6 +70,7 @@ (define-public efl
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"https://download.enlightenment.org/rel/libs/efl/efl-"
|
"https://download.enlightenment.org/rel/libs/efl/efl-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
|
(patches (search-patches "efl-mesa-compat.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0a5907h896pvpix7a6idc2fspzy6d78xrzf84k8y9fyvnd14nxs4"))))
|
"0a5907h896pvpix7a6idc2fspzy6d78xrzf84k8y9fyvnd14nxs4"))))
|
||||||
|
|
21
gnu/packages/patches/efl-mesa-compat.patch
Normal file
21
gnu/packages/patches/efl-mesa-compat.patch
Normal file
|
@ -0,0 +1,21 @@
|
||||||
|
Fix build on 32-bit architectures with Mesa 18.3. Patch taken from upstream:
|
||||||
|
|
||||||
|
https://git.enlightenment.org/core/efl.git/commit/?id=0d2b624f1e24240a1c4e651aa1cfe9a8dd10a573
|
||||||
|
|
||||||
|
diff --git a/src/lib/evas/Evas_GL.h b/src/lib/evas/Evas_GL.h
|
||||||
|
index b6b642400f..4f67b1695f 100644
|
||||||
|
--- a/src/lib/evas/Evas_GL.h
|
||||||
|
+++ b/src/lib/evas/Evas_GL.h
|
||||||
|
@@ -4272,9 +4272,11 @@ typedef signed int GLfixed; // Changed khronos_int32_t
|
||||||
|
|
||||||
|
#ifndef GL_ES_VERSION_2_0
|
||||||
|
/* GL types for handling large vertex buffer objects */
|
||||||
|
-#include <stddef.h>
|
||||||
|
+# ifndef GL_VERSION_1_5
|
||||||
|
+# include <stddef.h>
|
||||||
|
typedef ptrdiff_t GLintptr; // Changed khronos_intptr_t
|
||||||
|
typedef ptrdiff_t GLsizeiptr; // Changed khronos_ssize_t
|
||||||
|
+# endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
/* Some definitions from GLES 3.0.
|
Loading…
Reference in a new issue