mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: Add jfsutils.
* gnu/packages/file-systems.scm (jfsutils): New public variable.
This commit is contained in:
parent
f92ebd57e4
commit
e9e75da6e1
4 changed files with 87 additions and 0 deletions
|
@ -1030,6 +1030,8 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/java-xerces-build_dont_unzip.patch \
|
||||
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
|
||||
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
|
||||
%D%/packages/patches/jfsutils-add-sysmacros.patch \
|
||||
%D%/packages/patches/jfsutils-include-systypes.patch \
|
||||
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
|
||||
%D%/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch \
|
||||
%D%/packages/patches/libvirt-create-machine-cgroup.patch \
|
||||
|
|
|
@ -111,6 +111,40 @@ (define-public httpfs2
|
|||
single file can be mounted.")
|
||||
(license license:gpl2+)))
|
||||
|
||||
(define-public jfsutils
|
||||
(package
|
||||
(name "jfsutils")
|
||||
(version "1.1.15")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://jfs.sourceforge.net/project/pub/jfsutils-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "0kbsy2sk1jv4m82rxyl25gwrlkzvl3hzdga9gshkxkhm83v1aji4"))
|
||||
(patches (search-patches "jfsutils-add-sysmacros.patch"
|
||||
"jfsutils-include-systypes.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("util-linux" ,util-linux)))
|
||||
(home-page "http://jfs.sourceforge.net/home.html")
|
||||
(synopsis "Utilities for managing JFS file systems")
|
||||
(description
|
||||
"The JFSutils are a collection of utilities for managing the @acronym{JFS,
|
||||
Journaled File System}, a 64-bit journaling file system created by IBM and later
|
||||
ported to the kernel Linux. The following commands are available:
|
||||
@enumerate
|
||||
@item @command{fsck.jfs}: check and repair a JFS file system or replay its
|
||||
transaction log.
|
||||
@item @command{logdump}: dump the JFS journal log.
|
||||
@item @command{logredo}: replay the JFS journal log.
|
||||
@item @command{mkfs.jfs}: create a new JFS file system.
|
||||
@item @command{xchklog}: save a JFS fsck log to a file.
|
||||
@item @command{xchkdmp}: dump the contents of such a log file.
|
||||
@item @command{xpeek}: a JFS file system editor with a shell-like interface.
|
||||
@end enumerate\n")
|
||||
(license license:gpl3+))) ; no explicit version given
|
||||
|
||||
(define-public disorderfs
|
||||
(package
|
||||
(name "disorderfs")
|
||||
|
|
26
gnu/packages/patches/jfsutils-add-sysmacros.patch
Normal file
26
gnu/packages/patches/jfsutils-add-sysmacros.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Thu, 12 Dec 2019 02:15:37 +0100
|
||||
Subject: gnu: jfsutils: Include sys/sysmacros.h.
|
||||
|
||||
Copied verbatim[0] from the Debian package.
|
||||
|
||||
[0]: https://sources.debian.org/patches/jfsutils/1.1.15-4/add_sysmacros.patch
|
||||
|
||||
Description: Include sys/sysmacros.h
|
||||
Mentioned header needed for major() definition.
|
||||
Author: Laszlo Boszormenyi (GCS) <gcs@debian.org>
|
||||
Last-Update: 2018-12-11
|
||||
|
||||
---
|
||||
|
||||
--- jfsutils-1.1.15.orig/libfs/devices.c
|
||||
+++ jfsutils-1.1.15/libfs/devices.c
|
||||
@@ -49,6 +49,8 @@
|
||||
#include <sys/disklabel.h>
|
||||
#endif
|
||||
|
||||
+#include <sys/sysmacros.h>
|
||||
+
|
||||
#include "jfs_types.h"
|
||||
#include "jfs_filsys.h"
|
||||
#include "devices.h"
|
25
gnu/packages/patches/jfsutils-include-systypes.patch
Normal file
25
gnu/packages/patches/jfsutils-include-systypes.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From: Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
Date: Thu, 12 Dec 2019 02:15:37 +0100
|
||||
Subject: gnu: jfsutils: Include sys/types.h.
|
||||
|
||||
Copied verbatim[0] from the Debian package.
|
||||
|
||||
[0]: https://sources.debian.org/patches/jfsutils/1.1.15-4/missing-includes.diff
|
||||
|
||||
Description: Add missing include to fix FTBFS with eglibc 2.17
|
||||
Origin: vendor, http://patches.ubuntu.com/j/jfsutils/jfsutils_1.1.15-2ubuntu1.patch
|
||||
Bug-Debian: http://bugs.debian.org/701433
|
||||
Last-Update: 2013-07-05
|
||||
|
||||
Index: b/fscklog/extract.c
|
||||
===================================================================
|
||||
--- a/fscklog/extract.c 2006-06-05 19:31:40.000000000 +0000
|
||||
+++ b/fscklog/extract.c 2013-04-02 07:13:08.737654963 +0000
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
+#include <sys/types.h>
|
||||
|
||||
#include "devices.h"
|
||||
#include "diskmap.h"
|
Loading…
Reference in a new issue