gnu: zlib: Update to 1.2.13.

* gnu/packages/compression.scm (zlib): Update to 1.2.13.
[source]: Remove patches.
* gnu/packages/patches/zlib-cc.patch,
gnu/packages/patches/zlib-correct-crc32-inputs.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
This commit is contained in:
Efraim Flashner 2022-11-14 18:42:41 +02:00
parent beb418bbf4
commit eb3362cc8d
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
4 changed files with 2 additions and 71 deletions

View file

@ -1999,8 +1999,6 @@ dist_patch_DATA = \
%D%/packages/patches/xterm-370-explicit-xcursor.patch \
%D%/packages/patches/xygrib-fix-finding-data.patch \
%D%/packages/patches/yggdrasil-extra-config.patch \
%D%/packages/patches/zlib-cc.patch \
%D%/packages/patches/zlib-correct-crc32-inputs.patch \
%D%/packages/patches/zig-use-system-paths.patch
MISC_DISTRO_FILES = \

View file

@ -100,7 +100,7 @@ (define-module (gnu packages compression)
(define-public zlib
(package
(name "zlib")
(version "1.2.12")
(version "1.2.13")
(source
(origin
(method url-fetch)
@ -108,11 +108,9 @@ (define-public zlib
version ".tar.gz")
(string-append "mirror://sourceforge/libpng/zlib/"
version "/zlib-" version ".tar.gz")))
(patches (search-patches "zlib-cc.patch"
"zlib-correct-crc32-inputs.patch"))
(sha256
(base32
"1n9na4fq4wagw1nzsfjr6wyly960jfa94460ncbf6p1fac44i14i"))))
"0c5b8vw40dy178xlpddw65q9gf1h2186jcc3p4swinwggbllv8mk"))))
(build-system gnu-build-system)
(outputs '("out" "static"))
(arguments

View file

@ -1,21 +0,0 @@
Fix configure issue that discarded provided CC definition.
Taken from upstream:
https://github.com/madler/zlib/commit/05796d3d8d5546cf1b4dfe2cd72ab746afae505d
diff --git a/configure b/configure
index 52ff4a04e..3fa3e8618 100755
--- a/configure
+++ b/configure
@@ -174,7 +174,10 @@ if test -z "$CC"; then
else
cc=${CROSS_PREFIX}cc
fi
+else
+ cc=${CC}
fi
+
cflags=${CFLAGS-"-O3"}
# to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
case "$cc" in

View file

@ -1,44 +0,0 @@
Correct incorrect inputs provided to the CRC functions.
Taken from upstream:
https://github.com/madler/zlib/commit/ec3df00224d4b396e2ac6586ab5d25f673caa4c2
diff --git a/crc32.c b/crc32.c
index a1bdce5c2..451887bc7 100644
--- a/crc32.c
+++ b/crc32.c
@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
#endif /* DYNAMIC_CRC_TABLE */
/* Pre-condition the CRC */
- crc ^= 0xffffffff;
+ crc = (~crc) & 0xffffffff;
/* Compute the CRC up to a word boundary. */
while (len && ((z_size_t)buf & 7) != 0) {
@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
#endif /* DYNAMIC_CRC_TABLE */
/* Pre-condition the CRC */
- crc ^= 0xffffffff;
+ crc = (~crc) & 0xffffffff;
#ifdef W
@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
#ifdef DYNAMIC_CRC_TABLE
once(&made, make_crc_table);
#endif /* DYNAMIC_CRC_TABLE */
- return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
+ return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
}
/* ========================================================================= */
@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
uLong crc2;
uLong op;
{
- return multmodp(op, crc1) ^ crc2;
+ return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
}