mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: WebkitGTK: Fix build failure with ICU 65.
* gnu/packages/patches/webkitgtk-icu-65.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/webkit.scm (webkitgtk)[source](patches): New field.
This commit is contained in:
parent
84f1e12b8b
commit
eb5f3ea100
3 changed files with 49 additions and 0 deletions
|
@ -1464,6 +1464,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/wavpack-CVE-2018-7253.patch \
|
||||
%D%/packages/patches/wavpack-CVE-2018-7254.patch \
|
||||
%D%/packages/patches/weasyprint-library-paths.patch \
|
||||
%D%/packages/patches/webkitgtk-icu-65.patch \
|
||||
%D%/packages/patches/websocketpp-fix-for-boost-1.70.patch \
|
||||
%D%/packages/patches/wicd-bitrate-none-fix.patch \
|
||||
%D%/packages/patches/wicd-get-selected-profile-fix.patch \
|
||||
|
|
47
gnu/packages/patches/webkitgtk-icu-65.patch
Normal file
47
gnu/packages/patches/webkitgtk-icu-65.patch
Normal file
|
@ -0,0 +1,47 @@
|
|||
Fix build with ICU 65.
|
||||
|
||||
Taken from upstream:
|
||||
https://bugs.webkit.org/show_bug.cgi?id=202600
|
||||
https://trac.webkit.org/r250747
|
||||
|
||||
diff --git a/Source/WTF/wtf/URLHelpers.cpp b/Source/WTF/wtf/URLHelpers.cpp
|
||||
index 18e7f13cd615..c584f1a0cb7e 100644
|
||||
--- a/Source/WTF/wtf/URLHelpers.cpp
|
||||
+++ b/Source/WTF/wtf/URLHelpers.cpp
|
||||
@@ -301,7 +301,7 @@ static bool allCharactersInIDNScriptWhiteList(const UChar* buffer, int32_t lengt
|
||||
Optional<UChar32> previousCodePoint;
|
||||
while (i < length) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(buffer, i, length, c)
|
||||
+ U16_NEXT(buffer, i, length, c);
|
||||
UErrorCode error = U_ZERO_ERROR;
|
||||
UScriptCode script = uscript_getScript(c, &error);
|
||||
if (error != U_ZERO_ERROR) {
|
||||
diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
|
||||
index 2443e24c9bc4..1fbb3a716006 100644
|
||||
--- a/Source/WebCore/dom/Document.cpp
|
||||
+++ b/Source/WebCore/dom/Document.cpp
|
||||
@@ -4954,12 +4954,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
|
||||
unsigned i = 0;
|
||||
|
||||
UChar32 c;
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (!isValidNameStart(c))
|
||||
return false;
|
||||
|
||||
while (i < length) {
|
||||
- U16_NEXT(characters, i, length, c)
|
||||
+ U16_NEXT(characters, i, length, c);
|
||||
if (!isValidNamePart(c))
|
||||
return false;
|
||||
}
|
||||
@@ -5019,7 +5019,7 @@ ExceptionOr<std::pair<AtomString, AtomString>> Document::parseQualifiedName(cons
|
||||
|
||||
for (unsigned i = 0; i < length; ) {
|
||||
UChar32 c;
|
||||
- U16_NEXT(qualifiedName, i, length, c)
|
||||
+ U16_NEXT(qualifiedName, i, length, c);
|
||||
if (c == ':') {
|
||||
if (sawColon)
|
||||
return Exception { InvalidCharacterError };
|
|
@ -126,6 +126,7 @@ (define-public webkitgtk
|
|||
(method url-fetch)
|
||||
(uri (string-append "https://www.webkitgtk.org/releases/"
|
||||
"webkitgtk-" version ".tar.xz"))
|
||||
(patches (search-patches "webkitgtk-icu-65.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"04k5h0sid9azsqz9pyq436v1rx4lnfrhvmcgmicqb0c0g9iz103b"))))
|
||||
|
|
Loading…
Reference in a new issue