mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: lirc: Update to 0.10.2.
* gnu/packages/lirc.scm (lirc): Update to 0.10.2. [arguments]: Add a new 'build-reproducibly phase to partially replace… * gnu/packages/patches/lirc-reproducible-build.patch: …this updated file.
This commit is contained in:
parent
ea37595a7c
commit
ec3226c398
2 changed files with 22 additions and 56 deletions
|
@ -38,14 +38,14 @@ (define-module (gnu packages lirc)
|
|||
(define-public lirc
|
||||
(package
|
||||
(name "lirc")
|
||||
(version "0.10.1")
|
||||
(version "0.10.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/lirc/LIRC/" version
|
||||
"/lirc-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1whlyifvvc7w04ahq07nnk1h18wc8j7c6wnvlb6mszravxh3qxcb"))
|
||||
"0ai27l6hxfgkwvkqa3fy1b1gqzw2y10md030y5ig4748fj1fqi1x"))
|
||||
(patches (search-patches "lirc-localstatedir.patch"
|
||||
"lirc-reproducible-build.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
|
@ -91,7 +91,10 @@ (define-public lirc
|
|||
(lambda _
|
||||
(substitute* "Makefile.in"
|
||||
(("(PYTHON_TARBALL.*=).*" _ tarball=)
|
||||
(string-append tarball= "\n"))))))))
|
||||
(string-append tarball= "\n")))))
|
||||
(add-before 'configure 'build-reproducibly
|
||||
(lambda _
|
||||
(setenv "LIRC_IRDB_CACHE_ID" "build time"))))))
|
||||
(native-inputs
|
||||
(list pkg-config libxslt))
|
||||
(inputs
|
||||
|
|
|
@ -5,11 +5,22 @@ https://sourceforge.net/p/lirc/git/merge-requests/33/
|
|||
https://sourceforge.net/p/lirc/git/merge-requests/34/
|
||||
https://sourceforge.net/p/lirc/git/merge-requests/36/
|
||||
|
||||
Index: lirc-0.10.1/tools/lirc-lsplugins.cpp
|
||||
===================================================================
|
||||
--- lirc-0.10.1.orig/tools/lirc-lsplugins.cpp
|
||||
+++ lirc-0.10.1/tools/lirc-lsplugins.cpp
|
||||
@@ -415,10 +415,9 @@ static void print_header(void)
|
||||
diff -Naur lirc-0.10.2a/python-pkg/lirc/database.py lirc-0.10.2/python-pkg/lirc/database.py
|
||||
--- lirc-0.10.2a/python-pkg/lirc/database.py 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ lirc-0.10.2/python-pkg/lirc/database.py 2023-01-20 14:23:29.414088668 +0100
|
||||
@@ -160,7 +160,7 @@
|
||||
d['device_hint'] = hint
|
||||
|
||||
configs = {}
|
||||
- for path in glob.glob(configdir + '/*.conf'):
|
||||
+ for path in sorted(glob.glob(configdir + '/*.conf')):
|
||||
with open(path) as f:
|
||||
cf = yaml.load(f.read(), Loader = Loader)
|
||||
configs[cf['config']['id']] = cf['config']
|
||||
diff -Naur lirc-0.10.2a/tools/lirc-lsplugins.cpp lirc-0.10.2/tools/lirc-lsplugins.cpp
|
||||
--- lirc-0.10.2a/tools/lirc-lsplugins.cpp 1970-01-01 01:00:01.000000000 +0100
|
||||
+++ lirc-0.10.2/tools/lirc-lsplugins.cpp 2023-01-20 14:24:42.719085612 +0100
|
||||
@@ -413,10 +413,9 @@
|
||||
static void print_yaml_header(void)
|
||||
{
|
||||
static const char* const YAML_HEADER =
|
||||
|
@ -22,51 +33,3 @@ Index: lirc-0.10.1/tools/lirc-lsplugins.cpp
|
|||
printf("\ndrivers:\n");
|
||||
}
|
||||
|
||||
Index: lirc-0.10.1/python-pkg/lirc/database.py
|
||||
===================================================================
|
||||
--- lirc-0.10.1.orig/python-pkg/lirc/database.py
|
||||
+++ lirc-0.10.1/python-pkg/lirc/database.py
|
||||
@@ -156,7 +156,7 @@ class Database(object):
|
||||
d['device_hint'] = hint
|
||||
|
||||
configs = {}
|
||||
- for path in glob.glob(configdir + '/*.conf'):
|
||||
+ for path in sorted(glob.glob(configdir + '/*.conf')):
|
||||
with open(path) as f:
|
||||
cf = yaml.load(f.read())
|
||||
configs[cf['config']['id']] = cf['config']
|
||||
Index: lirc-0.10.1/tools/irdb-get
|
||||
===================================================================
|
||||
--- lirc-0.10.1.orig/tools/irdb-get
|
||||
+++ lirc-0.10.1/tools/irdb-get
|
||||
@@ -9,7 +9,6 @@ import fnmatch
|
||||
import os
|
||||
import os.path
|
||||
import sys
|
||||
-import time
|
||||
import urllib.error # pylint: disable=no-name-in-module,F0401,E0611
|
||||
import urllib.request # pylint: disable=no-name-in-module,F0401,E0611
|
||||
|
||||
@@ -193,7 +192,7 @@ def do_yaml_config():
|
||||
lircmd_by_driver[driver].append("%s/%s" % (tokens[0], tokens[2]))
|
||||
|
||||
print("#")
|
||||
- print("# Created by 'irdb-get yaml-config' at " + time.ctime())
|
||||
+ print("# Created by 'irdb-get yaml-config'")
|
||||
print("#")
|
||||
print("\nlircd_by_driver:")
|
||||
print_yaml_dict(lircd_by_driver)
|
||||
Index: lirc-0.10.1/tools/lirc-make-devinput
|
||||
===================================================================
|
||||
--- lirc-0.10.1.orig/tools/lirc-make-devinput
|
||||
+++ lirc-0.10.1/tools/lirc-make-devinput
|
||||
@@ -61,8 +61,7 @@ if test -n "$lirc_map"; then
|
||||
fi
|
||||
|
||||
|
||||
-echo "# Generated by $(basename $0) on $(uname -r)"
|
||||
-echo "# Date: $(date)"
|
||||
+echo "# Generated by $(basename $0)"
|
||||
cat <<EOF
|
||||
|
||||
begin remote
|
||||
|
|
Loading…
Reference in a new issue