mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 05:18:07 -05:00
gnu: quilt: Update to 0.66.
* gnu/packages/patchutils.scm (quilt): Update to 0.66. [source]: Remove all patches. * gnu/packages/patches/quilt-test-fix-regex.patch, gnu/packages/patches/quilt-getopt-nondigit-param.patch, gnu/packages/patches/quilt-getopt-second-separator.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
This commit is contained in:
parent
d2f477ba82
commit
eea75c435a
5 changed files with 6 additions and 157 deletions
|
@ -1220,9 +1220,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||
%D%/packages/patches/quickswitch-fix-dmenu-check.patch \
|
||||
%D%/packages/patches/quilt-test-fix-regex.patch \
|
||||
%D%/packages/patches/quilt-getopt-nondigit-param.patch \
|
||||
%D%/packages/patches/quilt-getopt-second-separator.patch \
|
||||
%D%/packages/patches/qtwebkit-pbutils-include.patch \
|
||||
%D%/packages/patches/randomjungle-disable-static-build.patch \
|
||||
%D%/packages/patches/rapicorn-isnan.patch \
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
From: Jean Delvare <jdelvare@suse.de>
|
||||
Subject: compat/getopt: Allow non-digit parameter embedded in short option
|
||||
|
||||
The compatibility getopt script allows only digit parameters to be
|
||||
embedded in short options. Util-linux's getopt implementation does
|
||||
not have such a restriction and allows any parameter to be embedded
|
||||
in short options. As a consequence, using the compatibility getopt
|
||||
script would choke for example on "-pab", which is a legal option
|
||||
of the "quilt refresh" command.
|
||||
|
||||
Remove the limitation on digits so that the compatibility getopt
|
||||
script allows what util-linux allows. This fixes the second half
|
||||
of bug #54772:
|
||||
https://savannah.nongnu.org/bugs/index.php?54772
|
||||
|
||||
As a side note, this feature of the compatibility script was broken
|
||||
anyway, as it would output the digits in reverse order.
|
||||
|
||||
Signed-off-by: Jean Delvare <jdelvare@suse.de>
|
||||
---
|
||||
compat/getopt.in | 13 ++++---------
|
||||
1 file changed, 4 insertions(+), 9 deletions(-)
|
||||
|
||||
--- quilt.orig/compat/getopt.in 2018-10-03 16:05:56.818667040 +0200
|
||||
+++ quilt/compat/getopt.in 2018-10-03 16:12:17.624841732 +0200
|
||||
@@ -108,15 +108,10 @@ foreach my $word (@words) {
|
||||
if (scalar(@letters) == 0) {
|
||||
$need_param = $letter;
|
||||
} else {
|
||||
- # short options can have numerical args
|
||||
- # embedded in the short option list: -UO
|
||||
- die "unexpected character after option $letter"
|
||||
- if ($letters[$#letters] !~ /[0-9]/);
|
||||
- my @digits;
|
||||
- while (scalar(@letters) && ($letters[$#letters] =~ /[0-9]/)) {
|
||||
- push @digits, pop @letters;
|
||||
- }
|
||||
- push @options, quote_word(join('', reverse @digits));
|
||||
+ # short options can have args
|
||||
+ # embedded in the short option list
|
||||
+ push @options, quote_word(join('', reverse @letters));
|
||||
+ @letters = ();
|
||||
}
|
||||
}
|
||||
}
|
|
@ -1,58 +0,0 @@
|
|||
From: Jean Delvare <jdelvare@suse.de>
|
||||
Subject: compat/getopt: Handle a second separator
|
||||
|
||||
getopt can be passed 2 '--' separators. The first one tells that
|
||||
getopt options are over and target program options start. The second
|
||||
one tells that the target program's options are over and following
|
||||
arguments should be treated as non-options even if they look like
|
||||
options.
|
||||
|
||||
This second separator was not handled, causing the compatibility
|
||||
getopt script to treat the following arguments as options, eventually
|
||||
failing one way or another.
|
||||
|
||||
Properly detect and handle the second separator. This fixes the first
|
||||
half of bug #54772:
|
||||
https://savannah.nongnu.org/bugs/index.php?54772
|
||||
|
||||
Signed-off-by: Jean Delvare <jdelvare@suse.de>
|
||||
---
|
||||
compat/getopt.in | 13 ++++++++++---
|
||||
1 file changed, 10 insertions(+), 3 deletions(-)
|
||||
|
||||
--- quilt.orig/compat/getopt.in 2018-10-03 15:23:21.147620172 +0200
|
||||
+++ quilt/compat/getopt.in 2018-10-03 16:05:56.818667040 +0200
|
||||
@@ -8,12 +8,12 @@
|
||||
|
||||
use strict;
|
||||
|
||||
-my $opts;
|
||||
+my $opts = '';
|
||||
my @words;
|
||||
my $found_sep = 0;
|
||||
|
||||
foreach my $arg (@ARGV) {
|
||||
- if ($arg eq '--') {
|
||||
+ if (!$found_sep && $arg eq '--') {
|
||||
$found_sep = 1;
|
||||
}
|
||||
else {
|
||||
@@ -62,10 +62,17 @@ sub quote_word
|
||||
return "'$word'";
|
||||
}
|
||||
|
||||
+# there can be a second separator, to inhibit processing following arguments
|
||||
+# as options
|
||||
+$found_sep = 0;
|
||||
foreach my $word (@words) {
|
||||
+ if ($word eq '--') {
|
||||
+ $found_sep = 1;
|
||||
+ next;
|
||||
+ }
|
||||
|
||||
# allow '-' to be an option value
|
||||
- if (!$need_param && $word !~ /^-./) {
|
||||
+ if ($found_sep || (!$need_param && $word !~ /^-./)) {
|
||||
push @barewords, quote_word($word);
|
||||
next;
|
||||
}
|
|
@ -1,41 +0,0 @@
|
|||
From 5193b137b5a9034ce79946edd40760df2f63a82a Mon Sep 17 00:00:00 2001
|
||||
From: Jean Delvare <jdelvare@suse.de>
|
||||
Date: Tue, 25 Apr 2017 15:17:53 +0200
|
||||
Subject: test: Escape curly braces in regex
|
||||
|
||||
Curly braces in perl regex are supposed to be escaped, recent
|
||||
versions of perl complain when they aren't:
|
||||
|
||||
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE (\w+)}/ at ./run line 114.
|
||||
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/%{ <-- HERE \?}/ at ./run line 290.
|
||||
|
||||
Signed-off-by: Jean Delvare <jdelvare@suse.de>
|
||||
---
|
||||
test/run | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/test/run b/test/run
|
||||
index 942014e..03afc7a 100755
|
||||
--- a/test/run
|
||||
+++ b/test/run
|
||||
@@ -112,7 +112,7 @@ sub flush_output()
|
||||
sub substitute_vars($)
|
||||
{
|
||||
my ($line) = @_;
|
||||
- $line =~ s[%{(\w+)}][defined $ENV{$1} ? $ENV{$1} : ""]eg;
|
||||
+ $line =~ s[%\{(\w+)\}][defined $ENV{$1} ? $ENV{$1} : ""]eg;
|
||||
return $line;
|
||||
}
|
||||
|
||||
@@ -288,7 +288,7 @@ while (defined(my $line = <SOURCE>)) {
|
||||
# Parse the next command
|
||||
if ($line =~ s/^\s*\$ ?//) {
|
||||
# Substitute %{?} with the last command's status
|
||||
- $line =~ s[%{\?}][$last_status]eg;
|
||||
+ $line =~ s[%\{\?\}][$last_status]eg;
|
||||
|
||||
chomp($prog = substitute_vars($line));
|
||||
$prog_line = $lineno;
|
||||
--
|
||||
cgit v1.0-41-gc330
|
||||
|
|
@ -98,18 +98,14 @@ (define-public patchutils
|
|||
(define-public quilt
|
||||
(package
|
||||
(name "quilt")
|
||||
(version "0.65")
|
||||
(version "0.66")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://savannah/quilt/"
|
||||
"quilt-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"06b816m2gz9jfif7k9v2hrm7fz76zjg5pavf7hd3ifybwn4cgjzn"))
|
||||
(patches (search-patches "quilt-test-fix-regex.patch"
|
||||
"quilt-getopt-second-separator.patch"
|
||||
"quilt-getopt-nondigit-param.patch"))))
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://savannah/quilt/"
|
||||
"quilt-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "01vfvk4pqigahx82fhaaffg921ivd3k7rylz1yfvy4zbdyd32jri"))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("gettext" ,gnu-gettext)))
|
||||
|
|
Loading…
Reference in a new issue