gnu: python-waitress: Update to 3.0.0.

* gnu/packages/python-xyz.scm (python-waitress): Update to 3.0.0.
[build-system]: Use pyproject-build-system.
[arguments]: Disable failing test.
* gnu/packages/patches/python-waitress-fix-tests.patch: Delete no longer
needed patch.
* gnu/local.mk: Delete patch line.

Change-Id: I5397649e30098627de8c24f6afa2b74413d3446a
This commit is contained in:
jgart 2024-07-22 17:45:26 -05:00
parent 119d658d75
commit efc2682640
No known key found for this signature in database
GPG key ID: A52AA2B477B6DD35
3 changed files with 7 additions and 34 deletions

View file

@ -1989,7 +1989,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-unittest2-remove-argparse.patch \
%D%/packages/patches/python-vega-datasets-remove-la-riots-code.patch \
%D%/packages/patches/python-versioneer-guix-support.patch \
%D%/packages/patches/python-waitress-fix-tests.patch \
%D%/packages/patches/python-werkzeug-tests.patch \
%D%/packages/patches/python-xmp-toolkit-add-missing-error-codes.patch \
%D%/packages/patches/python-zeep-Fix-pytest_httpx-test-cases.patch \

View file

@ -1,29 +0,0 @@
Skip test that requires getaddrinfo(), which is not available in the build
environment. This package uses a regexp for finding tests (see runner.py),
so using @unittest.skip does not work.
--- a/waitress/tests/test_adjustments.py
+++ b/waitress/tests/test_adjustments.py
@@ -185,22 +185,6 @@
def test_bad_port(self):
self.assertRaises(ValueError, self._makeOne, listen='127.0.0.1:test')
- def test_service_port(self):
- if WIN and PY2: # pragma: no cover
- # On Windows and Python 2 this is broken, so we raise a ValueError
- self.assertRaises(
- ValueError,
- self._makeOne,
- listen='127.0.0.1:http',
- )
- return
-
- inst = self._makeOne(listen='127.0.0.1:http 0.0.0.0:https')
-
- bind_pairs = [sockaddr[:2] for (_, _, _, sockaddr) in inst.listen]
-
- self.assertEqual(bind_pairs, [('127.0.0.1', 80), ('0.0.0.0', 443)])
-
def test_dont_mix_host_port_listen(self):
self.assertRaises(
ValueError,

View file

@ -19254,16 +19254,19 @@ (define-public python-mako
(define-public python-waitress
(package
(name "python-waitress")
(version "1.1.0")
(version "3.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "waitress" version))
(patches (search-patches "python-waitress-fix-tests.patch"))
(sha256
(base32
"1a85gyji0kajc3p0s1pwwfm06w4wfxjkvvl4rnrz3h164kbd6g6k"))))
(build-system python-build-system)
"18dq4bibsv6cfhv6a3b16w2xwycxqkkiwbb0vpcwsd21n1ws8p80"))))
(build-system pyproject-build-system)
(arguments
;; https://github.com/Pylons/waitress/issues/443
(list #:test-flags #~(list "-k" "not test_service_port")))
(native-inputs (list python-pytest python-pytest-cov))
(home-page "https://github.com/Pylons/waitress")
(synopsis "Waitress WSGI server")
(description "Waitress is meant to be a production-quality pure-Python WSGI