mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-11 13:49:23 -05:00
gnu: nghttp2: Update to 1.49.0.
* gnu/packages/web.scm (nghttp2): Update to 1.49.0. * gnu/packages/curl.scm (curl)[source](patches): Add compatibility patch. * gnu/packages/patches/curl-nghttp2-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
0877f66987
commit
f0cf6b5a32
4 changed files with 145 additions and 2 deletions
|
@ -988,6 +988,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/clucene-contribs-lib.patch \
|
||||
%D%/packages/patches/cube-nocheck.patch \
|
||||
%D%/packages/patches/curl-easy-lock.patch \
|
||||
%D%/packages/patches/curl-nghttp2-compat.patch \
|
||||
%D%/packages/patches/curl-use-ssl-cert-env.patch \
|
||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||
%D%/packages/patches/cvs-CVE-2017-12836.patch \
|
||||
|
|
|
@ -72,6 +72,7 @@ (define-public curl
|
|||
(base32
|
||||
"1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
|
||||
(patches (search-patches "curl-use-ssl-cert-env.patch"
|
||||
"curl-nghttp2-compat.patch"
|
||||
"curl-easy-lock.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out"
|
||||
|
|
141
gnu/packages/patches/curl-nghttp2-compat.patch
Normal file
141
gnu/packages/patches/curl-nghttp2-compat.patch
Normal file
|
@ -0,0 +1,141 @@
|
|||
Use CRLF headers in test responses to cope with newer nghttp2.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/curl/curl/commit/ef121401d6eabed204a716f16b2776ededc75c0e
|
||||
|
||||
diff --git a/tests/data/test1700 b/tests/data/test1700
|
||||
index 8b1ef4ae336c3..7f78bcf5f92ed 100644
|
||||
--- a/tests/data/test1700
|
||||
+++ b/tests/data/test1700
|
||||
@@ -11,26 +11,26 @@ HTTP/2
|
||||
# Server-side
|
||||
<reply>
|
||||
<data nocheck="yes">
|
||||
-HTTP/1.1 200 OK
|
||||
-Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
-Server: test-server/fake
|
||||
-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
-ETag: "21025-dc7-39462498"
|
||||
-Accept-Ranges: bytes
|
||||
-Content-Length: 6
|
||||
-Connection: close
|
||||
-Content-Type: text/html
|
||||
-Funny-head: yesyes
|
||||
-
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
+Server: test-server/fake
|
||||
+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
+ETag: "21025-dc7-39462498"
|
||||
+Accept-Ranges: bytes
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+
|
||||
-foo-
|
||||
</data>
|
||||
<data1>
|
||||
-HTTP/1.1 200 OK
|
||||
-Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
-Content-Length: 6
|
||||
-Connection: close
|
||||
-Content-Type: text/html
|
||||
-
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+
|
||||
-maa-
|
||||
</data1>
|
||||
</reply>
|
||||
diff --git a/tests/data/test1701 b/tests/data/test1701
|
||||
index 3c1a2bd0b8217..22f6147d0503a 100644
|
||||
--- a/tests/data/test1701
|
||||
+++ b/tests/data/test1701
|
||||
@@ -11,17 +11,17 @@ HTTP/2
|
||||
# Server-side
|
||||
<reply>
|
||||
<data nocheck="yes">
|
||||
-HTTP/1.1 200 OK
|
||||
-Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
-Server: test-server/fake
|
||||
-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
-ETag: "21025-dc7-39462498"
|
||||
-Accept-Ranges: bytes
|
||||
-Content-Length: 6
|
||||
-Connection: close
|
||||
-Content-Type: text/html
|
||||
-Funny-head: yesyes
|
||||
-
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
+Server: test-server/fake
|
||||
+Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
|
||||
+ETag: "21025-dc7-39462498"
|
||||
+Accept-Ranges: bytes
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+
|
||||
-foo-
|
||||
</data>
|
||||
</reply>
|
||||
diff --git a/tests/data/test358 b/tests/data/test358
|
||||
index 8b4f6606247a0..0f8a9801bbcb5 100644
|
||||
--- a/tests/data/test358
|
||||
+++ b/tests/data/test358
|
||||
@@ -12,14 +12,14 @@ HTTP/2
|
||||
# Server-side
|
||||
<reply>
|
||||
<data nocheck="yes">
|
||||
-HTTP/1.1 200 OK
|
||||
-Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
-Content-Length: 6
|
||||
-Connection: close
|
||||
-Content-Type: text/html
|
||||
-Funny-head: yesyes
|
||||
-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
|
||||
-
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
|
||||
+
|
||||
-foo-
|
||||
</data>
|
||||
</reply>
|
||||
diff --git a/tests/data/test359 b/tests/data/test359
|
||||
index a5ba4e3ae0971..0e684e39e5aa5 100644
|
||||
--- a/tests/data/test359
|
||||
+++ b/tests/data/test359
|
||||
@@ -12,14 +12,14 @@ HTTP/2
|
||||
# Server-side
|
||||
<reply>
|
||||
<data nocheck="yes">
|
||||
-HTTP/1.1 200 OK
|
||||
-Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
-Content-Length: 6
|
||||
-Connection: close
|
||||
-Content-Type: text/html
|
||||
-Funny-head: yesyes
|
||||
-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
|
||||
-
|
||||
+HTTP/1.1 200 OK
|
||||
+Date: Tue, 09 Nov 2010 14:49:00 GMT
|
||||
+Content-Length: 6
|
||||
+Connection: close
|
||||
+Content-Type: text/html
|
||||
+Funny-head: yesyes
|
||||
+Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
|
||||
+
|
||||
-foo-
|
||||
</data>
|
||||
</reply>
|
|
@ -7493,7 +7493,7 @@ (define-public cat-avatar-generator
|
|||
(define-public nghttp2
|
||||
(package
|
||||
(name "nghttp2")
|
||||
(version "1.48.0")
|
||||
(version "1.49.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
|
@ -7502,7 +7502,7 @@ (define-public nghttp2
|
|||
"nghttp2-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1r0ns1r6g03wji273nk3bhrkmj1s3g5640yicqan5g7iwh7g7n27"))))
|
||||
"0vm692c7q2wc4xxz8c41nr8jps2fkwf51xp8fb233cghpf9d9kxh"))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs (list "out"
|
||||
"lib")) ; only libnghttp2
|
||||
|
|
Loading…
Reference in a new issue