mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
gnu: kodi: Increase test timeout.
* gnu/packages/patches/kodi-increase-test-timeout.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kodi.scm (kodi)[source](patches): Add it.
This commit is contained in:
parent
28391dc038
commit
f19e571c97
3 changed files with 20 additions and 0 deletions
|
@ -1017,6 +1017,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch \
|
%D%/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch \
|
||||||
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
|
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
|
||||||
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
|
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
|
||||||
|
%D%/packages/patches/kodi-increase-test-timeout.patch \
|
||||||
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
|
||||||
%D%/packages/patches/kodi-skip-test-449.patch \
|
%D%/packages/patches/kodi-skip-test-449.patch \
|
||||||
%D%/packages/patches/laby-make-install.patch \
|
%D%/packages/patches/laby-make-install.patch \
|
||||||
|
|
|
@ -282,6 +282,7 @@ (define-public kodi
|
||||||
(base32
|
(base32
|
||||||
"1m0295czxabdcqyqf5m94av9d88pzhnzjvyfs1q07xqq82h313p7"))
|
"1m0295czxabdcqyqf5m94av9d88pzhnzjvyfs1q07xqq82h313p7"))
|
||||||
(patches (search-patches "kodi-skip-test-449.patch"
|
(patches (search-patches "kodi-skip-test-449.patch"
|
||||||
|
"kodi-increase-test-timeout.patch"
|
||||||
"kodi-set-libcurl-ssl-parameters.patch"))
|
"kodi-set-libcurl-ssl-parameters.patch"))
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
|
|
18
gnu/packages/patches/kodi-increase-test-timeout.patch
Normal file
18
gnu/packages/patches/kodi-increase-test-timeout.patch
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
Increase thread timeout to reduce flakiness.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
|
||||||
|
|
||||||
|
diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
|
||||||
|
index 42fb8c2fc609..40e644c0ed3c 100644
|
||||||
|
--- a/xbmc/threads/test/TestEvent.cpp
|
||||||
|
+++ b/xbmc/threads/test/TestEvent.cpp
|
||||||
|
@@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
|
||||||
|
EXPECT_TRUE(w3.result == NULL);
|
||||||
|
|
||||||
|
// this should end given the wait is for only 50 millis
|
||||||
|
- EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
|
||||||
|
+ EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
|
||||||
|
|
||||||
|
EXPECT_TRUE(!w3.waiting);
|
||||||
|
EXPECT_TRUE(w3.result == NULL);
|
Loading…
Reference in a new issue