gnu: agg: Fix build.

* gnu/packages/patches/agg-2.5-gcc8.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/graphics.scm (agg)[source]: Use it.
This commit is contained in:
Mathieu Othacehe 2021-11-29 14:58:39 +01:00
parent 3d54f24156
commit f22dfba530
No known key found for this signature in database
GPG key ID: 8354763531769CA6
3 changed files with 17 additions and 1 deletions

View file

@ -836,6 +836,7 @@ dist_patch_DATA = \
%D%/packages/patches/aegisub-boost68.patch \
%D%/packages/patches/aegisub-make43.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
%D%/packages/patches/agg-2.5-gcc8.patch \
%D%/packages/patches/akonadi-paths.patch \
%D%/packages/patches/akonadi-not-relocatable.patch \
%D%/packages/patches/akonadi-timestamps.patch \

View file

@ -1539,7 +1539,8 @@ (define-public agg
version ".tar.gz")))
(sha256
(base32 "07wii4i824vy9qsvjsgqxppgqmfdxq0xa87i5yk53fijriadq7mb"))
(patches (search-patches "agg-am_c_prototype.patch"))))
(patches (search-patches "agg-am_c_prototype.patch"
"agg-2.5-gcc8.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags

View file

@ -0,0 +1,14 @@
Taken from: https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-libs/agg/files/agg-2.5-gcc8.patch.
diff -uprN agg-2.5/include/agg_renderer_outline_aa.h agg-2.5-fixed/include/agg_renderer_outline_aa.h
--- agg-2.5/include/agg_renderer_outline_aa.h 2018-08-25 02:02:52.507254241 +0800
+++ agg-2.5-fixed/include/agg_renderer_outline_aa.h 2018-08-25 02:04:15.291175316 +0800
@@ -1375,7 +1375,7 @@ namespace agg
//---------------------------------------------------------------------
void profile(const line_profile_aa& prof) { m_profile = &prof; }
const line_profile_aa& profile() const { return *m_profile; }
- line_profile_aa& profile() { return *m_profile; }
+ const line_profile_aa& profile() { return *m_profile; }
//---------------------------------------------------------------------
int subpixel_width() const { return m_profile->subpixel_width(); }