mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: cmh: Update to 1.1.1.
* gnu/packages/algebra.scm (cmh): Update to 1.1.1. * gnu/packages/patches/cmh-support-fplll.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Andreas Enge <andreas@enge.fr>
This commit is contained in:
parent
25d88eb9f3
commit
f3130fc7d9
3 changed files with 23 additions and 52 deletions
|
@ -975,7 +975,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/cling-use-shared-library.patch \
|
||||
%D%/packages/patches/clucene-pkgconfig.patch \
|
||||
%D%/packages/patches/cmake-curl-certificates.patch \
|
||||
%D%/packages/patches/cmh-support-fplll.patch \
|
||||
%D%/packages/patches/coda-use-system-libs.patch \
|
||||
%D%/packages/patches/collectd-5.11.0-noinstallvar.patch \
|
||||
%D%/packages/patches/containerd-create-pid-file.patch \
|
||||
|
|
|
@ -294,34 +294,33 @@ (define-public gp2c
|
|||
|
||||
(define-public cmh
|
||||
(package
|
||||
(name "cmh")
|
||||
(version "1.1.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
|
||||
(uri (string-append "http://www.multiprecision.org/downloads/cmh-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1ws2yhzxmm2l5xqqqcjcimmg40f9qq5l9i6d4i5434an9v9s8531"))
|
||||
(patches (search-patches "cmh-support-fplll.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
(list gmp
|
||||
mpfr
|
||||
mpc
|
||||
mpfrcx
|
||||
fplll
|
||||
pari-gp))
|
||||
(synopsis "Igusa class polynomial computations")
|
||||
(description
|
||||
"The CMH software computes Igusa (genus 2) class polynomials, which
|
||||
(name "cmh")
|
||||
(version "1.1.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
;; Git repo at <https://gitlab.inria.fr/cmh/cmh>.
|
||||
(uri (string-append
|
||||
"https://www.multiprecision.org/downloads/cmh-" version
|
||||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0nadvqfmidgks1s7aljsf8dp32pz7vjaxyaym36m9bx4zr8msk91"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs (list gmp
|
||||
mpfr
|
||||
mpc
|
||||
mpfrcx
|
||||
fplll
|
||||
pari-gp))
|
||||
(synopsis "Igusa class polynomial computations")
|
||||
(description
|
||||
"The CMH software computes Igusa (genus 2) class polynomials, which
|
||||
parameterize the CM points in the moduli space of 2-dimensional abelian
|
||||
varieties, i.e. Jacobians of hyperelliptic curves.
|
||||
It can also be used to compute theta constants at arbitrary
|
||||
precision.")
|
||||
(license license:gpl3+)
|
||||
(home-page "http://www.multiprecision.org/cmh/home.html")))
|
||||
(license license:gpl3+)
|
||||
(home-page "https://www.multiprecision.org/cmh/home.html")))
|
||||
|
||||
(define-public giac
|
||||
(package
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
Patch from the CMH git, after the 1.1.0 release.
|
||||
|
||||
From 2328c819317dda2171217002268f57c74cedc476 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Emmanuel=20Thom=C3=A9?= <Emmanuel.Thome@inria.fr>
|
||||
Date: Tue, 7 Jun 2022 12:17:05 -0700
|
||||
Subject: [PATCH] patch suggested by @x-YVicto
|
||||
|
||||
---
|
||||
src/lll.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lll.cpp b/src/lll.cpp
|
||||
index 83dab07..f005931 100644
|
||||
--- a/src/lll.cpp
|
||||
+++ b/src/lll.cpp
|
||||
@@ -37,7 +37,7 @@
|
||||
#ifdef HAVE_FPLLL
|
||||
static void lll_fplll (mpz_t *v, mpz_t **M, const int m, const int n)
|
||||
{
|
||||
- ZZ_mat <mpz_t> Mp (m, n);
|
||||
+ fplll::ZZ_mat <mpz_t> Mp (m, n);
|
||||
int i, j;
|
||||
|
||||
for (i = 0; i < m; i++)
|
||||
--
|
||||
2.36.1
|
||||
|
Loading…
Reference in a new issue