gnu: perl-class-methodmaker: Build reproducibly.

* gnu/packages/patches/perl-class-methodmaker-reproducible.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add patch.
* gnu/packages/perl.scm (perl-class-methodmaker)[source]: Use patch.
This commit is contained in:
Vagrant Cascadian 2022-08-19 21:06:50 -07:00 committed by Vagrant Cascadian
parent d2b85f8906
commit f31e55d081
No known key found for this signature in database
GPG key ID: DC518FC87F9716AA
3 changed files with 25 additions and 1 deletions

View file

@ -1624,6 +1624,7 @@ dist_patch_DATA = \
%D%/packages/patches/perl-5.14-module-pluggable-search.patch \
%D%/packages/patches/perl-5.14-no-sys-dirs.patch \
%D%/packages/patches/perl-autosplit-default-time.patch \
%D%/packages/patches/perl-class-methodmaker-reproducible.patch \
%D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
%D%/packages/patches/perl-image-exiftool-CVE-2021-22204.patch \
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \

View file

@ -0,0 +1,21 @@
Description: make build reproducible by sorting hash keys
cf. https://reproducible.debian.net/dbd/unstable/amd64/libclass-methodmaker-perl_2.21-1.debbindiff.html
Origin: vendor
Bug-Debian: https://bugs.debian.org/778979
Author: Chris Lamb <lamby@debian.org>
Reviewed-by: gregor herrmann <gregoa@debian.org>
Last-Update: 2015-05-02
Forwarded: https://rt.cpan.org/Ticket/Display.html?id=104163
Bug: https://rt.cpan.org/Ticket/Display.html?id=104163
--- a/lib/Class/MethodMaker/OptExt.pm
+++ b/lib/Class/MethodMaker/OptExt.pm
@@ -357,7 +357,7 @@
# -------------------------------------
-sub option_names { grep $_ ne 'DEFAULT', keys %{OPTEXT()} }
+sub option_names { grep $_ ne 'DEFAULT', sort keys %{OPTEXT()} }
sub optcode {
my $class = shift;

View file

@ -1601,7 +1601,9 @@ (define-public perl-class-methodmaker
version ".tar.gz"))
(sha256
(base32
"0a03i4k3a33qqwhykhz5k437ld5mag2vq52vvsy03gbynb65ivsy"))))
"0a03i4k3a33qqwhykhz5k437ld5mag2vq52vvsy03gbynb65ivsy"))
(patches (search-patches
"perl-class-methodmaker-reproducible.patch"))))
(build-system perl-build-system)
(home-page "https://metacpan.org/release/Class-MethodMaker")
(synopsis "Create generic methods for OO Perl")