mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 13:28:12 -05:00
gnu: clisp: Update to 2.49-60.
* gnu/packages/lisp.scm (clisp): Update to 2.49-60. [source]: Download mercurial repository, apply patch. [inputs]: Replace readline@6.2 with readline, add ncurses. [arguments]: Add multiple configure flags. Remove build phase to build in "src" directory. Remove more uses of a timestamp.
This commit is contained in:
parent
fa4f95a7c4
commit
f473b8f1f7
3 changed files with 65 additions and 11 deletions
|
@ -560,6 +560,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/chmlib-inttypes.patch \
|
||||
%D%/packages/patches/clang-libc-search-path.patch \
|
||||
%D%/packages/patches/clang-3.8-libc-search-path.patch \
|
||||
%D%/packages/patches/clisp-remove-failing-test.patch \
|
||||
%D%/packages/patches/clucene-pkgconfig.patch \
|
||||
%D%/packages/patches/clx-remove-demo.patch \
|
||||
%D%/packages/patches/cmake-fix-tests.patch \
|
||||
|
|
|
@ -33,6 +33,7 @@ (define-module (gnu packages lisp)
|
|||
#:use-module (gnu packages m4)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix git-download)
|
||||
#:use-module (guix hg-download)
|
||||
#:use-module (guix utils)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (guix build-system asdf)
|
||||
|
@ -42,6 +43,7 @@ (define-module (gnu packages lisp)
|
|||
#:use-module (gnu packages fontutils)
|
||||
#:use-module (gnu packages maths)
|
||||
#:use-module (gnu packages multiprecision)
|
||||
#:use-module (gnu packages ncurses)
|
||||
#:use-module (gnu packages bdw-gc)
|
||||
#:use-module (gnu packages libffi)
|
||||
#:use-module (gnu packages libffcall)
|
||||
|
@ -228,21 +230,31 @@ (define-public ecl
|
|||
(define-public clisp
|
||||
(package
|
||||
(name "clisp")
|
||||
(version "2.49")
|
||||
(version "2.49-60")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/clisp/release/" version
|
||||
"/clisp-" version ".tar.gz"))
|
||||
(method hg-fetch)
|
||||
(uri (hg-reference
|
||||
(url "http://hg.code.sf.net/p/clisp/clisp")
|
||||
(changeset "clisp_2_49_60-2017-06-25")))
|
||||
(file-name (string-append name "-" version "-checkout"))
|
||||
(sha256
|
||||
(base32 "0rp82nqp5362isl9i34rwgg04cidz7izljd9d85pqcw1qr964bxx"))))
|
||||
(base32 "0qjv3z274rbdmb941hy03hl63f4z7bmci234f8dyz4skgfr82d3i"))
|
||||
(patches (search-patches "clisp-remove-failing-test.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs `(("libffcall" ,libffcall)
|
||||
("readline" ,readline-6.2)
|
||||
("ncurses" ,ncurses)
|
||||
("readline" ,readline)
|
||||
("libsigsegv" ,libsigsegv)))
|
||||
(arguments
|
||||
'(;; XXX The custom configure script does not cope well when passed
|
||||
;; --build=<triplet>.
|
||||
#:configure-flags '("CFLAGS=-falign-functions=4"
|
||||
"--enable-portability"
|
||||
"--with-dynamic-ffi"
|
||||
"--with-dynamic-modules"
|
||||
"--with-module=bindings/glibc"
|
||||
"--with-module=rawsock")
|
||||
#:build #f
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
|
@ -262,11 +274,9 @@ (define-public clisp
|
|||
(lambda _
|
||||
(substitute* "src/constobj.d"
|
||||
(("__DATE__ __TIME__") "\"1\""))
|
||||
#t))
|
||||
(add-before 'build 'chdir-to-source
|
||||
(lambda _
|
||||
;; We are supposed to call make under the src sub-directory.
|
||||
(chdir "src")
|
||||
(substitute* "src/genclisph.d"
|
||||
(("__DATE__") "\"1\"")
|
||||
(("__TIME__") "\"1\""))
|
||||
#t)))
|
||||
;; Makefiles seem to have race conditions.
|
||||
#:parallel-build? #f))
|
||||
|
|
43
gnu/packages/patches/clisp-remove-failing-test.patch
Normal file
43
gnu/packages/patches/clisp-remove-failing-test.patch
Normal file
|
@ -0,0 +1,43 @@
|
|||
This test doesn't ever complete or timeout
|
||||
|
||||
---
|
||||
tests/socket.tst | 24 ------------------------
|
||||
1 file changed, 24 deletions(-)
|
||||
|
||||
diff --git a/tests/socket.tst b/tests/socket.tst
|
||||
index 93c6310..1d976ff 100644
|
||||
--- a/tests/socket.tst
|
||||
+++ b/tests/socket.tst
|
||||
@@ -551,30 +551,6 @@ T
|
||||
interfaces))
|
||||
("0.0.0.0" "127.0.0.1" "0.0.0.0" "127.0.0.1")
|
||||
|
||||
-(multiple-value-bind (run args) (cmd-args)
|
||||
- (let ((se (socket:socket-server)))
|
||||
- (ext:run-program run :arguments (append args (list "-q" "-q" "-x" (format nil "(close (socket:socket-connect ~D))" (socket:socket-server-port se))))
|
||||
- :wait nil :input nil :output nil)
|
||||
- (unwind-protect
|
||||
- (with-open-stream (so (socket:socket-accept se))
|
||||
- (list
|
||||
- (socket:socket-status so)
|
||||
- (write-line "foo" so)
|
||||
- (socket:socket-status so)
|
||||
- #+macos (handler-case (read-char so)
|
||||
- (end-of-file (c)
|
||||
- (princ 'read-char) (princ-error c) t))
|
||||
- #-macos (check-os-error (read-char so) (:ECONNRESET 104))
|
||||
- (null (member (socket:socket-status so) '(:EOF :APPEND)))
|
||||
- #+macos (string= (write-line "bar" so) "bar")
|
||||
- #-macos (check-os-error (write-line "bar" so) (:EPIPE 32))
|
||||
- (null (member (socket:socket-status so) '(:EOF :APPEND)))
|
||||
- (handler-case (read-char so)
|
||||
- (end-of-file (c)
|
||||
- (princ 'read-char) (princ-error c) 'end-of-file))))
|
||||
- (socket:socket-server-close se))))
|
||||
-(:OUTPUT "foo" :OUTPUT T NIL T NIL END-OF-FILE)
|
||||
-
|
||||
;; https://sourceforge.net/p/clisp/feature-requests/46/
|
||||
(check-os-error (socket:socket-connect 0)
|
||||
#-(or win32 macos) (:ECONNREFUSED 111)
|
||||
--
|
||||
|
Loading…
Reference in a new issue