mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-27 23:02:16 -05:00
gnu: gdb: Fix cross-compilation for Hurd.
* gnu/packages/patches/gdb-hurd.patch: Update it. * gnu/packages/gdb.scm (gdb)[source]: Add it.
This commit is contained in:
parent
5f1e33f76c
commit
f4d3e7b82b
2 changed files with 22 additions and 59 deletions
|
@ -52,7 +52,9 @@ (define-public gdb-10
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0aag1c0fw875pvhjg1qp7x8pf6gf92bjv5gcic5716scacyj58da"))))
|
"0aag1c0fw875pvhjg1qp7x8pf6gf92bjv5gcic5716scacyj58da"))
|
||||||
|
(patches
|
||||||
|
(search-patches "gdb-hurd.patch"))))
|
||||||
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
|
|
|
@ -1,69 +1,30 @@
|
||||||
Taken from upstream, removed ChangeLog.
|
Taken from upstream.
|
||||||
|
|
||||||
From 6930bffe3373690b3431d6291f9f7c116d6a1ec4 Mon Sep 17 00:00:00 2001
|
From dca11eb872c96f86388890b3750e450cc2a68700 Mon Sep 17 00:00:00 2001
|
||||||
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
From: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
||||||
Date: Sat, 30 May 2020 18:35:59 +0000
|
Date: Mon, 21 Dec 2020 16:01:07 +0000
|
||||||
Subject: [PATCH] hurd: fix gnu_debug_flag type
|
Subject: [PATCH] hurd: Fix getting VM_MIN/MAX_ADDRESS
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
Fixes
|
gnu-nat.c was getting the inclusion of vm_param.h only by luck. We need
|
||||||
|
to explicitly include it to be sure to get the definitions of
|
||||||
../../gdb/gnu-nat.c:96:6: error: conflicting declaration ‘bool gnu_debug_flag’
|
VM_MIN/MAX_ADDRESS.
|
||||||
96 | bool gnu_debug_flag = false;
|
|
||||||
../../gdb/gnu-nat.c: In function ‘void _initialize_gnu_nat()’:
|
|
||||||
../../gdb/gnu-nat.c:3511:7: error: cannot
|
|
||||||
|
|
||||||
gdb/ChangeLog:
|
gdb/ChangeLog:
|
||||||
|
|
||||||
* gnu-nat.h (gnu_debug_flag): Set type to bool.
|
* gnu-nat.c: Include <mach/vm_param.h>.
|
||||||
---
|
---
|
||||||
gdb/ChangeLog | 4 ++++
|
gdb/gnu-nat.c | 1 +
|
||||||
gdb/gnu-nat.h | 2 +-
|
1 file changed, 1 insertion(+)
|
||||||
2 files changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/gdb/gnu-nat.h b/gdb/gnu-nat.h
|
|
||||||
index 77c57817b2..766f716587 100644
|
|
||||||
--- a/gdb/gnu-nat.h
|
|
||||||
+++ b/gdb/gnu-nat.h
|
|
||||||
@@ -111,7 +111,7 @@ extern char *proc_string (struct proc *proc);
|
|
||||||
__proc_pid (__proc), __proc->tid, \
|
|
||||||
host_address_to_string (__proc) , ##args); } while (0)
|
|
||||||
|
|
||||||
-extern int gnu_debug_flag;
|
|
||||||
+extern bool gnu_debug_flag;
|
|
||||||
|
|
||||||
#define debug(msg, args...) \
|
|
||||||
do { if (gnu_debug_flag) \
|
|
||||||
--
|
|
||||||
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
|
|
||||||
Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
|
|
||||||
|
|
||||||
commit 366f550a593c7e6bae3699a4b6d65fe937af5603
|
|
||||||
Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
|
|
||||||
Date: Sat May 30 18:41:30 2020 +0000
|
|
||||||
|
|
||||||
hurd: add missing include
|
|
||||||
|
|
||||||
Fixes
|
|
||||||
|
|
||||||
../../gdb/gnu-nat.c:2522:14: error: ‘target_gdbarch’ was not declared in this scope; did you mean ‘target_detach’?
|
|
||||||
2522 | paddress (target_gdbarch (), memaddr), pulongest (len),
|
|
||||||
|
|
||||||
gdb/Changelog:
|
|
||||||
|
|
||||||
* gnu-nat.c: Include "gdbarch.h".
|
|
||||||
|
|
||||||
diff --git a/gdb/gnu-nat.c b/gdb/gnu-nat.c
|
diff --git a/gdb/gnu-nat.c b/gdb/gnu-nat.c
|
||||||
index 3b438a9a43..9b93488b41 100644
|
index 1693ce0c43d..6f290be0d51 100644
|
||||||
--- a/gdb/gnu-nat.c
|
--- a/gdb/gnu-nat.c
|
||||||
+++ b/gdb/gnu-nat.c
|
+++ b/gdb/gnu-nat.c
|
||||||
@@ -64,6 +64,7 @@ extern "C"
|
@@ -32,6 +32,7 @@ extern "C"
|
||||||
#include "language.h"
|
#include <mach/message.h>
|
||||||
#include "target.h"
|
#include <mach/notify.h>
|
||||||
#include "gdbsupport/gdb_wait.h"
|
#include <mach/vm_attributes.h>
|
||||||
+#include "gdbarch.h"
|
+#include <mach/vm_param.h>
|
||||||
#include "gdbcmd.h"
|
|
||||||
#include "gdbcore.h"
|
#include <hurd.h>
|
||||||
#include "gdbthread.h"
|
#include <hurd/interrupt.h>
|
||||||
|
|
Loading…
Reference in a new issue