mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: ghc@8.0: Remove obsolete patch.
* gnu/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/haskell.scm (ghc-8.0)[source](patches): Remove it.
This commit is contained in:
parent
c75db69371
commit
f4e1833205
3 changed files with 1 additions and 31 deletions
|
@ -932,7 +932,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/geoclue-config.patch \
|
||||
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
|
||||
%D%/packages/patches/ghc-testsuite-dlopen-pie.patch \
|
||||
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
|
||||
%D%/packages/patches/ghc-diff-swap-cover-args.patch \
|
||||
%D%/packages/patches/ghc-haddock-api-fix-haddock.patch \
|
||||
%D%/packages/patches/ghc-hpack-fix-tests.patch \
|
||||
|
|
|
@ -320,9 +320,7 @@ (define-public ghc-8.0
|
|||
(sha256
|
||||
(base32 "1c8qc4fhkycynk4g1f9hvk53dj6a1vvqi6bklqznns6hw59m8qhi"))
|
||||
(patches
|
||||
(search-patches
|
||||
"ghc-dont-pass-linker-flags-via-response-files.patch"
|
||||
"ghc-8.0-fall-back-to-madv_dontneed.patch"))))
|
||||
(search-patches "ghc-8.0-fall-back-to-madv_dontneed.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(supported-systems '("i686-linux" "x86_64-linux"))
|
||||
(outputs '("out" "doc"))
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
Don’t add linker flags via ‘response files’ since ld-wrapper
|
||||
doesn’t handle them.
|
||||
See https://github.com/NixOS/nixpkgs/commit/a421e7bd4a28c69bded8b17888325e31554f61a1
|
||||
https://gcc.gnu.org/ml/gcc/2016-10/msg00151.html
|
||||
|
||||
diff --git a/compiler/main/SysTools.hs.orig b/compiler/main/SysTools.hs
|
||||
index 1ab5b13..99270fc 100644
|
||||
--- a/compiler/main/SysTools.hs.orig
|
||||
+++ b/compiler/main/SysTools.hs
|
||||
@@ -424,7 +424,7 @@ runCc dflags args = do
|
||||
args1 = map Option (getOpts dflags opt_c)
|
||||
args2 = args0 ++ args1 ++ args
|
||||
mb_env <- getGccEnv args2
|
||||
- runSomethingResponseFile dflags cc_filter "C Compiler" p args2 mb_env
|
||||
+ runSomethingFiltered dflags cc_filter "C Compiler" p args2 mb_env
|
||||
where
|
||||
-- discard some harmless warnings from gcc that we can't turn off
|
||||
cc_filter = unlines . doFilter . lines
|
||||
@@ -945,7 +945,7 @@ runLink dflags args = do
|
||||
args1 = map Option (getOpts dflags opt_l)
|
||||
args2 = args0 ++ linkargs ++ args1 ++ args
|
||||
mb_env <- getGccEnv args2
|
||||
- runSomethingResponseFile dflags ld_filter "Linker" p args2 mb_env
|
||||
+ runSomethingFiltered dflags ld_filter "Linker" p args2 mb_env
|
||||
where
|
||||
ld_filter = case (platformOS (targetPlatform dflags)) of
|
||||
OSSolaris2 -> sunos_ld_filter
|
Loading…
Reference in a new issue