gnu: Update calibre to 3.0.0.

* gnu/local.mk: Remove patch.
* gnu/packages/ebook.scm (calibre): Update to 3.0.0.
* gnu/packages/patches/calibre-dont-load-remote-icons.patch: Remove file.
This commit is contained in:
Roel Janssen 2017-06-22 00:07:58 +02:00
parent bb19b2ebf3
commit f70f3407ca
No known key found for this signature in database
GPG key ID: C3EC1DCA843072E1
3 changed files with 10 additions and 50 deletions

View file

@ -522,7 +522,6 @@ dist_patch_DATA = \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/cairo-CVE-2016-9082.patch \
%D%/packages/patches/calibre-drop-unrar.patch \
%D%/packages/patches/calibre-dont-load-remote-icons.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-use-packaged-feedparser.patch \
%D%/packages/patches/cdparanoia-fpic.patch \

View file

@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@ -65,7 +66,7 @@ (define-public chmlib
(define-public calibre
(package
(name "calibre")
(version "2.85.1")
(version "3.0.0")
(source
(origin
(method url-fetch)
@ -74,7 +75,7 @@ (define-public calibre
version ".tar.xz"))
(sha256
(base32
"1g8s0kp1gj05yysfgqpp2lgrxvzc0fsny1hwzx5jh9hvqn0b53cc"))
"1zhk7bvgr973dd18x4wp48kzai29qqqi5qcy72sxc4wcbk2sbnkw"))
;; Remove non-free or doubtful code, see
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
(modules '((guix build utils)))
@ -84,13 +85,11 @@ (define-public calibre
(delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")
(delete-file-recursively "resources/fonts/liberation")
(delete-file-recursively "src/chardet")
(substitute* (find-files "." "\\.py")
(("calibre\\.ebooks\\.markdown") "markdown"))
#t))
(patches (search-patches "calibre-drop-unrar.patch"
"calibre-use-packaged-feedparser.patch"
"calibre-dont-load-remote-icons.patch"
"calibre-no-updates-dialog.patch"))))
(build-system python-build-system)
(native-inputs
@ -132,6 +131,7 @@ (define-public calibre
("python2-pygments" ,python2-pygments)
("python2-pyqt" ,python2-pyqt)
("python2-sip" ,python2-sip)
("python2-regex" ,python2-regex)
("sqlite" ,sqlite)))
(arguments
`(#:python ,python-2
@ -148,6 +148,12 @@ (define-public calibre
;; We can't use the uninstaller in Guix. Don't build it.
(("self\\.create_uninstaller()") ""))
#t))
(add-after 'unpack 'dont-load-remote-icons
(lambda _
(substitute* "setup/plugins_mirror.py"
(("href=\"//calibre-ebook.com/favicon.ico\"")
"href=\"favicon.ico\""))
#t))
(add-before 'build 'configure
(lambda* (#:key inputs #:allow-other-keys)
(let ((podofo (assoc-ref inputs "podofo"))

View file

@ -1,45 +0,0 @@
From: Martin Pitt <mpitt@debian.org>
Date: Mon, 14 Nov 2016 22:41:24 +0100
Subject: content-server: Don't load external URLs for privacy
Spotted by lintian.
---
resources/content_server/browse/browse.html | 4 +---
resources/content_server/index.html | 2 +-
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/resources/content_server/browse/browse.html b/resources/content_server/browse/browse.html
index 36f7199..e615707 100644
--- a/resources/content_server/browse/browse.html
+++ b/resources/content_server/browse/browse.html
@@ -7,7 +7,7 @@
<title>..:: calibre {library} ::.. {title}</title>
<meta http-equiv="X-UA-Compatible" content="IE=100" />
<meta name="robots" content="noindex" />
- <link rel="icon" type="image/x-icon" href="//calibre-ebook.com/favicon.ico" />
+ <link rel="icon" type="image/x-icon" href="favicon.ico" />
<link rel="stylesheet" type="text/css" href="{prefix}/static/browse/browse.css" />
<link type="text/css" href="{prefix}/static/jquery_ui/css/humanity-custom/jquery-ui-1.8.5.custom.css" rel="stylesheet" />
@@ -63,8 +63,6 @@
<input type="image"
src="{prefix}/static/button-donate.png"
name="submit"></input>
- <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif"
- width="1" height="1"></img>
</div>
</form>
<div id="calibre-home-link" title="Go to the calibre website"></div>
diff --git a/resources/content_server/index.html b/resources/content_server/index.html
index 51cc33a..e71d0e8 100644
--- a/resources/content_server/index.html
+++ b/resources/content_server/index.html
@@ -9,7 +9,7 @@
<script type="text/javascript" src="{prefix}/static/date.js" charset="utf-8"></script>
<script type="text/javascript" src="{prefix}/static/jquery.js" charset="utf-8"></script>
<script type="text/javascript" src="{prefix}/static/gui.js" charset="utf-8"></script>
- <link rel="icon" href="//calibre-ebook.com/favicon.ico" type="image/x-icon" />
+ <link rel="icon" href="favicon.ico" type="image/x-icon" />
</head>
<body>
<div id="banner">