mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 22:38:07 -05:00
gnu: samba: Update to 4.13.10.
* gnu/packages/samba.scm (samba): Update to 4.13.10. [source]: Remove patch. * gnu/packages/patches/samba-fix-fcntl-hint-detection.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
7aad3dea66
commit
f71b381d1f
3 changed files with 2 additions and 59 deletions
|
@ -1548,7 +1548,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
|
%D%/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch \
|
||||||
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
|
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
|
||||||
%D%/packages/patches/pthreadpool-system-libraries.patch \
|
%D%/packages/patches/pthreadpool-system-libraries.patch \
|
||||||
%D%/packages/patches/samba-fix-fcntl-hint-detection.patch \
|
|
||||||
%D%/packages/patches/sdcc-disable-non-free-code.patch \
|
%D%/packages/patches/sdcc-disable-non-free-code.patch \
|
||||||
%D%/packages/patches/sdl-pango-api_additions.patch \
|
%D%/packages/patches/sdl-pango-api_additions.patch \
|
||||||
%D%/packages/patches/sdl-pango-blit_overflow.patch \
|
%D%/packages/patches/sdl-pango-blit_overflow.patch \
|
||||||
|
|
|
@ -1,55 +0,0 @@
|
||||||
From 454ccd986b61799908a6898a55d0480911f15306 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Ralph Boehme <slow@samba.org>
|
|
||||||
Date: Mon, 21 Sep 2020 07:48:43 +0200
|
|
||||||
Subject: [PATCH] s3: fix fcntl waf configure check
|
|
||||||
|
|
||||||
RN: Fix fcntl waf configure check
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=14503
|
|
||||||
|
|
||||||
Signed-off-by: Ralph Boehme <slow@samba.org>
|
|
||||||
Reviewed-by: Volker Lendecke <vl@samba.org>
|
|
||||||
|
|
||||||
Autobuild-User(master): Volker Lendecke <vl@samba.org>
|
|
||||||
Autobuild-Date(master): Mon Sep 21 07:26:54 UTC 2020 on sn-devel-184
|
|
||||||
---
|
|
||||||
source3/wscript | 10 +++++-----
|
|
||||||
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source3/wscript b/source3/wscript
|
|
||||||
index 840ed430c0f..d3ef346eecd 100644
|
|
||||||
--- a/source3/wscript
|
|
||||||
+++ b/source3/wscript
|
|
||||||
@@ -1244,7 +1244,7 @@ err:
|
|
||||||
|
|
||||||
int main(void)
|
|
||||||
{
|
|
||||||
- uint64_t *hint, get_hint;
|
|
||||||
+ uint64_t hint, get_hint;
|
|
||||||
int fd;
|
|
||||||
|
|
||||||
fd = open(DATA, O_RDONLY | O_CREAT | O_EXCL);
|
|
||||||
@@ -1252,8 +1252,8 @@ int main(void)
|
|
||||||
goto err;
|
|
||||||
}
|
|
||||||
|
|
||||||
- *hint = RWH_WRITE_LIFE_SHORT;
|
|
||||||
- int ret = fcntl(fd, F_SET_RW_HINT, hint);
|
|
||||||
+ hint = RWH_WRITE_LIFE_SHORT;
|
|
||||||
+ int ret = fcntl(fd, F_SET_RW_HINT, &hint);
|
|
||||||
if (ret == -1) {
|
|
||||||
goto err;
|
|
||||||
}
|
|
||||||
@@ -1267,8 +1267,8 @@ int main(void)
|
|
||||||
goto err;
|
|
||||||
}
|
|
||||||
|
|
||||||
- *hint = RWH_WRITE_LIFE_EXTREME;
|
|
||||||
- ret = fcntl(fd, F_SET_FILE_RW_HINT, hint);
|
|
||||||
+ hint = RWH_WRITE_LIFE_EXTREME;
|
|
||||||
+ ret = fcntl(fd, F_SET_FILE_RW_HINT, &hint);
|
|
||||||
if (ret == -1) {
|
|
||||||
goto err;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
|
@ -172,15 +172,14 @@ (define (install dir)
|
||||||
(define-public samba
|
(define-public samba
|
||||||
(package
|
(package
|
||||||
(name "samba")
|
(name "samba")
|
||||||
(version "4.13.4")
|
(version "4.13.10")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://download.samba.org/pub/samba/stable/"
|
(uri (string-append "https://download.samba.org/pub/samba/stable/"
|
||||||
"samba-" version ".tar.gz"))
|
"samba-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "0y2wc7njhyhg055krp878xfv9c3wbhrhzn02d5ich30hyxilrcx1"))
|
(base32 "00q5hf2r71dyma785dckcyksv3082mqfgyy9q6k6rc6kqjwkirzh"))
|
||||||
(patches (search-patches "samba-fix-fcntl-hint-detection.patch"))
|
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
'(begin
|
'(begin
|
||||||
|
|
Loading…
Reference in a new issue