mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
gnu: texinfo: Fix @headings regression.
* gnu/packages/patches/texinfo-headings-single.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/texinfo.scm (texinfo)[source](patches): New field. * gnu/packages/commencement.scm (texinfo-boot0)[source]: Use BOOTSTRAP-ORIGIN.
This commit is contained in:
parent
e9afd8a005
commit
f7e8be2318
4 changed files with 24 additions and 0 deletions
|
@ -1837,6 +1837,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tcsh-fix-autotest.patch \
|
||||
%D%/packages/patches/teensy-loader-cli-help.patch \
|
||||
%D%/packages/patches/tensorflow-c-api-fix.patch \
|
||||
%D%/packages/patches/texinfo-headings-single.patch \
|
||||
%D%/packages/patches/texinfo-5-perl-compat.patch \
|
||||
%D%/packages/patches/telegram-purple-adjust-test.patch \
|
||||
%D%/packages/patches/texi2html-document-encoding.patch \
|
||||
|
|
|
@ -2609,6 +2609,7 @@ (define texinfo-boot0
|
|||
;; Also, use (%BOOT0-INPUTS) to avoid building Perl once more.
|
||||
(package
|
||||
(inherit texinfo)
|
||||
(source (bootstrap-origin (package-source texinfo)))
|
||||
(native-inputs '())
|
||||
(inputs `(,@(%boot0-inputs)
|
||||
("perl" ,perl-boot0)))
|
||||
|
|
21
gnu/packages/patches/texinfo-headings-single.patch
Normal file
21
gnu/packages/patches/texinfo-headings-single.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
Fix a regression in 6.8 where the 'single' headings option was not recognized.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://git.savannah.gnu.org/cgit/texinfo.git/commit/?id=13a8894fe2faa45b04033d7122a8fe7939ce6aa2
|
||||
|
||||
diff --git a/tp/Texinfo/XS/parsetexi/end_line.c b/tp/Texinfo/XS/parsetexi/end_line.c
|
||||
index 4556780052..3fc2065616 100644
|
||||
--- a/tp/Texinfo/XS/parsetexi/end_line.c
|
||||
+++ b/tp/Texinfo/XS/parsetexi/end_line.c
|
||||
@@ -778,8 +778,8 @@ kdbinputstyle_invalid:
|
||||
case CM_headings:
|
||||
{
|
||||
if (!strcmp (line, "off") || !strcmp (line, "on")
|
||||
- || !strcmp (line, "double") || !strcmp (line, "singleafter")
|
||||
- || !strcmp (line, "doubleafter"))
|
||||
+ || !strcmp (line, "single") || !strcmp (line, "double")
|
||||
+ || !strcmp (line, "singleafter") || !strcmp (line, "doubleafter"))
|
||||
{
|
||||
ADD_ARG(line);
|
||||
}
|
|
@ -52,6 +52,7 @@ (define-public texinfo
|
|||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/texinfo/texinfo-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "texinfo-headings-single.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1i7yb7mrp3inz25zbzv2pllr4y7d58v818f1as7iz8mw53nm7dwf"))))
|
||||
|
|
Loading…
Reference in a new issue