mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 05:48:07 -05:00
gnu: calibre: Disable bs4 test.
* gnu/packages/patches/calibre-remove-test-bs4.patch: New file. * gnu/packages/ebook.scm (calibre)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
This commit is contained in:
parent
6e1ab5fadb
commit
f89f5abada
3 changed files with 36 additions and 0 deletions
|
@ -690,6 +690,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/boost-fix-icu-build.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||
%D%/packages/patches/calibre-remove-test-bs4.patch \
|
||||
%D%/packages/patches/calibre-remove-test-unrar.patch \
|
||||
%D%/packages/patches/casync-renameat2-declaration.patch \
|
||||
%D%/packages/patches/catdoc-CVE-2017-11110.patch \
|
||||
|
|
|
@ -97,6 +97,7 @@ (define-public calibre
|
|||
(delete-file "src/odf/thumbnail.py")
|
||||
#t))
|
||||
(patches (search-patches "calibre-no-updates-dialog.patch"
|
||||
"calibre-remove-test-bs4.patch" ; TODO: fix test.
|
||||
"calibre-remove-test-unrar.patch"))))
|
||||
(build-system python-build-system)
|
||||
(native-inputs
|
||||
|
|
34
gnu/packages/patches/calibre-remove-test-bs4.patch
Normal file
34
gnu/packages/patches/calibre-remove-test-bs4.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
In my efforts to fix all Calibre tests, this test would always complain about
|
||||
backports.functools_lru_cache not existing even after I packaged and added
|
||||
python2-soupsieve as an input and confirmed it was in the
|
||||
PYTHONPATH. Currently Calibre does not actually use it for anything other than
|
||||
testing it's there, so I assume they will start using it in future Calibre
|
||||
versions.
|
||||
|
||||
From 2738dd42caebe55326c76922a12ba8740bdb22e7 Mon Sep 17 00:00:00 2001
|
||||
From: Brendan Tildesley <mail@brendan.scot>
|
||||
Date: Sat, 27 Apr 2019 00:42:39 +1000
|
||||
Subject: [PATCH] Remove test_bs4
|
||||
|
||||
---
|
||||
src/calibre/test_build.py | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/src/calibre/test_build.py b/src/calibre/test_build.py
|
||||
index 73f1172e8c..07bdffd3e5 100644
|
||||
--- a/src/calibre/test_build.py
|
||||
+++ b/src/calibre/test_build.py
|
||||
@@ -73,10 +73,6 @@ class BuildTest(unittest.TestCase):
|
||||
from html5_parser import parse
|
||||
parse('<p>xxx')
|
||||
|
||||
- def test_bs4(self):
|
||||
- import soupsieve, bs4
|
||||
- del soupsieve, bs4
|
||||
-
|
||||
def test_zeroconf(self):
|
||||
if ispy3:
|
||||
import zeroconf as z, ifaddr
|
||||
--
|
||||
2.21.0
|
||||
|
Loading…
Reference in a new issue