mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-26 14:28:15 -05:00
gnu: pigx-bsseq: Remove dependency on pandoc-citeproc.
* gnu/packages/patches/pigx-bsseq-no-citeproc.patch: Add patch. * gnu/local.mk: Register it. * gnu/packages/bioinformatics.scm (pigx-bsseq)[source]: Use it. [native-inputs]: Add automake/autoconf.
This commit is contained in:
parent
ff5fea3dfe
commit
fb1ffc53ba
3 changed files with 42 additions and 2 deletions
|
@ -1599,6 +1599,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/picard-fix-id3-rename-test.patch \
|
||||
%D%/packages/patches/picprog-non-intel-support.patch \
|
||||
%D%/packages/patches/pidgin-add-search-path.patch \
|
||||
%D%/packages/patches/pigx-bsseq-no-citeproc.patch \
|
||||
%D%/packages/patches/pinball-system-ltdl.patch \
|
||||
%D%/packages/patches/pingus-boost-headers.patch \
|
||||
%D%/packages/patches/pingus-sdl-libs-config.patch \
|
||||
|
|
|
@ -10644,7 +10644,8 @@ (define-public pigx-bsseq
|
|||
"/pigx_bsseq-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"05al5dacfp1vf1x3cq20jhd6w4xj5vaxslzaka6yrpg0av8sh3k3"))))
|
||||
"05al5dacfp1vf1x3cq20jhd6w4xj5vaxslzaka6yrpg0av8sh3k3"))
|
||||
(patches (search-patches "pigx-bsseq-no-citeproc.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(;; TODO: tests currently require 12+GB of RAM. See
|
||||
|
@ -10652,6 +10653,9 @@ (define-public pigx-bsseq
|
|||
#:tests? #f
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
(add-before 'bootstrap 'autoreconf
|
||||
(lambda _
|
||||
(invoke "autoreconf" "-vif")))
|
||||
(add-before 'check 'set-timezone
|
||||
;; The readr package is picky about timezones.
|
||||
(lambda* (#:key inputs #:allow-other-keys)
|
||||
|
@ -10660,7 +10664,9 @@ (define-public pigx-bsseq
|
|||
(string-append (assoc-ref inputs "tzdata")
|
||||
"/share/zoneinfo")))))))
|
||||
(native-inputs
|
||||
`(("tzdata" ,tzdata)))
|
||||
`(("tzdata" ,tzdata)
|
||||
("automake" ,automake)
|
||||
("autoconf" ,autoconf)))
|
||||
(inputs
|
||||
`(("coreutils" ,coreutils)
|
||||
("sed" ,sed)
|
||||
|
|
33
gnu/packages/patches/pigx-bsseq-no-citeproc.patch
Normal file
33
gnu/packages/patches/pigx-bsseq-no-citeproc.patch
Normal file
|
@ -0,0 +1,33 @@
|
|||
diff -Naur pigx_bsseq-0.1.5/configure.ac pigx_bsseq-0.1.5.patched/configure.ac
|
||||
--- pigx_bsseq-0.1.5/configure.ac 2021-06-08 15:28:08.000000000 +0200
|
||||
+++ pigx_bsseq-0.1.5.patched/configure.ac 2021-10-05 14:43:56.806529137 +0200
|
||||
@@ -38,7 +38,6 @@
|
||||
find_or_override_prog([GNUBASH], [bash])
|
||||
find_or_override_prog([SNAKEMAKE], [snakemake])
|
||||
find_or_override_prog([PANDOC], [pandoc])
|
||||
-find_or_override_prog([PANDOC_CITEPROC], [pandoc-citeproc])
|
||||
find_or_override_prog([FASTQC], [fastqc])
|
||||
find_or_override_prog([MULTIQC], [multiqc])
|
||||
find_or_override_prog([TRIMGALORE], [trim_galore])
|
||||
diff -Naur pigx_bsseq-0.1.5/Makefile.in pigx_bsseq-0.1.5.patched/Makefile.in
|
||||
--- pigx_bsseq-0.1.5/Makefile.in 2021-06-08 16:17:03.000000000 +0200
|
||||
+++ pigx_bsseq-0.1.5.patched/Makefile.in 2021-10-05 14:43:34.635876855 +0200
|
||||
@@ -408,7 +408,6 @@
|
||||
PACKAGE_URL = @PACKAGE_URL@
|
||||
PACKAGE_VERSION = @PACKAGE_VERSION@
|
||||
PANDOC = @PANDOC@
|
||||
-PANDOC_CITEPROC = @PANDOC_CITEPROC@
|
||||
PATH_SEPARATOR = @PATH_SEPARATOR@
|
||||
PYTHON = @PYTHON@
|
||||
PYTHONPATH = @PYTHONPATH@
|
||||
diff -Naur pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in
|
||||
--- pigx_bsseq-0.1.5/pigx-common/common/pigx-runner.in 2021-06-08 10:14:29.000000000 +0200
|
||||
+++ pigx_bsseq-0.1.5.patched/pigx-common/common/pigx-runner.in 2021-10-05 14:43:44.296161069 +0200
|
||||
@@ -375,7 +375,6 @@
|
||||
if path.exists(bin): shutil.rmtree(bin)
|
||||
os.makedirs(bin, exist_ok=True)
|
||||
os.symlink('@PANDOC@', path.join(bin, "pandoc"))
|
||||
- os.symlink('@PANDOC_CITEPROC@', path.join(bin, "pandoc-citeproc"))
|
||||
os.symlink('@RSCRIPT@', path.join(bin, "Rscript"))
|
||||
os.environ['PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
|
||||
os.environ['PIGX_PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
|
Loading…
Reference in a new issue