mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
gnu: racket: Update to 7.6.
* gnu/packages/scheme.scm (racket): Update to 7.6. [home-page]: Use HTTPS. * gnu/packages/patches/racket-store-checksum-override.patch: Adjust for 7.6.
This commit is contained in:
parent
45cf3c3019
commit
fb9832436a
2 changed files with 22 additions and 20 deletions
|
@ -11,26 +11,15 @@ See <https://debbugs.gnu.org/30680> for details.
|
|||
---
|
||||
--- a/collects/compiler/private/cm-minimal.rkt
|
||||
+++ b/collects/compiler/private/cm-minimal.rkt
|
||||
@@ -7,6 +7,7 @@
|
||||
@@ -6,6 +6,7 @@
|
||||
racket/list
|
||||
racket/path
|
||||
racket/promise
|
||||
+ racket/string
|
||||
file/sha1
|
||||
setup/collects
|
||||
setup/cross-system
|
||||
@@ -940,6 +941,10 @@
|
||||
#f
|
||||
(list src-hash recorded-hash)))
|
||||
|
||||
+(define (store-reference? path)
|
||||
+ (let ([store-prefix (or (getenv "NIX_STORE") "/gnu/store")])
|
||||
+ (string-prefix? (path->string path) store-prefix)))
|
||||
+
|
||||
(define (rkt->ss p)
|
||||
(if (path-has-extension? p #".rkt")
|
||||
(path-replace-extension p #".ss")
|
||||
@@ -1015,6 +1020,7 @@
|
||||
compiler/compilation-path
|
||||
@@ -268,7 +269,8 @@
|
||||
(trace-printf "newer src... ~a > ~a" path-time path-zo-time)
|
||||
(maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
|
||||
#:trying-sha1? sha1-only?)]
|
||||
|
@ -39,4 +28,15 @@ See <https://debbugs.gnu.org/30680> for details.
|
|||
+ (different-source-sha1-and-dep-recorded path deps))
|
||||
=> (lambda (difference)
|
||||
(trace-printf "different src hash ~a for ~a..." difference path)
|
||||
(maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
|
||||
(maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
|
||||
@@ -1012,5 +1014,9 @@
|
||||
#f
|
||||
(list src-hash recorded-hash)))
|
||||
|
||||
+(define (store-reference? path)
|
||||
+ (let ([store-prefix (or (getenv "NIX_STORE") "/gnu/store")])
|
||||
+ (string-prefix? (path->string path) store-prefix)))
|
||||
+
|
||||
;; Make sure `recompile-from` is machine-independent so that
|
||||
;; recompilation makes sense.
|
||||
;; The compilation lock must is held for the source of `recompile-from`.
|
|
@ -11,6 +11,7 @@
|
|||
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Adam Massmann <massmannak@gmail.com>
|
||||
;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
|
||||
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -31,7 +32,7 @@ (define-module (gnu packages scheme)
|
|||
#:use-module (gnu packages)
|
||||
#:use-module ((guix licenses)
|
||||
#:select (gpl2+ lgpl2.0+ lgpl2.1+ lgpl3+ asl2.0 bsd-3
|
||||
cc-by-sa4.0 non-copyleft))
|
||||
cc-by-sa4.0 non-copyleft expat))
|
||||
#:use-module (guix packages)
|
||||
#:use-module (guix download)
|
||||
#:use-module (guix git-download)
|
||||
|
@ -394,7 +395,7 @@ (define-public scheme48
|
|||
(define-public racket
|
||||
(package
|
||||
(name "racket")
|
||||
(version "7.3")
|
||||
(version "7.6")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (list (string-append "http://mirror.racket-lang.org/installers/"
|
||||
|
@ -404,7 +405,7 @@ (define-public racket
|
|||
version "/racket-" version "-src.tgz")))
|
||||
(sha256
|
||||
(base32
|
||||
"0h6072njhb87rkz4arijvahxgjzn8r14s4wns0ijvxm89bg136yl"))
|
||||
"0yagy7qrnz96gwafnj3whh2vs54788k1ci3vkm100h68gsw638b8"))
|
||||
(patches (search-patches
|
||||
"racket-store-checksum-override.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
|
@ -502,14 +503,15 @@ (define-public racket
|
|||
("sqlite" ,sqlite)
|
||||
("unixodbc" ,unixodbc)
|
||||
("libedit" ,libedit)))
|
||||
(home-page "http://racket-lang.org")
|
||||
(home-page "https://racket-lang.org")
|
||||
(synopsis "Implementation of Scheme and related languages")
|
||||
(description
|
||||
"Racket is an implementation of the Scheme programming language (R5RS and
|
||||
R6RS) and related languages, such as Typed Racket. It features a compiler and
|
||||
a virtual machine with just-in-time native compilation, as well as a large set
|
||||
of libraries.")
|
||||
(license lgpl2.0+)))
|
||||
;; https://download.racket-lang.org/license.html
|
||||
(license (list lgpl3+ asl2.0 expat))))
|
||||
|
||||
(define-public gambit-c
|
||||
(package
|
||||
|
|
Loading…
Reference in a new issue