mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-24 21:38:07 -05:00
gnu: mupen64plus-video-z64: Fix glew.h location.
* gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emulators.scm (mupen64plus-video-z64)[source]: Use it.
This commit is contained in:
parent
3b4f3ff7ee
commit
fdb61400a0
3 changed files with 39 additions and 1 deletions
|
@ -935,6 +935,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/mupdf-CVE-2018-6544.patch \
|
%D%/packages/patches/mupdf-CVE-2018-6544.patch \
|
||||||
%D%/packages/patches/mupdf-CVE-2018-1000051.patch \
|
%D%/packages/patches/mupdf-CVE-2018-1000051.patch \
|
||||||
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
|
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
|
||||||
|
%D%/packages/patches/mupen64plus-video-z64-glew-correct-path.patch \
|
||||||
%D%/packages/patches/mutt-store-references.patch \
|
%D%/packages/patches/mutt-store-references.patch \
|
||||||
%D%/packages/patches/net-tools-bitrot.patch \
|
%D%/packages/patches/net-tools-bitrot.patch \
|
||||||
%D%/packages/patches/netcdf-date-time.patch \
|
%D%/packages/patches/netcdf-date-time.patch \
|
||||||
|
|
|
@ -882,7 +882,8 @@ (define-public mupen64plus-video-z64
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1x7wsjs5gx2iwx20p4cjcbf696zsjlh31qxmghwv0ifrq8x58s1b"))))
|
(base32 "1x7wsjs5gx2iwx20p4cjcbf696zsjlh31qxmghwv0ifrq8x58s1b"))
|
||||||
|
(patches (search-patches "mupen64plus-video-z64-glew-correct-path.patch"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("pkg-config" ,pkg-config)
|
`(("pkg-config" ,pkg-config)
|
||||||
|
|
|
@ -0,0 +1,36 @@
|
||||||
|
From 21507b3600c616bca7049004eb518cf11f45f299 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Anthony J. Bentley" <anthony@cathet.us>
|
||||||
|
Date: Sun, 7 Jun 2015 02:41:28 -0600
|
||||||
|
Subject: [PATCH] Correct the path to the GLEW header.
|
||||||
|
|
||||||
|
---
|
||||||
|
src/glshader.cpp | 2 +-
|
||||||
|
src/rgl.h | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/glshader.cpp b/src/glshader.cpp
|
||||||
|
index 4729945..a8947ea 100644
|
||||||
|
--- a/src/glshader.cpp
|
||||||
|
+++ b/src/glshader.cpp
|
||||||
|
@@ -23,7 +23,7 @@
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <string.h>
|
||||||
|
#include "rgl_assert.h"
|
||||||
|
-#include <glew.h>
|
||||||
|
+#include <GL/glew.h>
|
||||||
|
#if defined(__MACOSX__)
|
||||||
|
#include <OpenGL/gl.h>
|
||||||
|
#include <OpenGL/glext.h>
|
||||||
|
diff --git a/src/rgl.h b/src/rgl.h
|
||||||
|
index c15f93f..1748406 100644
|
||||||
|
--- a/src/rgl.h
|
||||||
|
+++ b/src/rgl.h
|
||||||
|
@@ -26,7 +26,7 @@
|
||||||
|
#include "rgl_assert.h"
|
||||||
|
#include "rdp.h"
|
||||||
|
|
||||||
|
-#include <glew.h>
|
||||||
|
+#include <GL/glew.h>
|
||||||
|
#if defined(__MACOSX__)
|
||||||
|
#include <OpenGL/gl.h>
|
||||||
|
#elif defined(__MACOS__)
|
Loading…
Reference in a new issue