mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-23 21:17:11 -05:00
gnu: binutils: Update to 2.30.
* gnu/packages/patches/binutils-ld-new-dtags.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/base.scm (binutils): Update to 2.30. [source](patches): Remove obsolete patch. [arguments]: Add "--enable-new-dtags" in #:configure-flags.
This commit is contained in:
parent
8809a15389
commit
ff19532fd5
3 changed files with 9 additions and 21 deletions
|
@ -573,7 +573,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/bash-completion-directories.patch \
|
||||
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
|
||||
%D%/packages/patches/bcftools-regidx-unsigned-char.patch \
|
||||
%D%/packages/patches/binutils-ld-new-dtags.patch \
|
||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||
%D%/packages/patches/byobu-writable-status.patch \
|
||||
|
|
|
@ -415,16 +415,15 @@ (define-public gnu-make
|
|||
(define-public binutils
|
||||
(package
|
||||
(name "binutils")
|
||||
(version "2.28.1")
|
||||
(version "2.30")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/binutils/binutils-"
|
||||
version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"1sj234nd05cdgga1r36zalvvdkvpfbr12g5mir2n8i1dwsdrj939"))
|
||||
(patches (search-patches "binutils-ld-new-dtags.patch"
|
||||
"binutils-loongson-workaround.patch"))))
|
||||
"028cklfqaab24glva1ks2aqa1zxa6w6xmc8q34zs1sb7h22dxspg"))
|
||||
(patches (search-patches "binutils-loongson-workaround.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
|
||||
;; TODO: Add dependency on zlib + those for Gold.
|
||||
|
@ -433,6 +432,12 @@ (define-public binutils
|
|||
;; on GCC when bootstrapping.
|
||||
"LDFLAGS=-static-libgcc"
|
||||
|
||||
;; Turn on --enable-new-dtags by default to make the
|
||||
;; linker set RUNPATH instead of RPATH on binaries.
|
||||
;; This is important because RUNPATH can be overriden
|
||||
;; using LD_LIBRARY_PATH at runtime.
|
||||
"--enable-new-dtags"
|
||||
|
||||
;; Don't search under /usr/lib & co.
|
||||
"--with-lib-path=/no-ld-lib-path"
|
||||
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
Turn on --enable-new-dtags by default to make the linker set RUNPATH
|
||||
instead of RPATH on binaries. This is important because RUNPATH can
|
||||
be overriden using LD_LIBRARY_PATH at runtime.
|
||||
|
||||
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
|
||||
|
||||
--- binutils/ld/ldmain.c
|
||||
+++ binutils/ld/ldmain.c
|
||||
@@ -296,6 +296,7 @@ main (int argc, char **argv)
|
||||
|
||||
link_info.allow_undefined_version = TRUE;
|
||||
link_info.keep_memory = TRUE;
|
||||
+ link_info.new_dtags = TRUE;
|
||||
link_info.combreloc = TRUE;
|
||||
link_info.strip_discarded = TRUE;
|
||||
link_info.callbacks = &link_callbacks;
|
Loading…
Reference in a new issue