gnu: ldns: Update to 1.8.4.

* gnu/packages/dns.scm (ldns): Update to 1.8.4.
* gnu/packages/patches/ldns-drill-examples.patch: Adjust diff.

Change-Id: I52480085d45890b73278b2b529764482c591c9ac
This commit is contained in:
Tobias Geerinckx-Rice 2024-09-08 02:00:00 +02:00
parent ba5b975173
commit ff5d9ae0fa
No known key found for this signature in database
GPG key ID: 0DB0FF884F556D79
2 changed files with 44 additions and 47 deletions

View file

@ -144,7 +144,7 @@ (define-public cloudflare-cli
(define-public ldns
(package
(name "ldns")
(version "1.8.3")
(version "1.8.4")
(source
(origin
(method url-fetch)
@ -152,12 +152,11 @@ (define-public ldns
(string-append "https://www.nlnetlabs.nl/downloads/"
"ldns/ldns-" version ".tar.gz"))
(sha256
(base32 "0q3q1svyxpj2g5wdkfy1ndb14m9fzffwyskflpihfabb0g8jvxy3"))
(base32 "0is25vgf4qncvhwf0jy79gk8m6a5fxm4d5byfv6z3bxsjisr12w3"))
(patches
(search-patches
;; To create make-flag variables,
;; for splitting installation of drill and examples.
"ldns-drill-examples.patch"))))
;; This patch adds the Guix-specific {drill,examples}{bin,man}dir make
;; flags used below.
(search-patches "ldns-drill-examples.patch"))))
(build-system gnu-build-system)
(outputs '("out" "drill" "examples" "pyldns"))
(arguments

View file

@ -1,85 +1,83 @@
From 68916cd7ffb49ece9126d13ef984595595a156c4 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 29 Jul 2020 12:32:48 -0400
Subject: [PATCH] [PATCH]: Split installation of drill and examples.
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 15 Sep 2024 00:00:00 +0000
Subject: [PATCH]: Split installation of drill and examples.
---
Allow installing drill and examples into separate directory hierarchies.
Based on the original by Raghav Gururajan <raghavgururajan@disroot.org>
Makefile.in | 38 +++++++++++++++++++++-----------------
1 file changed, 21 insertions(+), 17 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 442067de..9d2d5f4d 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -14,6 +14,10 @@ libdir = @libdir@
diff -Naur a/Makefile.in b/Makefile.in
--- a/Makefile.in 2024-07-20 05:07:42.000000000 +0000
+++ b/Makefile.in 2024-09-15 00:00:00.000000000 +0000
@@ -14,6 +14,10 @@
includedir = @includedir@
sysconfdir = @sysconfdir@
doxygen = @doxygen@
+drillbindir = @drillbindir@
+drillmandir = @drillmandir@
+examplesbindir = @examplesbindir@
+examplesmandir = @examplesmandir@
+drillbindir = @drillbindir@
+drillmandir = @drillmandir@
+examplesbindir = @examplesbindir@
+examplesmandir = @examplesmandir@
pywrapdir = $(srcdir)/contrib/python
pyldnsxwrapdir = $(srcdir)/contrib/ldnsx
p5_dns_ldns_dir = $(srcdir)/contrib/DNS-LDNS
@@ -154,16 +158,16 @@ drill/drill.1: $(srcdir)/drill/drill.1.in
@@ -177,16 +181,16 @@
$(edit) $(srcdir)/drill/drill.1.in > drill/drill.1
install-drill: drill/drill drill/drill.1
- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
- $(LIBTOOL) --mode=install cp drill/drill $(DESTDIR)$(bindir)
- $(LIBTOOL) --mode=install cp drill/drill$(EXEEXT) $(DESTDIR)$(bindir)
- $(INSTALL) -m 644 drill/drill.1 $(DESTDIR)$(mandir)/man1/drill.1
+ $(INSTALL) -m 755 -d $(drillbindir)
+ $(INSTALL) -m 755 -d $(drillmandir)
+ $(INSTALL) -m 755 -d $(drillmandir)/man1
+ $(LIBTOOL) --mode=install cp drill/drill $(drillbindir)
+ $(INSTALL) -m 644 drill/drill.1 $(drillmandir)/man1/drill.1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(drillbindir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(drillmandir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(drillmandir)/man1
+ $(LIBTOOL) --mode=install cp drill/drill$(EXEEXT) $(DESTDIR)$(drillbindir)
+ $(INSTALL) -m 644 drill/drill.1 $(DESTDIR)$(drillmandir)/man1/drill.1
uninstall-drill:
- rm -f $(DESTDIR)$(bindir)/drill $(DESTDIR)$(mandir)/man1/drill.1
- rm -f $(DESTDIR)$(bindir)/drill$(EXEEXT) $(DESTDIR)$(mandir)/man1/drill.1
- test ! -d $(DESTDIR)$(mandir) || rmdir -p $(DESTDIR)$(mandir)/man1 || :;
- test ! -d $(DESTDIR)$(bindir) || rmdir -p $(DESTDIR)$(bindir) || : ;
+ rm -f $(drillbindir)/drill $(drillmandir)/man1/drill.1
+ test ! -d $(drillmandir) || rmdir -p $(drillmandir)/man1 || :;
+ test ! -d $(drillbindir) || rmdir -p $(drillbindir) || : ;
+ rm -f $(DESTDIR)$(drillbindir)/drill$(EXEEXT) $(DESTDIR)$(drillmandir)/man1/drill.1
+ test ! -d $(DESTDIR)$(drillmandir) || rmdir -p $(DESTDIR)$(drillmandir)/man1 || :;
+ test ! -d $(DESTDIR)$(drillbindir) || rmdir -p $(DESTDIR)$(drillbindir) || : ;
clean-drill:
$(LIBTOOL) --mode clean rm -f $(DRILL_LOBJS) drill/drill drill/drill.1
@@ -202,23 +206,23 @@ examples/ldns-verify-zone.1: $(srcdir)/examples/ldns-verify-zone.1.in
$(LIBTOOL) --mode clean rm -f $(DRILL_LOBJS) drill/drill$(EXEEXT) drill/drill.1
@@ -228,23 +232,23 @@
$(edit) $(srcdir)/examples/ldns-verify-zone.1.in > examples/ldns-verify-zone.1
install-examples: $(EXAMPLE_PROGS) $(TESTNS) $(LDNS_DPA) $(LDNS_DANE) $(EX_SSL_PROGS) examples/ldns-dane.1 examples/ldns-verify-zone.1
- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(examplesbindir)
+ $(INSTALL) -m 755 -d $(examplesmandir)
+ $(INSTALL) -m 755 -d $(examplesmandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(examplesbindir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(examplesmandir)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(examplesmandir)/man1
for p in $(EXAMPLE_PROGS) $(TESTNS) $(LDNS_DPA) $(LDNS_DANE) $(EX_SSL_PROGS) ; do \
- $(LIBTOOL) --mode=install cp $$p $(DESTDIR)$(bindir) ; \
+ $(LIBTOOL) --mode=install cp $$p $(examplesbindir) ; \
- $(LIBTOOL) --mode=install cp $$p$(EXEEXT) $(DESTDIR)$(bindir) ; \
+ $(LIBTOOL) --mode=install cp $$p$(EXEEXT) $(DESTDIR)$(examplesbindir) ; \
if test -f $$p.1 ; \
- then $(INSTALL) -m 644 $$p.1 $(DESTDIR)$(mandir)/man1 ; \
- else $(INSTALL) -m 644 $(srcdir)/$$p.1 $(DESTDIR)$(mandir)/man1 ; \
+ then $(INSTALL) -m 644 $$p.1 $(examplesmandir)/man1 ; \
+ else $(INSTALL) -m 644 $(srcdir)/$$p.1 $(examplesmandir)/man1 ; \
+ then $(INSTALL) -m 644 $$p.1 $(DESTDIR)$(examplesmandir)/man1 ; \
+ else $(INSTALL) -m 644 $(srcdir)/$$p.1 $(DESTDIR)$(examplesmandir)/man1 ; \
fi ; \
done
uninstall-examples:
for p in $(EX_PROGS_BASENM) ; do \
- rm -f $(DESTDIR)$(bindir)/$$p $(DESTDIR)$(mandir)/man1/$$p.1 ;\
+ rm -f $(examplesbindir)/$$p $(examplesmandir)/man1/$$p.1 ;\
- rm -f $(DESTDIR)$(bindir)/$$p$(EXEEXT) $(DESTDIR)$(mandir)/man1/$$p.1 ;\
+ rm -f $(DESTDIR)$(examplesbindir)/$$p$(EXEEXT) $(DESTDIR)$(examplesmandir)/man1/$$p.1 ;\
done
- test ! -d $(DESTDIR)$(mandir) || rmdir -p $(DESTDIR)$(mandir)/man1 || :;
- test ! -d $(DESTDIR)$(bindir) || rmdir -p $(DESTDIR)$(bindir) || : ;
+ test ! -d $(examplesmandir) || rmdir -p $(examplesmandir)/man1 || :;
+ test ! -d $(examplesbindir) || rmdir -p $(examplesbindir) || : ;
+ test ! -d $(DESTDIR)$(examplesmandir) || rmdir -p $(DESTDIR)$(examplesmandir)/man1 || :;
+ test ! -d $(DESTDIR)$(examplesbindir) || rmdir -p $(DESTDIR)$(examplesbindir) || : ;
clean-examples:
$(LIBTOOL) --mode clean rm -f $(EXAMPLE_PROGS)
--
2.27.0
for p in $(EX_PROGS_BASENM) ; do \