gnu: python-2: Update to 2.7.10.

* gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch,
  gnu/packages/patches/python-libffi-mips-n32-fix.patch: Remove files.
* gnu-system.am (dist_patch_DATA): Remove them.
* gnu/packages/python.scm (python-2): Update to 2.7.10.  Remove patches.
  Update comment showing test failures.
This commit is contained in:
Eric Dvorsak 2015-08-02 19:27:24 +02:00 committed by Mark H Weaver
parent 9f6509c655
commit ff6f33cf80
4 changed files with 42 additions and 84 deletions

View file

@ -595,9 +595,7 @@ dist_patch_DATA = \
gnu/packages/patches/pyqt-configure.patch \
gnu/packages/patches/python-disable-ssl-test.patch \
gnu/packages/patches/python-fix-tests.patch \
gnu/packages/patches/python-libffi-mips-n32-fix.patch \
gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch \
gnu/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
gnu/packages/patches/qemu-CVE-2015-3209.patch \
gnu/packages/patches/qemu-CVE-2015-3456.patch \

View file

@ -1,21 +0,0 @@
Fix handling of uint32_t arguments on the MIPS N32 ABI.
Patch by Mark H Weaver <mhw@netris.org>.
--- Modules/_ctypes/libffi/src/mips/ffi.c.orig 2013-03-16 07:19:39.000000000 -0400
+++ Modules/_ctypes/libffi/src/mips/ffi.c 2013-10-22 01:11:03.111985247 -0400
@@ -170,7 +170,14 @@
break;
case FFI_TYPE_UINT32:
+#ifdef FFI_MIPS_N32
+ /* The N32 ABI requires that 32-bit integers
+ be sign-extended to 64-bits, regardless of
+ whether they are signed or unsigned. */
+ *(ffi_arg *)argp = *(SINT32 *)(* p_argv);
+#else
*(ffi_arg *)argp = *(UINT32 *)(* p_argv);
+#endif
break;
/* This can only happen with 64bit slots. */

View file

@ -1,15 +0,0 @@
From resolution of upstream python issue #20901: http://bugs.python.org/issue20901
diff --git a/Lib/sqlite3/test/hooks.py b/Lib/sqlite3/test/hooks.py
--- Lib/sqlite3/test/hooks.py
+++ Lib/sqlite3/test/hooks.py
@@ -162,7 +162,7 @@ class ProgressTests(unittest.TestCase):
create table bar (a, b)
""")
second_count = len(progress_calls)
- self.assertTrue(first_count > second_count)
+ self.assertGreaterEqual(first_count, second_count)
def CheckCancelOperation(self):
"""

View file

@ -74,62 +74,58 @@ (define-module (gnu packages python)
(define-public python-2
(package
(name "python")
(version "2.7.6")
(version "2.7.10")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (list (search-patch "python-libffi-mips-n32-fix.patch")
(search-patch "python2-sqlite-3.8.4-test-fix.patch")))
(patch-flags '("-p0"))
(sha256
(base32
"18gnpyh071dxa0rv3silrz92jw9qpblswzwv4gzqcwxzz20qxmhz"))))
"1h7zbrf9pkj29hlm18b10548ch9757f75m64l47sy75rh43p7lqw"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
;; 258 tests OK.
;; 103 tests failed:
;; test_bz2 test_distutils test_file test_file2k test_popen2
;; test_shutil test_signal test_site test_slice test_smtplib
;; test_smtpnet test_socket test_socketserver test_softspace
;; test_sort test_sqlite test_ssl test_startfile test_str
;; test_strftime test_string test_stringprep test_strop test_strptime
;; test_strtod test_struct test_structmembers test_structseq
;; test_subprocess test_sunaudiodev test_sundry test_symtable
;; test_syntax test_sys test_sys_setprofile test_sys_settrace
;; test_sysconfig test_tarfile test_tcl test_telnetlib test_tempfile
;; test_textwrap test_thread test_threaded_import
;; test_threadedtempfile test_threading test_threading_local
;; test_threadsignals test_time test_timeout test_tk test_tokenize
;; test_tools test_trace test_traceback test_transformer
;; test_ttk_guionly test_ttk_textonly test_tuple test_typechecks
;; test_ucn test_unary test_undocumented_details test_unicode
;; test_unicode_file test_unicodedata test_univnewlines
;; test_univnewlines2k test_unpack test_urllib test_urllib2
;; test_urllib2_localnet test_urllib2net test_urllibnet test_urlparse
;; test_userdict test_userlist test_userstring test_uu test_uuid
;; test_wait3 test_wait4 test_warnings test_wave test_weakref
;; test_weakset test_whichdb test_winreg test_winsound test_with
;; test_wsgiref test_xdrlib test_xml_etree test_xml_etree_c
;; test_xmllib test_xmlrpc test_xpickle test_xrange test_zipfile
;; test_zipfile64 test_zipimport test_zipimport_support test_zlib
;; 31 tests skipped:
;; test_aepack test_al test_applesingle test_ascii_formatd test_bsddb
;; test_bsddb185 test_bsddb3 test_cd test_cl test_codecmaps_cn
;; test_codecmaps_hk test_codecmaps_jp test_codecmaps_kr
;; test_codecmaps_tw test_ctypes test_curses test_dl test_gdb test_gl
;; test_imageop test_imgfile test_ioctl test_kqueue
;; test_linuxaudiodev test_macos test_macostools test_msilib
;; test_multiprocessing test_ossaudiodev test_pep277
;; test_scriptpackages
;; 7 skips unexpected on linux2:
;; test_ascii_formatd test_bsddb test_bsddb3 test_ctypes test_gdb
;; test_ioctl test_multiprocessing
;; One of the typical errors:
;; test_unicode
;; test test_unicode crashed -- <type 'exceptions.OSError'>: [Errno 2] No such file or directory
;; 268 tests OK.
;; 103 tests failed:
;; test_distutils test_shutil test_signal test_site test_slice
;; test_smtplib test_smtpnet test_socket test_socketserver
;; test_softspace test_sort test_spwd test_sqlite test_ssl
;; test_startfile test_stat test_str test_strftime test_string
;; test_stringprep test_strop test_strptime test_strtod test_struct
;; test_structmembers test_structseq test_subprocess test_sunau
;; test_sunaudiodev test_sundry test_symtable test_syntax test_sys
;; test_sys_setprofile test_sys_settrace test_sysconfig test_tarfile
;; test_tcl test_telnetlib test_tempfile test_textwrap test_thread
;; test_threaded_import test_threadedtempfile test_threading
;; test_threading_local test_threadsignals test_time test_timeit
;; test_timeout test_tk test_tokenize test_tools test_trace
;; test_traceback test_transformer test_ttk_guionly test_ttk_textonly
;; test_tuple test_typechecks test_ucn test_unary
;; test_undocumented_details test_unicode test_unicode_file
;; test_unicodedata test_univnewlines test_univnewlines2k test_unpack
;; test_urllib test_urllib2 test_urllib2_localnet test_urllib2net
;; test_urllibnet test_urlparse test_userdict test_userlist
;; test_userstring test_uu test_uuid test_wait3 test_wait4
;; test_warnings test_wave test_weakref test_weakset test_whichdb
;; test_winreg test_winsound test_with test_wsgiref test_xdrlib
;; test_xml_etree test_xml_etree_c test_xmllib test_xmlrpc
;; test_xpickle test_xrange test_zipfile test_zipfile64
;; test_zipimport test_zipimport_support test_zlib
;; 30 tests skipped:
;; test_aepack test_al test_applesingle test_bsddb test_bsddb185
;; test_bsddb3 test_cd test_cl test_codecmaps_cn test_codecmaps_hk
;; test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_crypt
;; test_curses test_dl test_gdb test_gl test_idle test_imageop
;; test_imgfile test_ioctl test_kqueue test_linuxaudiodev test_macos
;; test_macostools test_msilib test_nis test_ossaudiodev
;; test_scriptpackages
;; 6 skips unexpected on linux2:
;; test_bsddb test_bsddb3 test_crypt test_gdb test_idle test_ioctl
;; One of the typical errors:
;; test_unicode
;; test test_unicode crashed -- <type 'exceptions.OSError'>: [Errno 2] No
;; such file or directory
#:test-target "test"
#:configure-flags
(let ((bz2 (assoc-ref %build-inputs "bzip2"))