mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
23e2ff223c
* gnu/packages/apr.scm (apr): When building for powerpc-linux add a phase to apply a patch. [native-inputs]: When building for powerpc-linux add a patch. * gnu/packages/patches/apr-fix-atomics.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
49 lines
1.7 KiB
Diff
49 lines
1.7 KiB
Diff
This patch is taken from Debian, using Debian version 1.7.0-8.
|
|
A new patch will be needed when apr is updated.
|
|
|
|
# quick and dirty fix for FTBFS on mipsel
|
|
# There should be a proper configure check, see
|
|
# https://bz.apache.org/bugzilla/show_bug.cgi?id=63566
|
|
Index: apr-1.7.0/include/arch/unix/apr_arch_atomic.h
|
|
===================================================================
|
|
--- apr-1.7.0.orig/include/arch/unix/apr_arch_atomic.h
|
|
+++ apr-1.7.0/include/arch/unix/apr_arch_atomic.h
|
|
@@ -26,6 +26,9 @@
|
|
/* noop */
|
|
#elif HAVE_ATOMIC_BUILTINS
|
|
# define USE_ATOMICS_BUILTINS
|
|
+# if (__INTPTR_WIDTH__ == 32) && ( defined(__MIPSEL__) || defined(__powerpc__) ) || defined(__m68k__) || defined(__sh__)
|
|
+# define NEED_ATOMICS_GENERIC64
|
|
+# endif
|
|
#elif defined(SOLARIS2) && SOLARIS2 >= 10
|
|
# define USE_ATOMICS_SOLARIS
|
|
# define NEED_ATOMICS_GENERIC64
|
|
Index: apr-1.7.0/atomic/unix/builtins64.c
|
|
===================================================================
|
|
--- apr-1.7.0.orig/atomic/unix/builtins64.c
|
|
+++ apr-1.7.0/atomic/unix/builtins64.c
|
|
@@ -16,7 +16,7 @@
|
|
|
|
#include "apr_arch_atomic.h"
|
|
|
|
-#ifdef USE_ATOMICS_BUILTINS
|
|
+#if defined(USE_ATOMICS_BUILTINS) && ! defined(NEED_ATOMICS_GENERIC64)
|
|
|
|
APR_DECLARE(apr_uint64_t) apr_atomic_read64(volatile apr_uint64_t *mem)
|
|
{
|
|
Index: apr-1.7.0/atomic/unix/builtins.c
|
|
===================================================================
|
|
--- apr-1.7.0.orig/atomic/unix/builtins.c
|
|
+++ apr-1.7.0/atomic/unix/builtins.c
|
|
@@ -20,7 +20,11 @@
|
|
|
|
APR_DECLARE(apr_status_t) apr_atomic_init(apr_pool_t *p)
|
|
{
|
|
+#if defined (NEED_ATOMICS_GENERIC64)
|
|
+ return apr__atomic_generic64_init(p);
|
|
+#else
|
|
return APR_SUCCESS;
|
|
+#endif
|
|
}
|
|
|
|
APR_DECLARE(apr_uint32_t) apr_atomic_read32(volatile apr_uint32_t *mem)
|