mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
04496dc574
* gnu/packages/dbm.scm (bdb-4.8, bdb-5.3)[source]: Apply patch. * gnu/packages/patches/bdb-5.3-atomics-on-gcc-9.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new file. Signed-off-by: Marius Bakke <marius@gnu.org>
22 lines
850 B
Diff
22 lines
850 B
Diff
Patch borrowed from Arch Linux. Allows compiling bdb 5.3 and earlier with GCC newer than 7.
|
|
|
|
--- src/dbinc/atomic.h 2013-03-12 14:07:22.000000000 -0400
|
|
+++ src/dbinc/atomic.h.change 2013-03-12 14:06:35.000000000 -0400
|
|
@@ -144,7 +144,7 @@
|
|
#define atomic_inc(env, p) __atomic_inc(p)
|
|
#define atomic_dec(env, p) __atomic_dec(p)
|
|
#define atomic_compare_exchange(env, p, o, n) \
|
|
- __atomic_compare_exchange((p), (o), (n))
|
|
+ __atomic_compare_exchange_db((p), (o), (n))
|
|
static inline int __atomic_inc(db_atomic_t *p)
|
|
{
|
|
int temp;
|
|
@@ -176,7 +176,7 @@
|
|
* http://gcc.gnu.org/onlinedocs/gcc-4.1.0/gcc/Atomic-Builtins.html
|
|
* which configure could be changed to use.
|
|
*/
|
|
-static inline int __atomic_compare_exchange(
|
|
+static inline int __atomic_compare_exchange_db(
|
|
db_atomic_t *p, atomic_value_t oldval, atomic_value_t newval)
|
|
{
|
|
atomic_value_t was;
|