mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 07:26:13 -05:00
1afd98dc93
* gnu/packages/wm.scm (date): New variable. * gnu/packages/patches/date-output-pkg-config-files.patch: New file. * gnu/local.mk: Add patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
60 lines
1.9 KiB
Diff
60 lines
1.9 KiB
Diff
From e56b2dce7e89a92e1b9b35caa13b3e938c4cedea Mon Sep 17 00:00:00 2001
|
|
From: Cole Mickens <cole.mickens@gmail.com>
|
|
Date: Sun, 26 Jan 2020 01:27:08 -0800
|
|
Subject: [PATCH] CMakeLists.txt: output date.pc for pkg-config
|
|
|
|
---
|
|
CMakeLists.txt | 15 +++++++++++++++
|
|
date.pc.in | 10 ++++++++++
|
|
2 files changed, 25 insertions(+)
|
|
create mode 100644 date.pc.in
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index f30c473..fe778e8 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -128,6 +128,15 @@ if( BUILD_TZ_LIB )
|
|
endif( )
|
|
endif( )
|
|
|
|
+if ( BUILD_TZ_LIB )
|
|
+ # Cflags: -I${includedir} @TZ_COMPILE_DEFINITIONS@
|
|
+ set( TZ_COMPILE_DEFINITIONS "$<IF:$<TARGET_EXISTS:tz>,-D$<JOIN:$<TARGET_PROPERTY:tz,INTERFACE_COMPILE_DEFINITIONS>, -D>,>" )
|
|
+ configure_file(date.pc.in date.pc.cf @ONLY)
|
|
+ file( GENERATE OUTPUT "${CMAKE_CURRENT_BINARY_DIR}/date.pc"
|
|
+ INPUT "${CMAKE_CURRENT_BINARY_DIR}/date.pc.cf" )
|
|
+
|
|
+endif( )
|
|
+
|
|
#[===================================================================[
|
|
installation
|
|
#]===================================================================]
|
|
@@ -171,6 +180,12 @@ install (
|
|
FILES cmake/dateConfig.cmake "${version_config}"
|
|
DESTINATION ${CONFIG_LOC})
|
|
|
|
+if ( BUILD_TZ_LIB )
|
|
+ install(
|
|
+ FILES ${CMAKE_BINARY_DIR}/date.pc
|
|
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
|
|
+endif( )
|
|
+
|
|
#[===================================================================[
|
|
testing
|
|
#]===================================================================]
|
|
diff --git a/date.pc.in b/date.pc.in
|
|
new file mode 100644
|
|
index 0000000..b9c4623
|
|
--- /dev/null
|
|
+++ b/date.pc.in
|
|
@@ -0,0 +1,10 @@
|
|
+prefix=@CMAKE_INSTALL_PREFIX@
|
|
+exec_prefix=@CMAKE_INSTALL_BINDIR@
|
|
+libdir=@CMAKE_INSTALL_LIB@
|
|
+includedir=@CMAKE_INSTALL_INCLUDE@
|
|
+
|
|
+Name: date
|
|
+Description: A date and time library based on the C++11/14/17 <chrono> header
|
|
+Version: @PACKAGE_VERSION@
|
|
+Libs: -L${libdir} -ltz
|
|
+Cflags: -I${includedir} @TZ_COMPILE_DEFINITIONS@
|